Sign-in / Sign-up
Your question

Windows 7 SP1: Hard Drives Disappear after Sleep Resume

Tags:
  • Windows 7
  • Hard Drives
  • Seagate
Last response: in Windows 7
June 18, 2011 8:30:55 PM

Found an old closed thread that gave http://support.microsoft.com/kb/977178 as the solution to the problem - but that hotfix won't install to an SP1 machine. Looking for a solution for Windows 7 SP1. The drive in question is one of the newer Seagate BarracudaLP drives. Seagate was no help, and MS want's me to pay them $200+ to even be able to ask them about it (with no actual help guaranteed for that money).

More about : windows sp1 hard drives disappear sleep resume

a c 610 $ Windows 7
June 19, 2011 12:03:04 AM

The Power settings in Windows 7 is not automatically set for maximum performance. By default the power plan in Windows 7 is set for a balanced performance with energy consumption on hardware. So you may not get the optimal performance from windows 7 if this is the case. So we need to change the power plan to High Performance Mode.

Double click the Power Options in the Control panel.
Click the down arrow showing Show Additional Plans to see the High Performance power plan
Now just activate the High Performance plan and that's it.
Go for the advanced power settings.
Go to Hard disk, then to Turn off hard disk after and set it to Never.
m
0
l
June 19, 2011 12:42:41 AM

I'll try that, but the issue is with sleep resume of the SYSTEM not of the drive. Don't see how setting the drive to never go to sleep will help, since everything shuts down when the system goes to sleep.

System has 3 drives, and only the 2TB BarracudaLP has the issue. The 1TB WD Green drive does not. Primary system drive is an SSD, so no 'spin up' time there.
m
0
l
December 8, 2014 7:53:58 AM

I had the same problem, and the hotfix wouldn't install for me, either. Setting hard drives to never shut down really defeats the purpose of sleep mode, so that wasn't really an option for me (and I don't think it worked, anyway). I ended up installing custom (but certified) SATA drivers for my NVidia NForce4 chipset. That did the trick. NVidia never released Windows 7 drivers themselves, and the default Windows 7 drivers are part of the problem, so I had to go here for drivers:

http://www.win-raid.com/t15f37-NVIDIA-Optimized-nForce-...

The guy who put those drivers together deserves some sort of award, or at least a beer.
m
0
l