Sign in with
Sign up | Sign in
Your question

unrecognised hard drives - Need help??

Last response: in Storage
Share
December 8, 2006 1:55:51 AM

Hi all,
Hoping some of you can help me out there. I apologies if I've posted this in the wrong area of the forum - not sure which was most appropriate.
I was running my system in a raid 1 (mirroring). The raid monitor which shows up a message during the sustem boot, advised me that the raid had degraded. At the time I couldn't be bothered to fix it straight away. Anyway I decided today that I would fix it and here starts my problem.
I deleted the raid and cleared the disks through the raid managing program. I then created a new raid. However when I have gone to reinstall the operating system onto the raid WinXP says I've got no hard disks installed.
The bios recognises the drives no problem, but it seems that the O/S won't. I've tried deleting and recreating the raid, deleting the raid and using them as two indidual drives etc. I've also formatted another hard drive (IDE) and installed WinXP on that, which worked fine. In the hope that I could get into WinXP and delete any paritions etc. on the drives and redo it. Again the O/s is fine with the other drive that wasn't in the raid, but won't recognise the 2 drives that where in the raid.
I've built quite a few systems before, but this is my first time using a raid.
I need help to be able to clean these 2 hard disks so that I can use them again.

Cheers
CC

system specs are as follows:

Asus A8N32 deluxe nforce 4
AMD x2 4200
OCR platinum 2gb
XFX Geforce 7800GT
Creative X-fi
2 Hitachi Deskstar T7K250
2 optical drives

More about : unrecognised hard drives

December 8, 2006 2:00:22 AM

Did you use the F6 feature on the Windows Install to load the RAID drivers, if not thats why Windows cannot see the HDDs.
December 8, 2006 2:08:46 AM

Watch the bottom of the Windows Installation screen when you see Press F6 to load RAID drivers press F6, it won't ask for the drivers right then but when the installation gets to the point it needs them it will ask for them and you'll have to have them on a Floppy Disk [either from your M/B installation CD, or downloaded from your M/B manufacturers website and put on a floppy disk], and install them through the Floppy drive, since you had a previous RAID setup, you should have the drivers already and probably just forgot about loading them, it happens to all of us sooner or later.
Related resources
December 8, 2006 3:55:37 AM

Thanks for replying.
Its interesting the point you make. The reason I say that is that I have known from previously setting up many machines that I have noted the message in the windows installer about having to press F6 to set up the raid. When I orginally setup my machine I specifically remember finding it odd that it worked without me having to press F6 to make it recognise the raid. It just treated it like another drive and allowed me to install straight onto it.
The other thing I am having difficulty with is that windows doesn't recognise the individual drives when they are not in the raid. As I say I've installed windows now on an extra 3rd drive and once loaded up. windows doesn't see the other 2 drives when they are in the raid or when their not.
Hence why I've been puzzled.
Cheers for the help though, and any further thoughts would be most appricated.
CC
December 8, 2006 5:46:55 AM

Do the show up in the device manager? Maybe they are just not formatted? Also remember to go into the raid menu at boot (probably F4 or something - it will say onscreen) to specify what each drive is doing (alone or part of a set).

Jo
December 8, 2006 10:18:21 AM

just to clarify this is a hardware raid rather than a software raid. If that makes much difference.
CC
December 8, 2006 11:03:11 AM

Get your RAID drivers on a stiffy. When prompted, hit F6 (during Windows installation)

Then insert stiffy with drivers.. There you go, that should work ;) 
December 8, 2006 6:07:23 PM

Quote:

...the most common cause of hdd's not bieng recognized is user error. :wink:

Yeah I know. And it may well be true in my case. hence why I'm asking for pointers. normally I figure out what I've done wrong. but raids are new to me and I'm still learning. :-)
Cheers for the help though guys.
CC
December 9, 2006 12:54:51 AM

It looks like its all ok. I've sorted it all out. The only downside is, I'm not exactly sure which of my actions solved the problem..... :( 
This time I've had to use the F6 option to get windows to recognise the raid. Which I'm supprised about, as I didn't have to do that last time. I know this for a fact as I never had a disk with any drivers for the raid on them.
But Its all sorted ( I think) well atleast for now anyway.
Many thanks for all your help.
Cheers
CC
!