Bad Memory or Bad Motheboard

I have recently build a new system and I decided to run a memtest. My memory is corsair xms2 2x1gb ddr2 675. My mobo is a gigabyte 965p-s3. So it made it through most of the tests and at test #7 it just starts throwing errors like crazy. I am thinking that the memory is bad and i am going to have to rma it. But then i decide to take one stick out and just run in single channel and see what happens. The memtest runs through a couple passes and not a single error. So i take that stick out and throw the other one in. Same thing, couple of passes and no errors. So now i am wondering what is going on. So i put each individual stick in each individual slot and run the test(eight different tests) and each one runs perfectly without any errors. So by this point i am starting to think that it is not a memory issue. I put both sticks back in and run a test and it runs just fine, no errors. Then i run it again, and this time at test #7 there are a bunch of errors again. I am pretty bummed on the whole situation.

So at this point i am just really confused. It seems like the memory is good, but i dont really know. I am just wondering if anybody might know of a fix or if somebody can definitively diagnose the problem. Appreciate any advice.

Thanks.
26 answers Last reply
More about memory motheboard
  1. check your ram voltage in the bios . i have the xms2 800 cas 4. make sure it's set to atleast 1.9 volts.
  2. yeah, i did set the the voltage to 1.9 and i manually set timings to 4-4-4-12. I guess i could try to set it to 2.0v. Not sure if that would make any difference.
  3. i'm not sure what the max safe voltage on your ram is but 2.1v is my max recommended although i had it up to 2.4 trying to get my machine stable with a higher oc. in your position i would probably go as high as 2.1. is your system oc'd or stock
  4. my system is stock right now. I am just thinking its some kind of compatibility issue. this sucks!
  5. does your sys run fine aside from memtest?

    if so dont worry about it.
  6. i'd try the ram at 2.0v and see if it's stable. that seems to be the most common problem in the newegg reviews
  7. the system runs ok i guess. but there are definite problems. when i have been installing certain programs they cant finish because of errors when i know that there should be no problem.
  8. ok then. it may be a bad stick of memory?
  9. I'd try the Corsair support forum with this. Getting any errors in memtest86+ means there's some sort of problem.
  10. can the power supplies play as a factor in here also?? maybe the power supplies itself is unstable and causing the RAM to run into errors? I'm temporary using the stock 420W PSU with 2x14A that came with my case.

    someone help me out here too, I have almost the same problem as ssbsts except that I have a GA-M55Sli-S4 and Corsair CM2X512A-6400

    I didn't know which one was causing the problem so I RMAed the mobo, and now, it's not the mobo.

    :(
  11. Have you tried running both modules in SINGLE CHANNEL mode? It would rule-out the possibility of a faulty handling of cual channel by the memory controller.

    I would also suggest you try setting the RAM voltage to 0.1V over the module's requirement. Maybe the voltage isn't as regular as it should be and under load it drops under a specific threshold. I had the exact same problem as you have with an "old" Asus A7N8X-Dlx and 2x Ballistix modules and I had to set the RAM voltage to 1.9 instead of the rated 1.8 to make it work stable. Before that is would always fail test #7 of memtest86 ... The problem might therfore be the motherboard and not the RAM modules.

    Try it, it might be much less of a pain to have it work like that than RMAing either the modules or the mobo.
  12. My firned had same problem...

    We think its because one of the ram slots is very close to a hot CPU and North bridge while the other stick of ram is far away from the heat (dual chanel mode)

    we did exactly the same as you (single chane one stick at a time works fine).

    We put a fan no top of the ram modules to cool them both down, memtest runs without any errors.

    I find if you oc and upvolt the memory as it getts hotter you get more errors. same applies if you stick your ram too close to heat sources with bad airflow in the case.
  13. OP here. Ok, good news, i think. So i decide to put both sticks, but in a single channel config. As far as i understand, and according to the mobo's manual, to enable dual channel the memory needs to be in the same colored sockets. So i put both sticks in, but in the different colored sockets(sockets 1 and 4) and boot up. For some reason, it still says "dual channel interleaved" at the post screen. whatever. I run memtest and i am currently on the 4th pass and no errors. I hope that it will stay clean of errors, but my question is can my memory really be in dual channel mode when the sticks are in different colored sockets? Or does that not matter? I am just going off what the manual says.

    Thanks for all the tips and advice.

    I also bumped the voltage up to 0.1 over the recommended setting.
  14. I know this has nothing to do with the memory but here is a screenshot of my computer while running orthos. I have speedfan running as well and the distribution of the power on the dual rails is pretty much non-existent. Is that normal? Here is the screenshot
    Could that by any chance cause me problems?

    Thanks again
  15. I've been having the same types of problems. I recently purchased the following new hardware:

    Gigabyte P965-S3
    OCZ Platinum DDR2-800 512x2 (1GB Total Ram)
    E6300 Core 2 Duo 1.86GHZ
    ATI Radeon 800XL PCI-E (Got it cheap)

    So since putting all this new hardware in, I'm getting memory errors, I notice the system isn't installing applications as it should where it gets to say 90% of the way and then kicks out an error saying it couldn't access a .cab file. I thought okay, maybe just that one program but it has occured for others as well.

    Also noticing random reboots... so here's what I did. Called the retailer where I purchased and had both the motherboard and ram swapped for new ones. Problems continue to persist.

    In the end, I believe the cause is the power supply. It's an Antec 350W powersupply with single rail and the system is just acting way too strange for it to be anything else. I even formatted the drive to start fresh and still same issues.

    I should have my new PSU tomorrow but I highly suggest you take a look at that. Unless you're getting 24-26A on your 12V+, you may not have sufficient power depending on what you're running.

    Feel free to email me to discuss... pjstyles@cogeco.ca

    PJStyles
  16. I had the same exact problem..I had 2 1 gig simms..and when they were both in ..I had the same problems as you..games would lock up..windows would crash..Installs would get screwed up..I pulled one simm out and no problems..then I tried the other slot,problems..I believe it is a faulty memory controller on the motherboard..try it and let me know.
  17. At this point my personal belief is that it is either the motherboard or the psu. For some reason i just dont think its the ram. I know a lot of you agree with that. I kind of wish it was, cause that would be the easiest thing to rma. Anyway, today i am going to test my ram in another system and also use some of my friends ram in my system that way i can test both the memory and the mobo and maybe come up with some sort of conclusion.
    I am definitely not getting 24-26A on the 12v so that is probably a problem. Thanks for all the helpful posts.

    Also, i have just recently noticed that when i turn on the computer it powers on, then after about a second it powers off then almost immediately powers on again. Probably is something to do with PSU. Anyone have any experience with that?
  18. When you took out one stick and put in the other, did you put it back in the same slot that you removed the prior stick from? What happens if you put the same stick into each mem slot in turn? Also, are the two sticks from the same batch or different batches? I have seen where RAM with the same CL from different batches do not play well together so you could be seeing an issue there.
  19. Well i have tested each stick of ram in each slot. 2 sticks x 4 slots = 8 tests and they all checked out fine. I took one stick and tested it in slot 1 then 2 and so forth, then took stick two and tested it in slot 1 then 2 and so forth. They all ran without any errors in memtest.

    It is a matched pair from corsair, its a 2gb dual channel kit, so i would assume that it they are from the same batch.
  20. Quote:
    ... have speedfan running as well and the distribution of the power on the dual rails is pretty much non-existent. ...

    Not sure exactly what you mean by this, since none of the programs on the screen show voltages from both +12V rails. If you mean the VCore1 and VCore2, those are NOT different CPU core voltages; VCore2 is probably the DIMM voltage.
  21. Quote:
    ...
    I am definitely not getting 24-26A on the 12v so that is probably a problem. Thanks for all the helpful posts.

    Also, i have just recently noticed that when i turn on the computer it powers on, then after about a second it powers off then almost immediately powers on again. Probably is something to do with PSU. ...

    Yep, sounds like the PS. What model number PS do you have? Please also list the model number of ALL other components, such as video card(s), CPU cooler, drives, etc.
  22. I'm having a similar problem but it's more painful. i can't even load windows with two memory sticks. it just crashes and restarts. i couldn't even install windows with both sticks installed. i also have the corsair xms2, but 512 instead of 1 gb. i tried all configurations. both sticks seem fine when by themselves, regardless of which slot they're in. if i put in the other, my system crashes.

    i'm using this motherboard:

    ASUS M2N-E Socket AM2 NVIDIA nForce 570 Ultra MCP ATX AMD Motherboard
    http://www.newegg.com/Product/Product.asp?Item=N82E16813131022
  23. Okay, I tested the memory in another system and it still had a ton of erros in memtest. However, i borrowed some other memory and ran it in my system in dual channel and it checked out just fine, so i am definitely going to rma the memory. Bummer, but i am glad to have at least isolated a problem.

    To Mondoman, i will admit that i am pretty much a noob. I looked at speedfan and thought that it looked a bit off. From your perspective, did the screenshot indicate anything wrong to you? If it looks normal then i wont really worry about it. I am just looking for advice on that one. I just looked at it and assumed that the +12v and the -12v should be approximately the same, but that was purely an assumption.

    Intel Core 2 Duo E6300 Conroe 1.86GHz LGA 775 Processor Model BX80557E6300
    CHAINTECH VGA256C-SE73GT GeForce 7300GT 256MB GDDR2 PCI Express x16 Video Card
    XCLIO GOODPOWER 500W ATX 500W Power Supply
    CORSAIR XMS2 2GB 240-Pin DDR2 SDRAM PC2 5400 Dual Channel Kit Desktop Memory Model TWIN2X2048-5400c4
    GIGABYTE GA-965P-S3 Socket T (LGA 775) Intel P965 Express ATX Intel Motherboard
    Western Digital Caviar SE WD1600JS 160GB 7200 RPM SATA 3.0Gb/s Hard Drive

    Thanks again
  24. Hey SSBSTS,

    Noticed your post about memory errors on Test #7 in memtest86+. Having the exact same issue even though each memory module tests out fine individually.

    What solution did you come up with? Did you go with a different name branch memory or try something else? I can't for the life of me figure this out...

    Please email me at pjstyles@cogeco.ca as I think we are having the identical problem!!! Thanks...

    P.S - originally thought it was the PSU but it's not... I'm really stuck and it's pissing me off!!!

    PJStyles
  25. got a new set or memory and now my system is rock solid. thanks for all the help!
  26. Well... as per ssbsts... found the problem... the ram I had purchased is incompatable with all Core 2 Duo chipset mobo's ie: P965 etc... It was the OCZ Platinum XTC that caused the issue. I had to get Revision 2 of these ram modules by OCZ and that solved all of my problems...


    Thanks to SSBSTS!

    PJStyles
Ask a new question

Read More

Memory Single Channel