Sign in with
Sign up | Sign in
Your question

Managing Files on the C Drive in XP

Last response: in Windows XP
Share
Anonymous
January 12, 2005 12:51:52 AM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

Hi all
I have initiated a Program Files Folder which is to receive the builds of a
DOT net system I am building. It also contain the main database. Although I
was initially able to put early file versions in there, the whole folder now
seems completely locked against all change and no matter how many times I
indicate it is sharable and writable it always reverts to Read Only. I need
to update the Access Database formats

I have looked through the Local Security Policies and can see nothing about
Locking CDrive Changes if Used by the OS which is the sort of message that
crops up in intellisense when messing with the Program Files Folder. What
can I do to get round this



Thanks in anticipation

Roger Stenson

More about : managing files drive

Anonymous
January 12, 2005 12:51:53 AM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

All folders on XP are read only but it's a system attribute and not the
source of the issue.

You might need to take ownership, see below:
Note, file ownership and permissions supersede administrator rights. How
you resolve it depends upon which version of XP you are running.

XP-Home

Unfortunately, XP Home using NTFS is essentially hard wired for "Simple File
Sharing" at system level.

However, you can set XP Home permissions in Safe Mode. Reboot, and start
hitting F8, a menu should eventually appear and one of the
options is Safe Mode. Select it. Note, it will ask for the administrator's
password. This is not your administrator account, rather it is the
machine's administrator account for which users are asked to create a
password during setup.

If you created no such password, when requested, leave blank and press
enter.

Open Explorer, go to Tools and Folder Options, on the view tab, scroll to
the bottom of the list, if it shows "Enable Simple File Sharing" deselect it
and click apply and ok. If it shows nothing or won't let you make a change,
move on to the next step.

Navigate to the files, right click, select properties, go to the Security
tab, click advanced, go to the Owner tab and select the user that was logged
on when you were refused permission to access the files. Click apply and
ok. Close the properties box, reopen it, click add and type in the name of
the user you just enabled. If you wish to set ownership for everything in
the folder, at the bottom of the Owner tab is the following selection:
"Replace owner on subcontainers and objects," select it as well.

Once complete, you should be able to do what you wish with these files when
you log back on as that user.

XP-Pro

If you have XP Pro, temporarily change the limited account to
administrative. First, go to Windows Explorer, go to Tools, select Folder
Options, go to the View tab and be sure "Use Simple File Sharing" is not
selected. If it is, deselect it and click apply and ok.

If you wish everything in a specific folder to be accessible to a user,
right click the folder, select properties, go to the Security tab, click
Advanced, go to the Owner tab,
select the user you wish to have access, at the bottom of the box, you
should see a check box for "Replace owner on subcontainers and objects,"
place a check in the box and click apply and ok.

The user should now be able to perform necessary functions on files in the
folder even as a limited account. If not, make it an admin account again,
right click the folder, select Properties, go to the Security tab and be
sure the user is listed in the user list. If not, click add and type the
user name in the appropriate box, be sure the user has all the necessary
permissions checked in the permission list below the user list, click apply
and ok.

That should do it and allow whatever access you desire for that folder even
in a limited account.



--
Michael Solomon MS-MVP
Windows Shell/User
Backup is a PC User's Best Friend
DTS-L.Org: http://www.dts-l.org/

"Roger Stenson" <roger.stenson1@ntlworld.com> wrote in message
news:YTXEd.1334$qb7.1318@newsfe4-gui.ntli.net...
> Hi all
> I have initiated a Program Files Folder which is to receive the builds of
> a
> DOT net system I am building. It also contain the main database. Although
> I
> was initially able to put early file versions in there, the whole folder
> now
> seems completely locked against all change and no matter how many times I
> indicate it is sharable and writable it always reverts to Read Only. I
> need
> to update the Access Database formats
>
> I have looked through the Local Security Policies and can see nothing
> about
> Locking CDrive Changes if Used by the OS which is the sort of message that
> crops up in intellisense when messing with the Program Files Folder. What
> can I do to get round this
>
>
>
> Thanks in anticipation
>
> Roger Stenson
>
>
>
Anonymous
January 12, 2005 2:16:48 PM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

Thanks for your help Michael
I have done everying you advise for XP Professional security set up. (The
system is part of a simple XP user network without a Server.) I am clearly
identiried as the owner of the relevant folder. I and the System seem to
have all 'full control' we need. Having gained this access I createda new
user database by copying one of the others in the folder. The dateabse
persists and holds all the data changes I make.

Then as soon as my system attempts to open it it disappears and is reported
not to exist
We are talking about a completely unsecured Access database in this
development phase of the system, opened by logon section of a .Net VB system

Only a week ago I had no trouble with this procedure and have only made
security backups of the whole system in the interval.

Roger Stenson

"Michael Solomon (MS-MVP)" <user@#notme.com> wrote in message
news:o Yu0hvE%23EHA.3472@TK2MSFTNGP14.phx.gbl...
> All folders on XP are read only but it's a system attribute and not the
> source of the issue.
>
> You might need to take ownership, see below:
> Note, file ownership and permissions supersede administrator rights. How
> you resolve it depends upon which version of XP you are running.
>
> XP-Home
>
> Unfortunately, XP Home using NTFS is essentially hard wired for "Simple
> File Sharing" at system level.
>
> However, you can set XP Home permissions in Safe Mode. Reboot, and start
> hitting F8, a menu should eventually appear and one of the
> options is Safe Mode. Select it. Note, it will ask for the
> administrator's
> password. This is not your administrator account, rather it is the
> machine's administrator account for which users are asked to create a
> password during setup.
>
> If you created no such password, when requested, leave blank and press
> enter.
>
> Open Explorer, go to Tools and Folder Options, on the view tab, scroll to
> the bottom of the list, if it shows "Enable Simple File Sharing" deselect
> it
> and click apply and ok. If it shows nothing or won't let you make a
> change,
> move on to the next step.
>
> Navigate to the files, right click, select properties, go to the Security
> tab, click advanced, go to the Owner tab and select the user that was
> logged
> on when you were refused permission to access the files. Click apply and
> ok. Close the properties box, reopen it, click add and type in the name
> of
> the user you just enabled. If you wish to set ownership for everything in
> the folder, at the bottom of the Owner tab is the following selection:
> "Replace owner on subcontainers and objects," select it as well.
>
> Once complete, you should be able to do what you wish with these files
> when
> you log back on as that user.
>
> XP-Pro
>
> If you have XP Pro, temporarily change the limited account to
> administrative. First, go to Windows Explorer, go to Tools, select Folder
> Options, go to the View tab and be sure "Use Simple File Sharing" is not
> selected. If it is, deselect it and click apply and ok.
>
> If you wish everything in a specific folder to be accessible to a user,
> right click the folder, select properties, go to the Security tab, click
> Advanced, go to the Owner tab,
> select the user you wish to have access, at the bottom of the box, you
> should see a check box for "Replace owner on subcontainers and objects,"
> place a check in the box and click apply and ok.
>
> The user should now be able to perform necessary functions on files in the
> folder even as a limited account. If not, make it an admin account again,
> right click the folder, select Properties, go to the Security tab and be
> sure the user is listed in the user list. If not, click add and type the
> user name in the appropriate box, be sure the user has all the necessary
> permissions checked in the permission list below the user list, click
> apply
> and ok.
>
> That should do it and allow whatever access you desire for that folder
> even
> in a limited account.
>
>
>
> --
> Michael Solomon MS-MVP
> Windows Shell/User
> Backup is a PC User's Best Friend
> DTS-L.Org: http://www.dts-l.org/
>
> "Roger Stenson" <roger.stenson1@ntlworld.com> wrote in message
> news:YTXEd.1334$qb7.1318@newsfe4-gui.ntli.net...
>> Hi all
>> I have initiated a Program Files Folder which is to receive the builds of
>> a
>> DOT net system I am building. It also contain the main database. Although
>> I
>> was initially able to put early file versions in there, the whole folder
>> now
>> seems completely locked against all change and no matter how many times I
>> indicate it is sharable and writable it always reverts to Read Only. I
>> need
>> to update the Access Database formats
>>
>> I have looked through the Local Security Policies and can see nothing
>> about
>> Locking CDrive Changes if Used by the OS which is the sort of message
>> that crops up in intellisense when messing with the Program Files Folder.
>> What can I do to get round this
>>
>>
>>
>> Thanks in anticipation
>>
>> Roger Stenson
>>
>>
>>
>
>
Anonymous
January 12, 2005 2:59:40 PM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

The next step would be to take this to microsoft.public.access as they are
more likely to have run into this issue and know the cause and how to deal
with it.

--
Michael Solomon MS-MVP
Windows Shell/User
Backup is a PC User's Best Friend
DTS-L.Org: http://www.dts-l.org/

"Roger Stenson" <roger.stenson1@ntlworld.com> wrote in message
news:AG7Fd.223$613.200@newsfe3-win.ntli.net...
> Thanks for your help Michael
> I have done everying you advise for XP Professional security set up. (The
> system is part of a simple XP user network without a Server.) I am clearly
> identiried as the owner of the relevant folder. I and the System seem to
> have all 'full control' we need. Having gained this access I createda new
> user database by copying one of the others in the folder. The dateabse
> persists and holds all the data changes I make.
>
> Then as soon as my system attempts to open it it disappears and is
> reported not to exist
> We are talking about a completely unsecured Access database in this
> development phase of the system, opened by logon section of a .Net VB
> system
>
> Only a week ago I had no trouble with this procedure and have only made
> security backups of the whole system in the interval.
>
> Roger Stenson
>
> "Michael Solomon (MS-MVP)" <user@#notme.com> wrote in message
> news:o Yu0hvE%23EHA.3472@TK2MSFTNGP14.phx.gbl...
>> All folders on XP are read only but it's a system attribute and not the
>> source of the issue.
>>
>> You might need to take ownership, see below:
>> Note, file ownership and permissions supersede administrator rights. How
>> you resolve it depends upon which version of XP you are running.
>>
>> XP-Home
>>
>> Unfortunately, XP Home using NTFS is essentially hard wired for "Simple
>> File Sharing" at system level.
>>
>> However, you can set XP Home permissions in Safe Mode. Reboot, and start
>> hitting F8, a menu should eventually appear and one of the
>> options is Safe Mode. Select it. Note, it will ask for the
>> administrator's
>> password. This is not your administrator account, rather it is the
>> machine's administrator account for which users are asked to create a
>> password during setup.
>>
>> If you created no such password, when requested, leave blank and press
>> enter.
>>
>> Open Explorer, go to Tools and Folder Options, on the view tab, scroll to
>> the bottom of the list, if it shows "Enable Simple File Sharing" deselect
>> it
>> and click apply and ok. If it shows nothing or won't let you make a
>> change,
>> move on to the next step.
>>
>> Navigate to the files, right click, select properties, go to the Security
>> tab, click advanced, go to the Owner tab and select the user that was
>> logged
>> on when you were refused permission to access the files. Click apply and
>> ok. Close the properties box, reopen it, click add and type in the name
>> of
>> the user you just enabled. If you wish to set ownership for everything
>> in
>> the folder, at the bottom of the Owner tab is the following selection:
>> "Replace owner on subcontainers and objects," select it as well.
>>
>> Once complete, you should be able to do what you wish with these files
>> when
>> you log back on as that user.
>>
>> XP-Pro
>>
>> If you have XP Pro, temporarily change the limited account to
>> administrative. First, go to Windows Explorer, go to Tools, select
>> Folder Options, go to the View tab and be sure "Use Simple File Sharing"
>> is not selected. If it is, deselect it and click apply and ok.
>>
>> If you wish everything in a specific folder to be accessible to a user,
>> right click the folder, select properties, go to the Security tab, click
>> Advanced, go to the Owner tab,
>> select the user you wish to have access, at the bottom of the box, you
>> should see a check box for "Replace owner on subcontainers and objects,"
>> place a check in the box and click apply and ok.
>>
>> The user should now be able to perform necessary functions on files in
>> the
>> folder even as a limited account. If not, make it an admin account
>> again,
>> right click the folder, select Properties, go to the Security tab and be
>> sure the user is listed in the user list. If not, click add and type the
>> user name in the appropriate box, be sure the user has all the necessary
>> permissions checked in the permission list below the user list, click
>> apply
>> and ok.
>>
>> That should do it and allow whatever access you desire for that folder
>> even
>> in a limited account.
>>
>>
>>
>> --
>> Michael Solomon MS-MVP
>> Windows Shell/User
>> Backup is a PC User's Best Friend
>> DTS-L.Org: http://www.dts-l.org/
>>
>> "Roger Stenson" <roger.stenson1@ntlworld.com> wrote in message
>> news:YTXEd.1334$qb7.1318@newsfe4-gui.ntli.net...
>>> Hi all
>>> I have initiated a Program Files Folder which is to receive the builds
>>> of a
>>> DOT net system I am building. It also contain the main database.
>>> Although I
>>> was initially able to put early file versions in there, the whole folder
>>> now
>>> seems completely locked against all change and no matter how many times
>>> I
>>> indicate it is sharable and writable it always reverts to Read Only. I
>>> need
>>> to update the Access Database formats
>>>
>>> I have looked through the Local Security Policies and can see nothing
>>> about
>>> Locking CDrive Changes if Used by the OS which is the sort of message
>>> that crops up in intellisense when messing with the Program Files
>>> Folder. What can I do to get round this
>>>
>>>
>>>
>>> Thanks in anticipation
>>>
>>> Roger Stenson
>>>
>>>
>>>
>>
>>
>
>
Related resources
!