Windows 7 Professional / Samba domain v 3.5.8 / Unable to join domain

Hello,

I have done this all before. In addition to

HKLM\System\CCS\Services\LanmanWorkstation\Parameters

DWORD DomainCompatibilityMode = 1

DWORD DNSNameResolutionRequired = 0

I am using Samba 3.5.8
and I am trying to join a Windows 7 64Bit laptop to my domain.

HP Pavillion dv6
Intel core i5 CPU M 520 @ 2.40GHz 2.40Ghz
4.00 GB RAM

However when I try join the domain i get the following message:

"The following error occurred attempting to join the domain "MYDOMAIN"
The specified domain either does not exist or could not be contacted.

If I do a nslookup it resolves the domain controller, as well if i watch the traffic I can only see UDP traffic on that IP, however i can still browse the web from it?

Any suggestions please? It's day two and dont know where to turn anymore.

Thanks in advance
Jes
3 answers Last reply
More about windows professional samba domain unable join domain
  1. have you tried using "MYDOMAIN.local"?

    Does that work?
  2. Hi Chainzsaw,

    Many thanks for your response. I will give that a try this morning, and let you know.

    Thanks

    Jes

    Update 06 July 11

    HI, I have tried mydomain.local and mydomain.co.za (south africa) with no help. I am re-installing windows in case i messed something up somewhere. Thanks again for all your suggestions.

    Jes
  3. Add windows 7 machine in your samba server using below commands.

    useradd -s /bin/false -d /dev/null computername$

    smbpasswd -a -m computername‚Äč


    And then try to add domain in windows 7 system.
Ask a new question

Read More

Configuration Windows 7 Domain Samba