Sign in with
Sign up | Sign in
Your question

Gamespy and Symantec Firewall on a home network

Last response: in Networking
Share
May 22, 2006 11:06:16 PM

I currently have 4 computers on my home network, and all 4 computers access the Internet through the dial-up connection on my main computer. This works fine, even when my Symantec Firewall is enabled.

But in order to play NWN online through gamespy, I am forced to disable my firewall on my main computer for the other computers to connect to gamespy. I have added lots of exe files to my approved list, even searching through my network and locating the nwn.exe file one of the computers that has a hard time getting through the firewall on my main computer, but no luck.

When I have friends over andf we play online, I am essentially playing with my computer unprotected. I want to be able to enable my firewall and have my other computers be able to access gamespy through my firewall.

Help.
May 23, 2006 1:53:01 AM

Odd thing is, I can get through my frewall to reach gamespy. When I update a game like NWN, the very first time I run it, I get a prompt about whether I want NWN.exe to access the Internet. I click yes, then it is good until I update again. Seems like this is what the webpage is telling me to do.

Other computers get through their respective firewalls as well. But when other computers attempt to get through my firewall with a game, they cannot. They cannot connect to Gamespy. How do I allow client computers to connect to gamespy?


Will opening up the following ports on my host computer via Symantic Client Firewall make a diffference? Hmmm?

6667 (IRC)
3783 (Voice Chat Port)
27900 (Master Server UDP Heartbeat)
28900 (Master Server List Request)
29900 (GP Connection Manager)
29901 (GP Search Manager)
13139 (Custom UDP Pings)
6515 (Dplay UDP)
6500 (Query Port)
Related resources
May 23, 2006 2:42:04 AM

Maybe you need to make specific allows for the IP addresses of the computers in your lan? I've never bothered with a software firewall myself but I seem to recall something like that for file sharing purposes. Maybe you need that for gaming due to your setup.
May 23, 2006 3:17:04 PM

They are all set to auto and make their own IP addresses. And they all reach the Internet just fine through the firewall on the host computer... just not gamespy.
May 23, 2006 3:57:20 PM

Here is some more info from the neverwinter site:

Quote:

If you are trying to play through a firewall of some sort, here is some information for you to help you get connected. Neverwinter Nights uses UDP, not TCP for its connections. If you think that your firewall is preventing you from connecting to the game servers, please make sure that the following ports are open:

Ports 5120 through 5300
Port 6500
Port 6667
Port 27900
Port 28900

If you have multiple computers behind a firewall and you want to play multiplayer with 2 or more of them at the same time, you must ensure the Client Port setting for each computer is set to a different value. You will find this entry in the file nwnplayer.ini Simply double click on it to open it, and look for the Client Port= line in the [Profile] section. Change this from the default value of 5120 on each machine. You have to stay in a certain range, so use numbers like 5121, 5122, 5123, etc.


You may have to open those ports in addition to the gamespy ports.
May 23, 2006 9:23:55 PM

If you are opening all of those port, you are disabling the firewall anyway. And opening your self up for attacks. Make sure you have a good backup you may need it.
May 23, 2006 10:53:44 PM

Very true ;) 

Be completely open on a bunch of ports all the time or be open on all ports for short amounts of time. It is sort of a lose lose situation...
!