USB flash drive causes system to crash

I have a PNY Attache' 1G U3 smart drive, which works fine on my laptop. However, when uses on my desktop as soon as the detection notification pops up windows crashes.

My blue screen of death reads:

DRIVER_IRQL_NOT_LESS_OR_EQUAL

(then the standadard advice)

then the technical information reads:
"STOP: 0x000000D1 (0x201903E8,0x00000002,0x00000000,0x86190333)"

I have no idea what's causing this problem, all my other usb devices are working fine. My only guess would be the U3 smart software that comes on his particular flash drive. Any other ideas would be greatly appreciated.
Thanks in advance...
4 answers Last reply
More about flash drive system crash
  1. Look for a newer version of that software. It's obviously causing a problem with the USB driver. If there is no newer version available yet, report this to PNY.
  2. This happens to me also, I have checked the PNY site, even the U3 site but I cant find anything, can we get any help?
  3. Now this could just be a guess, but it sounds right to me. It can eather be one of these 2 thaughts. I read on another forum that aparently the drive trys to force the same drive letter for the CD-Drive it puts on. I think that if you have another CD drive or Hard Drive even that could be causing conflict.. Eather that, or the fact that im using an Image Drive so its not allowing it to make another, cause after all the Flash drive is just creating another image drive to run its Image CD. Can I get any feedback on these thaughts? What do you think?
  4. I had a similar problem, also with a PNY Attache' 1GB...though I didn't get a blue screen - my system would simply reboot as soon as the task bar identified the drive as being connected. :evil: I tried holding down shift to bypass autorun, same result. There are a number of known software conflicts, and though Daemon Tools wasn't on the U3 list, it offers similar functionality. Since I only needed the space on the Flash Drive, not the interface, I elected to uninstall the U3 Launchpad. I had to use another machine with USB 2.0 capability that had no virtual drive software, etc. From there I was able to plug in the Flash Drive, and download the uninstall app from the U3 website (http://www.u3.com/uninstall/). After running that with the drive connected, I was able to go back to my main system and connect the drive with no problems.

    While the idea of the U3 interface seems promising, I make use of many of the type of programs which would render the device useless to me on several of my PC's. Perhaps someday I can revisit the idea when and if the implementation is more thought-out...but it will have to be on a new Flash Drive, as U3 states the uninstall process is irreversible. :(
Ask a new question

Read More

USB Flash Storage