Sign in with
Sign up | Sign in
Your question

File extension not assigned properly

Last response: in Windows 2000/NT
Share
March 14, 2005 4:30:51 PM

Archived from groups: microsoft.public.win2000.general (More info?)

This is a followup to a note I posted here a week or so ago explaining that
when I attempted to save pictures from the web and change its file name,
the dialog box doesn't want to assign the .jpg extension. (That exchange is
below.) Hence it gets saved as "File". Subsequently, finding the file in
Windows Explorer I can rename it by adding ".jpg" and it then is identified
with the jpeg icon and is recognized as a jepg file - even though it hides
the file extension.

Question: If I don't add the ".jpg" extension manually the Save Dialog Box
doesn't assign it. Why not? It did using 98SE.

Solution, please.

Bud



Old Post:

I just changed from 98SE to Win 2K. Occasionally I want to save a picture
of something that comes up on ebay. In 98SE, when I pointed to the "Save"
icon in the picture or "Save picture as", the file menu would come up with
the file name and type (jpeg). I usually changed the file name and then
saved it. Windows Explorer would show it with the new file name and it
would show the type as jpeg and also the jpeg icon.

Now, if I leave the file name unchanged, the file is saved correctly.
However, if I change the file name, Win Explore lists it as "File" (not
jpeg) and the icon is the generic Windows flag. It also isn't recognized as
a photo to any photo application.


Response: It seems like you may
have your OS configured to display file extensions. So it is displaying
'photo.jpg'. Then you rename it and replace 'photo.jpg' with 'newname' and
no '.jpg'. This rewrites the name of the file and gives it no extension
making it not recognizable by the OS or (most) programs.


You are correct but I still can't make the change. I unchecked the
suggested box in Control Panel. In Windows Explorer I also went to folder
options / file types / selected both JPG & JPEG / Advanced - and unchecked
that box. Still no good.

When the "Save Picture" dialog box comes up and I change the File name, I
leave the "Save as type" set to JPEG which should still save it as a *.jpg
type, shouldn't it?

Another curious thing also happens - If I leave the file name untouched and
try to save it as a Bitmap type, a warning tells me that a jpeg file by that
name already exists. If I tell it to overwrite it as a Bitmap it instead
overwrites it as a jpeg.

Somehow the "Save Picture" dialog box doesn't seem to be responding
properly.

Thanks in advance, Bud
Anonymous
March 15, 2005 12:09:16 PM

Archived from groups: microsoft.public.win2000.general (More info?)

Something is broken, probably as a result of the upgrade instead of a clean install?
Have you applied SP4. You really need to.
Did you have any 3rd party image handling software installed before the upgrade?

If uninstalling any 3rd party image handling software and applying SP4 doesn't fix it, consider a clean install with SP4.

On Mon, 14 Mar 2005 13:30:51 -0500, "Bud" <76b4ruehle@ptd.net> wrote:

>This is a followup to a note I posted here a week or so ago explaining that
>when I attempted to save pictures from the web and change its file name,
>the dialog box doesn't want to assign the .jpg extension. (That exchange is
>below.) Hence it gets saved as "File". Subsequently, finding the file in
>Windows Explorer I can rename it by adding ".jpg" and it then is identified
>with the jpeg icon and is recognized as a jepg file - even though it hides
>the file extension.
>
>Question: If I don't add the ".jpg" extension manually the Save Dialog Box
>doesn't assign it. Why not? It did using 98SE.
>
>Solution, please.
>
>Bud
>
>
>
>Old Post:
>
>I just changed from 98SE to Win 2K. Occasionally I want to save a picture
>of something that comes up on ebay. In 98SE, when I pointed to the "Save"
>icon in the picture or "Save picture as", the file menu would come up with
>the file name and type (jpeg). I usually changed the file name and then
>saved it. Windows Explorer would show it with the new file name and it
>would show the type as jpeg and also the jpeg icon.
>
>Now, if I leave the file name unchanged, the file is saved correctly.
>However, if I change the file name, Win Explore lists it as "File" (not
>jpeg) and the icon is the generic Windows flag. It also isn't recognized as
>a photo to any photo application.
>
>
>Response: It seems like you may
>have your OS configured to display file extensions. So it is displaying
>'photo.jpg'. Then you rename it and replace 'photo.jpg' with 'newname' and
>no '.jpg'. This rewrites the name of the file and gives it no extension
>making it not recognizable by the OS or (most) programs.
>
>
>You are correct but I still can't make the change. I unchecked the
>suggested box in Control Panel. In Windows Explorer I also went to folder
>options / file types / selected both JPG & JPEG / Advanced - and unchecked
>that box. Still no good.
>
>When the "Save Picture" dialog box comes up and I change the File name, I
>leave the "Save as type" set to JPEG which should still save it as a *.jpg
>type, shouldn't it?
>
>Another curious thing also happens - If I leave the file name untouched and
>try to save it as a Bitmap type, a warning tells me that a jpeg file by that
>name already exists. If I tell it to overwrite it as a Bitmap it instead
>overwrites it as a jpeg.
>
>Somehow the "Save Picture" dialog box doesn't seem to be responding
>properly.
>
>Thanks in advance, Bud
>
>
>


Jerold Schulman
Windows Server MVP
JSI, Inc.
http://www.jsiinc.com
March 16, 2005 3:04:51 PM

Archived from groups: microsoft.public.win2000.general (More info?)

The original install was not an upgrade but a clean install with SP4. I
have spent the last couple of weeks reinstalling programs, setting
preferences and retrieving data from another hard drive so I don't want to
go through all that again.

I uninstalled Photoshop 5 and an ACDSee trial - no solution.

Is there a way to reinstall Win2K over top of what I have to fix the
problem? What harm would it do to try?





"Jerold Schulman" <Jerry@jsiinc.com> wrote in message
news:rvqd31lahjdlaeqeif6t7a281on5629tnq@4ax.com...
>
> Something is broken, probably as a result of the upgrade instead of a
clean install?
> Have you applied SP4. You really need to.
> Did you have any 3rd party image handling software installed before the
upgrade?
>
> If uninstalling any 3rd party image handling software and applying SP4
doesn't fix it, consider a clean install with SP4.
>
> On Mon, 14 Mar 2005 13:30:51 -0500, "Bud" <76b4ruehle@ptd.net> wrote:
>
> >This is a followup to a note I posted here a week or so ago explaining
that
> >when I attempted to save pictures from the web and change its file name,
> >the dialog box doesn't want to assign the .jpg extension. (That exchange
is
> >below.) Hence it gets saved as "File". Subsequently, finding the file
in
> >Windows Explorer I can rename it by adding ".jpg" and it then is
identified
> >with the jpeg icon and is recognized as a jepg file - even though it
hides
> >the file extension.
> >
> >Question: If I don't add the ".jpg" extension manually the Save Dialog
Box
> >doesn't assign it. Why not? It did using 98SE.
> >
> >Solution, please.
> >
> >Bud
> >
> >
> >
> >Old Post:
> >
> >I just changed from 98SE to Win 2K. Occasionally I want to save a picture
> >of something that comes up on ebay. In 98SE, when I pointed to the "Save"
> >icon in the picture or "Save picture as", the file menu would come up
with
> >the file name and type (jpeg). I usually changed the file name and then
> >saved it. Windows Explorer would show it with the new file name and it
> >would show the type as jpeg and also the jpeg icon.
> >
> >Now, if I leave the file name unchanged, the file is saved correctly.
> >However, if I change the file name, Win Explore lists it as "File" (not
> >jpeg) and the icon is the generic Windows flag. It also isn't recognized
as
> >a photo to any photo application.
> >
> >
> >Response: It seems like you may
> >have your OS configured to display file extensions. So it is displaying
> >'photo.jpg'. Then you rename it and replace 'photo.jpg' with 'newname'
and
> >no '.jpg'. This rewrites the name of the file and gives it no extension
> >making it not recognizable by the OS or (most) programs.
> >
> >
> >You are correct but I still can't make the change. I unchecked the
> >suggested box in Control Panel. In Windows Explorer I also went to folder
> >options / file types / selected both JPG & JPEG / Advanced - and
unchecked
> >that box. Still no good.
> >
> >When the "Save Picture" dialog box comes up and I change the File name, I
> >leave the "Save as type" set to JPEG which should still save it as a
*.jpg
> >type, shouldn't it?
> >
> >Another curious thing also happens - If I leave the file name untouched
and
> >try to save it as a Bitmap type, a warning tells me that a jpeg file by
that
> >name already exists. If I tell it to overwrite it as a Bitmap it instead
> >overwrites it as a jpeg.
> >
> >Somehow the "Save Picture" dialog box doesn't seem to be responding
> >properly.
> >
> >Thanks in advance, Bud
> >
> >
> >
>
>
> Jerold Schulman
> Windows Server MVP
> JSI, Inc.
> http://www.jsiinc.com
!