Sign in with
Sign up | Sign in
Your question

Cisco Pix 515 Help

Last response: in Networking
Share
June 7, 2006 4:22:49 PM

I am trying to figure out if the dhcp is disabled on my 515 but I dont know to much about unix or its commands to find out. I can log into it but I am stuck on where exactly to go? Could anyone please help, I would greatly appreciate it. Thanks Neal

More about : cisco pix 515

June 7, 2006 6:44:59 PM

im not a cisco pro or anything, but if i had a PIX, and i know Cisco stuff are VERY expensive, i would simply call Cisco tech support and get the quick answer from them. just a quick suggestion to get your answer quicker. :) 
June 8, 2006 2:54:47 PM

I know that by default dhcp is disable on the older model Cisco equipment.

I know if you input "show run" at the command prompt and look for "dhcp enable inside" i think is the command.

Your best friend is www.cisco.com and just search for dhcp on pix 515.

These snippets are some things you might see:

interface management 0/0

ip address 192.168.1.1 255.255.255.0

nameif management

security-level 100

no shutdown

asdm logging informational 100

asdm history enable

http server enable

http 192.168.1.0 255.255.255.0 management

dhcpd address 192.168.1.2-192.168.1.254 management

dhcpd lease 3600

dhcpd ping_timeout 750

dhcpd enable management

-----------------------------------------------------------------
dhcpd address 192.168.1.2-192.168.1.254 inside

dhcpd auto_config outside

dhcpd enable inside


===================THis is the 515 default config

interface ethernet 1

ip address 192.168.1.1 255.255.255.0

nameif management

security-level 100

no shutdown

asdm logging informational 100

asdm history enable

http server enable

http 192.168.1.0 255.255.255.0 management

dhcpd address 192.168.1.2-192.168.1.254 management

dhcpd lease 3600

dhcpd ping_timeout 750

dhcpd enable management
Related resources
June 8, 2006 3:59:24 PM

Thanks, It does show that it is enabled. I need to disable it but I think I am going to have an issue. The login i have has a security level of 2. I tried to change the clock and it wouldnt let me. What is the command to disable dhcp. Thanks Neal.
June 8, 2006 8:07:19 PM

Usually if you use the negate commands "no" for of the commands that enable dhcp it usually disables it.

So "no dhcpd address 192.168.1.2-192.168.1.254 management" and so on for teh dhcp commands listed for the 515 and that show up in your config.

As for you username problem. You can access the enable mode correct? If so you can reset the admin password using "configure terminal" to access the global config mode and then "username admin password xxxxx."

If you can't access the terminal to configure it I think its possible to break into these in the same way as a router. I assume your using the console connection to connect to it. To do that you have to power down and power on the PIX and when its booting you'll see the "system bootstrap" info and at that point you press "ctrl + break" to get to rommon. I think this works, don't quote me on it even though I used quotes :lol: 

Let me know how it goes. Try the username commands first.
June 8, 2006 8:13:09 PM

I figured out the problem, I didnt type in the configure terminal command. So I was able to disable dhcp. I am trying to log into the pix via pix device manager. I updated the certificate but now it is giving me a host name mismatch? I have looked on the web but havent found anything but configuring a new pix. When I log into 192.168.XXX.X it tells me the certificate is ACVGATE@emailaddress.com so 192.168.XXX.X doesnt match the certificate. How do I change the pix to a host name of 192.168.XXX.X? Thanks for all the help. Neal
June 8, 2006 8:20:15 PM

When you started configuring this PIX did you delete all the information on prior to working on it?

I've never heard of an error like that before, it sounds like an SSL error.
June 8, 2006 8:49:29 PM

I am not the original installer. I was trying to log into the pix via pdm. When I first started looking through the pix yesterday I noticed the time and date was off by a couple years so I changed the time and renewed the certificate. When I log on to the pdm it asks me to accept the certificate which i do but it tells me of the host name mismatch. And doesnt let me log in. I looked over the web and found data on the pdm which is version 3.0, but in only explains a new install not configuring an existing install. It says to go into the config mode and enter setup but I dont want to loose any settings that are critical! It took me a day and half to get cisco to return my call. I dont know enough about the set up to know where to look! But it said in the setup there was a host name which i believe is the culprit. It also stated to allow inside traffic to the pdm by typing in http ip address subnet inside which I did and it told me my ip already exists. Its not a big issue now that i got the dhcp disabled I would just like the ease of looking at the pix via pdm instead of the command line. Thans Neal.
June 8, 2006 8:54:30 PM

I see. I'm a command line guy myself. I've never used the PIX device manager before.

Well the hostname on a PIX usually refers to what you see at the command line. By default it says "PIX#" you can change it using the "hostname xxxxx" command at the configure terminal prompt.

Is this PIX in use while your working on it?
June 8, 2006 8:59:28 PM

Yes it is in use. What it the command to look at the host name.
June 8, 2006 9:04:23 PM

When you access the command prompt its what you see on screen by the text cursor.

Also I recommend copying your configuration just in case. The nice thing about the command line is you can copy and past text.
June 8, 2006 10:51:57 PM

Thanks for all the help, Neal.[/img]
!