Sign in with
Sign up | Sign in
Your question
Closed

How to change the network type?

Tags:
  • Windows 7
Last response: in Windows 7
Share
April 17, 2009 8:11:52 PM

Connecting to my Access Point (WEP, Shared Key) works fine, but the network type becomes PUBLIC in the Network and Sharing Center and I cannot change it, it is read only there! My computer is not part of a domain but a member of a workgroup.

I need to change the network type for the above WiFi connection to WORK/HOME.

Please help. Thank you in advance.

More about : change network type

April 17, 2009 8:40:26 PM

First what version of windows are you using?
Vista?
Score
0
April 17, 2009 9:00:44 PM

Windows 7 Ultimate Beta 1 Build 7077 x64 Bit
Score
0
Related resources
a b $ Windows 7
April 18, 2009 9:52:24 AM

open the network and sharing center, under the name of your network connection it should say public network, click it, and you should be able to alter it to whatever you want.
Score
0
April 18, 2009 3:48:27 PM

montyuk said:
open the network and sharing center, under the name of your network connection it should say public network, click it, and you should be able to alter it to whatever you want.


Dear Monty, thanks for your efforts, but in my case, the text PUBLIC is read only and cannot be clicked, any idea?
Score
0

Best solution

a b $ Windows 7
April 18, 2009 5:12:03 PM

well i can guess why, on the screen that you cant get to theres a tick box and i imagine theres a similar box when setting up a new network which reads - "treat all future networks as public and dont ask me again"

now, i think i have found an option that might override this

goto the start menu and type in the search box - gpedit.msc
find this branch - computer config>windows settings>security settings>network list
and you should see your network listed on the right, however dont select it, look for the one called 'all networks' select that and select properties, second section down theres a radio button for 'user can change location' select that and click ok.

Share
April 28, 2009 12:45:35 PM

Hi, thank you all for the efforts. However, I finally sorted it out and got the reason. I am posting the story step by step over here.
Score
0
a b $ Windows 7
April 28, 2009 9:32:02 PM

A wireless router would have saved you a bit of a headache... but at least you got it figured out. Wouldn't a router also have been cheaper? A lot of wireless routers I see are actually cheaper than a good portion of the WAPs I see.
Score
0
April 29, 2009 12:19:43 PM

Yes you are right but WiFi Router wasn't available here when I bought the WiFi Access Point.
Score
0
January 16, 2010 8:19:36 PM

This is the message that probably hides behind that link to windows7forums which is down at the moment, so for those who have similar problem here you go.
[quote = "SKJoy2001"]
For Windows 7 network types, the secret lies in the GATEWAY entry. Any network you connect on that doesn't have a DEFAULT GATEWAY provided with, becomes PUBLIC and you cannot change it's type.

The solution is simple, specify the DEFAULT GATEWAY IP in the network properties and you are done.

There had been other suggestions like requesting the system to treat any future networks to be PRIVATE/WORK, but that will make a serious security issue if your computer is exposed in an environment that cannot really be trsuted, so, don't do that.

Also, don't use Group Policy Editor to force making the network type PRIVATE/WORK as that is not really a solution and eventually, that will revert back to PUBLIC.

I hope this helps you out. If so, please do post this to the forum where people having difficulty with this type.

I solved my trouble with a router later, but with an access point, if you want to set up a real network, then you need to make your computer the gateway and use a DNS server on this gateway so other clients can be configured automatically to connect to the network, this way, your computer is connected to the network via the access point and perfoms as the DEFAULT GATEWAY & DNS SERVER for the other clients, this makes your computer a soft router ;) [/quote]

This is the quote from email Joy sent to me

Best regards, Srdjan
Score
0
March 1, 2010 6:48:53 PM

100r said:
This is the message that probably hides behind that link to windows7forums which is down at the moment, so for those who have similar problem here you go.
[quote = "SKJoy2001"]
For Windows 7 network types, the secret lies in the GATEWAY entry. Any network you connect on that doesn't have a DEFAULT GATEWAY provided with, becomes PUBLIC and you cannot change it's type.

The solution is simple, specify the DEFAULT GATEWAY IP in the network properties and you are done.

There had been other suggestions like requesting the system to treat any future networks to be PRIVATE/WORK, but that will make a serious security issue if your computer is exposed in an environment that cannot really be trsuted, so, don't do that.

Also, don't use Group Policy Editor to force making the network type PRIVATE/WORK as that is not really a solution and eventually, that will revert back to PUBLIC.

I hope this helps you out. If so, please do post this to the forum where people having difficulty with this type.

I solved my trouble with a router later, but with an access point, if you want to set up a real network, then you need to make your computer the gateway and use a DNS server on this gateway so other clients can be configured automatically to connect to the network, this way, your computer is connected to the network via the access point and perfoms as the DEFAULT GATEWAY & DNS SERVER for the other clients, this makes your computer a soft router ;) 

This is the quote from email Joy sent to me

Best regards, Srdjan
[/quote]
Hi, thanks for sharing it out there as I don't have much time to look at things now a days that I used to, and thank you again on behalf of the mourning souls with Win7NetTrouble ;)  out their.
Score
0
May 5, 2010 6:06:08 PM

After reading miles of forums and trying everything i could, the only logical response was this one: Windows 7 DHCP server emulation (or whatever is their DHCP called) SUCKS badly, so it is not capable to give you a proper DHCP lease (an internal class B IP, a default route, and no stupid settings at all) - negotiation for such a DHCP lease fails because somewhere in your small network is another DHCP, but CONNECTED TO ANOTHER LAN interface and has nothing to do with the one you really want to use.
So I haven't seen my solution anywhere, and I give it to you hoping you will spend less time wondering about your drivers, setting stuff manually or other disputable solutions as i did. I can now connect without any hustle whenever i please to do so: I got myself a small DHCP server software, which runs alone as a service; every time i get my laptop at work, i can connect. when i come home to my stupid windows 7, i can also connect, as i have my small dhcp software running and granting me the proper settings in a heartbeat.

you can use any software you like, this is what i found first: DHCP Server V1.81 written by some guy named Uwe Ruttkamp.

I have set the config to something like this:
Quote:

[General]
SUBNETMASK=255.255.255.0
NODETYPE=8 ; Hybrid
LEASETIME=86400 ; lease time of 1 day

[Settings]
IgnoreUnknownClients=1

; replace X with MAC ADDRESS from the lan/wan card to which you want your secondary computer to connect
[XX-XX-XX-XX-XX-XX]
IPADDR=192.168.2.3
SUBNETMASK=255.255.255.0
;this is the address my card is always setting for the router
ROUTER_1=192.168.2.1
DNS_1=192.168.2.1


and now i can relax and enjoy a decent internet connection EVERY time!

I hope this helps dudes,
Score
0
a b $ Windows 7
February 4, 2012 11:51:28 AM

This topic has been closed by Mousemonkey
Score
0
!