Sign in with
Sign up | Sign in
Your question

DCM-202 & DI-624 browsing problems

Tags:
  • Routers
  • Modem
  • Networking
Last response: in Networking
Share
June 27, 2006 11:21:23 PM

I have comcast high speed. Suddenly on Sunday I was unable to browse many web sites such as google.com etc. This was the same for all 5 computers on the network. After a call to comcast tech support thinking comcast was offline I discovered that when directly connected to the DCM-202 modem I could browse any place I wanted. But when I put the DI-624 router back in line the problem reoccurred. I have powered off both the modem and router for several minutes several times with no change. I have reset the router several times (10 seconds). I have upgraded the firmware on the router to the latest 2.70. Still the problem persists.
When I get home again tonight I will once again power everything off for several minuets and see if the problem fixes itself.
So far calls to D-Link tech support have not been able to fix the problem. Their attitude is that it is a comcast dns problem even though directly connecting to the DCM-202 modem has no problems what so ever.
Could it be the way the router and modem are communicating to each other or something in the router blocking requests?

More about : dcm 202 624 browsing problems

June 28, 2006 12:18:15 AM

I had a similar problem, also with comcast. Try replacing the cat5 cable between the modem and router with a different one. Preferably around a 12'. I discovered mine use the Yukon cable tester. I had one pair that was jumping around, bad connector, factory.
June 28, 2006 1:48:38 AM

Tried that with no effect. In fact I tested all the cables and they all show good, even pulled twisted basicly worked them over with no bad cables.
Related resources
June 28, 2006 1:59:41 AM

What are you using for a MTU. I have one site that wants a low value 1420.
June 28, 2006 2:19:42 AM

all mtu's are default for computers and modem and router. No changes what so ever had been made to anything. The problem arose out of the blue.
June 28, 2006 3:43:50 AM

Can you ping the router from your PCs? (Establish Router presence)
Can you ping 4.2.2.2 from the PCs? (Bypasses DNS)
-If you can ping this address through the router from a PC, the problem may be DNS related.

Is the Router picking up an IP address from the cable modem?
-If not, clone the MAC address of the PC you connected to the cable modem and reboot the router to see if it will then.

If the router is picking up an address, make sure it is also picking up valid DNS entries.

Can you run an nslookup on the DNS entries the router gives you?
June 28, 2006 4:14:15 AM

I can ping the router and I can ping 4.2.2.2 but presently I can not ping www.google.com but 20 mins ago I could ping google.
The router is getting an ip address from the modem. It is also getting valid dns entries.
Presently I am running thru the router and can reach this site but I can not reach google, yahoo or many other sites. If I take the router out of line and release and renew my ip address then thru the modem directly everything is normal.
June 28, 2006 4:42:52 AM

Ok, so now I am direct thru the dcm-202 modem and I can ping anything with out a problem.

If I access the modem directly via its ip address here are the last entries in its log.

On 6-25-06, 11:12:44, R04.0, critical, Received Response to Broadcast Maintenance Request, but no Unicast Maintenance opportunities received - T4 timeout.

6-25-06, 11:12:44, T01.0, critical, SYNC Timing Synchronization failure - Failed to acquire QAM/QPSK symbol timing.

6-25-06, 11:13:00, R02.0, critical, No Ranging Response received - T3 time-out.

This was after our being ok and before the trouble began.
June 28, 2006 8:39:03 PM

With My comcast service I was required to cloan the MAC Address of the computer used to setup the service. If you did not do that during the router setup you will need to. Part of the WAN Setup.
June 28, 2006 9:18:44 PM

Quote:
With My comcast service I was required to cloan the MAC Address of the computer used to setup the service. If you did not do that during the router setup you will need to. Part of the WAN Setup.


Did that when I set up the router. Remember, this problem came out of a blue sky. Everything had been working normal for many many months.
June 28, 2006 10:21:53 PM

It'a a good posibility that your router went belly up. I had one one time that could send but not receive. Try to setup a loop back test. If I recall you have to connect the WAN to a LAN port (crossover may be required) then ping the gateway. This may not be correct it's been over 5 yrs since I have used a loop back test. If that doesn't work, setup a PC to be the WAN.

Can you tranfer data between lan pc's ?

Another posibility is the router is overheating. Turn off (unplug) for 10-15 min and try again.
July 1, 2006 7:17:24 PM

that router is very unreliable. trust me, the thing works when it wants to.
July 1, 2006 7:53:06 PM

When they get to that point is time to replace them. Is the thing still in warranty?

Currently I'm using Netgear FVS338 VPN SmallBussiness router. My AP is seperate which gives me more options.
July 2, 2006 3:37:27 AM

Not under warranty any more. And as far as it working when it wants to that could be a good point because right now its working just fine. I left it powered off for one day and it came back to life.
September 15, 2006 6:52:54 AM

I have the same exact modem & router combination and have experienced the same problem twice since installing last week, including tonight. It's taken 4-5 hrs to resolve on each occasion, with the final hour being spent with D-Link tech support troubleshooting. When connecting via the router (wirelessly or via LAN) to the internet doesn't work, directly plugging an ethernet cable from the DCM-202 into a PC or Mac laptop connects. The problem is the router/modem handshake; the router's having a difficult time pulling an IP/getting assigned an IP from the modem (even when forcing the router to request this from the modem via the router software). It's not just the DI-624 that has a problem, but two different generations of Apple Airport base stations had the same problem with the DCM-202 modem (and they worked flawlessly with my previous Motorola surfboard, which I foolishly returned to the cable company thinking it was outdated and unreliable ... big mistake).

The thing that finally worked with the DCM-202/DI-624 pair earlier tonight was the following. Pull the power on both. After 2 minutes (not sooner), power up the modem. After you get 3 full green lights (incl cable and status), wait another 2 minutes. Now power up the router. After this sequence, everything worked tonight (and I googled and found this page). Perhaps powering up the router too quickly (even if the various lights suggested the modem was operational) resulted in a nonproductive communication with the modem. It might also just be a stochastic event, i.e. one has to power up the router at some random moment to handshake nicely with the modem. In any case, it isn't worth the time. If I run into this problem again (i.e. laptop -> modem connects to internet, but laptop -> router -> modem does not) and it is not resolved with a half hour of power offs, resets, requests to renew DHCP, etc, I'm just buying a different brand cable modem (that is approved by my cable provider). The problem is clearly modem instrinsic (running the latest firmware).
June 9, 2009 11:02:21 PM

I have the exact same equipment and the exact same problem. I have been searching high and low, and this is the first web page I have found that suggested that these DLink pieces of garbage were anything other than holy artifacts of some kind.

to rule out DNS, I have been testing exclusively by IP address:

- from the Wireless or the LAN, I can ping the router consistantly.
- from the Wireless or the LAN, I can ping the modem consistantly.
- from the modem, I can ping the internet (any upstream IP, 4.2.2.2 for example) consistantly.
- from the Wireless or the LAN, pings to the the internet are highly unpredictable and unreliable.
- rebooting in any order with any ammount of "wait time" does not have any reliable effect.

I was about ready to throw all of it out the window, suspecting that it had something to do with the Modem's wonderful feature of running two LAN subnets over the same ethernet segment (public IP assigned by the ISP, as well as 192.168.100.0 management network) and some sort of split horizon b.s. going on. But then I stumbled onto something:

The problem seems to be entirely due to RF interferance from the cables! I havent isolated wither its the wireless antenna, the power cords, the cable line, or the ethernet cable (definitly not a bad patch cord, i've tried three of different lengths and they all behve the same, and test reliably elsewhere). But when the cables are all streached out and seperated, it works fine! when they are bunched up, coiled, or near each other, then packets start dropping.

I'm not sure which component is causing the interferance, but i can reliably and verifyably change the behavior of the system by reshaping the cord arrangements. will have to test more to isolate the component that is causing the problem, but its beyond any doubt RF noise between the cables and/or the antenna.
!