Sign in with
Sign up | Sign in
Your question

A Disk Read Error Occurred

Tags:
  • Hard Drives
  • Disk Read Error
  • Storage
Last response: in Storage
Share
January 3, 2007 4:55:07 PM

I just built a computer two weeks ago. Here is the thread with all the pieces I bought. http://forumz.tomshardware.com/Critique-Build-ftopict21...

I went to sleep last night and the comp was working fine but I woke up this morning and my monitor wasn't getting a signal though the comp was on. I restarted my comp and it goes through the start up a little ways, it shows the hardware monitor screen and it says verifiying dmi pool data.......... and then below that it says a disk read error occurred...press alt control deleteto restart yet I hit the buttons and nothing happens and I have to turn the comp off and back on to start the process over.

I have restarted a hundred times same error each time. I have booted up BIOS and don't see any problems there, I changed the boot device to cd rom to try and boot from the windos disc and all it does is say reading disc.......to boot from disc press any button..... then it says the same error message. I opened the computer and unplugged the wires and replugged them in, that didn't work. I booted up while hitting each time one of the f1-f12 buttons to try and enter dos or enter safe mode or anything to get around that and nothing works. Is my hard drive bad, or could it be something else? This is really pissing me off that I can't figure out what is the matter. Any help would be GREATLY appreciated.

More about : disk read error occurred

January 3, 2007 5:15:31 PM

Hard Drive = toast.

RMA it immediately.

I'm a bit confused though: it should be possible to get into the BIOS and set the boot order to be CD-ROM first.... Have you tried hitting DEL instead of F8 to get to the BIOS?
January 3, 2007 5:19:35 PM

Need to test the hard drive. Many ways of doing this.

First, can you hear the drive spin up during the boot process?

Try another hard drive in its place and hook your current hard drive up as a secondary drive. see if you can access the file system.

-Using this method will allow you to use the WD lifeguard tools to diagnose your hard drive. http://support.wdc.com/download/index.asp?swid=1
-If it fails you can check your warranty status with this link
http://websupport.wdc.com/warranty/serialinput.asp?custtype=end&requesttype=warranty&lang=en and return if need be.
-You can also download the lifeguard tools and run them from dos as well.

Or, try an external usb/fireware enclosure and see if you can gain access to the drive from another machine.

Finally, if you are linux savvy then you could try knoppix or other forms of CD-bootable linux distros and see if you can interact with the drive that way.
Related resources
January 3, 2007 5:25:41 PM

Here's something to check (happened to me last week). In my DS3 bios there is an option to enable or disable support for a USB keyboard and mouse.

The funny thing about it is that you have USB support in the BIOS and after Windows loads you get USB support from there. This setting only comes into play during that brief instant when you are in between posting and loading the OS.

The effect is that it doesn't read you keyboard input (if it's disabled) when it throws that disk read error and asks you what to do. Same thing for "press any key to boot from CD" - I'd press a key and it wouldn't boot from the CD becuase it didn't know I had pressed a key. It was a really easy fix for a really annoying problem.

Good luck.
January 3, 2007 5:48:55 PM

You haven't told us about the install cd. When it says "Press any key to boot from the cd" did you tap a key, and, did the install seem to start okay?

Or, was your keyboard unresponsive to the press?

Is your keyboard USB?

If not, disable support for USB k&m as per MAK-Daddy.

If the cd install works, your hd is toast.
January 3, 2007 6:43:47 PM

well I just typed in about four paprgraphsof what I did to my comp and it didn't post so I will just give the gist of it. Ran chkdsk:said there were errors in in the disk. Ran fix boot: said it fixed corrupt files. Ran Bootcfg /scan: said it failed because of corrupt file system then it told me to run chkdsk which I already had and that didn't help just told me stuff was bad. Set the HD as the boot and retstarted. This time I had a non-usb keyboard plugged in and it went to the choice of what windows to start. No matter if I choose start win normal, safe, or from last sucessful boot, it goes to the loading windows xp screen, then goes to a blank screen and I hear a click in the computer and it reboots and it continues to do this over and over again regardless of what mode I try to start windows. Should I just format everything and reinstall windows? It would suck to do that because will loose everything I had setup in the past two weeks including my whole oblivion saved game which equals 40+ hours of play.
January 3, 2007 6:49:43 PM

Anyone know what the problem could be?
January 3, 2007 8:27:49 PM

Give a repair install a shot.

Start the xp cd and when you come to the first screen that offers a Repair - DO NOT HIT "R". Hit Enter. When you get to the next screen that offers to repair an existing Windows installation - do that.

It will overwrite the existing. If it goes okay and completes, run chkdsk immediately. Right-click the "C" drive - Properties - Tools - Error Checking - check both boxes and reboot. I would run this every day to keep tabs on your hard drive condition. Pay particular attention to bad sectors. If they accumulate, clone this hd immediately to a brand new one. Don't worry, the cloning app doesn't transfer bad spots.

Then you can rma the bad one for a replacement.

Print out the chkdsk reports by doing the following:Control Panel - Admin Tools - Event Viewer - Application. On the right side, look for Winlogon near the top. Open it - click the clipboard - close - open your word processor - paste - print.
January 4, 2007 2:21:21 AM

Look the damn thing is obviously got damage to it. If there isn't any blue sceen on death when booting, then the hard drive is either completely toast, or the Computer is not recognizing it. Check the cables, if they wiggled loose (MB and HDD). Some SATA cable tend to have that problem. I wouldn't trust the hard drive for anything important from now on.. If its got a warranty, RMA. If you need to get files off the thing, you can try a USB to IDE/SATA converter or what the previous posts suggest.
January 4, 2007 11:01:38 PM

Ok, I reinstalled windows and backed up my stuff on dvd through I failed data verification on two separate burns cause of one sector each time. I pulled the HD out and RMA it today. I yanked the HD out of a friend's comp I am building and am gonna use that till my RMA comes back. Thanks for the help everyone.
!