Sign in with
Sign up | Sign in
Your question

How can I disable com1 & lpt1?

Last response: in Windows 2000/NT
Share
Anonymous
July 15, 2005 7:55:08 PM

Archived from groups: microsoft.public.win2000.general (More info?)

Dell PowerEdge 1400 server and some other Dual-Processor PIII 1GHz.
Windows 2000 Server

I have 2 3COM PCI faxmodems that I have installed into them. Both do the
same: The Blue Screen on startup.

I have disabled COM1, 2 and LPT1 in my server's BIOS, to allow enough IRQ's
to be available for two 3COM PCI internal modems in the machine. In the
BIOS this appears correctly and it reports the devices. However, when W2K
(fully patched with all SP's and hotfixes) starts it detects com1, com2 and
lpt1 anyway, and then reports that the second modem has a problem. When I
force the IRQ's, after disabling the incorrectly detected com and lpt ports,
the machine crashes with a BSOD.

I moved the modems to a totally different server (a dual 1GHz PIII server)
and the problem is exactly the same, so my suspicion that the BIOS is the
problem, was proven wrong. It's actually windows 2000 server that stuffs
this up.

So my question is: Is it possible to tell W2K that no COM or LPT ports are
installed? (or alternatively I don't want auto-detection). I think then
I'd be able to manually config the modems to work correctly. Of course then
I would not want the modems autodetected either.

I have googled and searches microsoft for anything on this behaviour, but
come up emptyhanded.

Please help!

regards

Roland Giesler

More about : disable com1 lpt1

July 15, 2005 7:55:09 PM

Archived from groups: microsoft.public.win2000.general (More info?)

"Roland Giesler" <roland@giesler.za.net.nospam.me> wrote in message
news:ufg#TTUiFHA.3288@TK2MSFTNGP09.phx.gbl...
> Dell PowerEdge 1400 server and some other Dual-Processor PIII 1GHz.
> Windows 2000 Server
>
> I have 2 3COM PCI faxmodems that I have installed into them. Both do the
> same: The Blue Screen on startup.
>
> I have disabled COM1, 2 and LPT1 in my server's BIOS, to allow enough
IRQ's
> to be available for two 3COM PCI internal modems in the machine. In the
> BIOS this appears correctly and it reports the devices. However, when W2K
> (fully patched with all SP's and hotfixes) starts it detects com1, com2
and
> lpt1 anyway, and then reports that the second modem has a problem. When I
> force the IRQ's, after disabling the incorrectly detected com and lpt
ports,
> the machine crashes with a BSOD.
>
> I moved the modems to a totally different server (a dual 1GHz PIII server)
> and the problem is exactly the same, so my suspicion that the BIOS is the
> problem, was proven wrong. It's actually windows 2000 server that stuffs
> this up.
>
> So my question is: Is it possible to tell W2K that no COM or LPT ports
are
> installed? (or alternatively I don't want auto-detection). I think then
> I'd be able to manually config the modems to work correctly. Of course
then
> I would not want the modems autodetected either.
>
> I have googled and searches microsoft for anything on this behaviour, but
> come up emptyhanded.
>
> Please help!
>
> regards
>
> Roland Giesler
>
>
> Can you not let them install then choose "Dont use this.." in Device
manager?.

Jud
Anonymous
July 15, 2005 8:20:41 PM

Archived from groups: microsoft.public.win2000.general (More info?)

>> Can you not let them install then choose "Dont use this.." in Device
> manager?.

I've disabled the device already in device manager, but the IRQ is still in
use and causes the machine to crash :-(

Roland
!