Sign in with
Sign up | Sign in
Your question

DVD Read Maxing Out E6600

Tags:
Last response: in CPUs
Share
January 6, 2007 6:48:42 AM

I have posted about this problem before, but even with a new DVD writer, I am still having a problem when copying files from DVD's to disk. I am currently transferring avi's from a DVD to my HD and this is maxing out one of my E6600's cores and making my mouse movement and sound choppy.

1) Why would copying files (no ripping / conversion) max out a modern CPU core? Surely the DVD read speeds are no where near what the cpu can handle.

2) Why does having one maxed out core ruin my sound and mouse control when the other core is barely loaded?

Memory usage is low (1/4 of 2GB used) and here's the thing - this is not at all a problem when I copy from an IDE disk (IDE or USB connected), so why from an IDE DVD drive?

Last time I posted about this was during a software install, so other things could occur but now is a file transfer. Internet explorer seems to load pages quickly enough (I can set its affinity in Windows Task Manager, but don't know which processes control the mouse and sounds). I also downloaded the Microsoft update for dual-cores that you have to call them for but this obviously didn't help. While Task manager shows one core going full blast in the Performance tab, it shows only the 'System Idle Process' taking up any CPU (~95%) in the Processes tab (so what is taking up the cpu is not a process?).

Any ideas on what I can try to resolve this; dual-core CPU's were supposed to keep comps responsive even under load, right?

Thanks,
Jo

More about : dvd read maxing e6600

January 6, 2007 7:32:35 AM

Install the drivers for the controller the DVD drive is attached to. (Be it Intel, or someone else).

Confirm DMA Mode is enabled.

Upgrade the firmware on the DVD drive.
January 6, 2007 4:42:49 PM

OK so I've installed the IDE controller's drivers (JMicron for my MSI P965 Platinum) and upgraded to Pioneer DVR-111D's latest firmware (1.29). I went to the Device Manager to check for DMA and changed the Secondary IDE channel Device 0 (The DVD in question) to 'DMA if available' but it still lists the Current Transfer Mode as 'PIO Mode'. According to MS ( http://www.microsoft.com/whdc/device/storage/IDE-DMA.ms... ), some devices cannot be forced to use DMA.

Anyway the problem persists. I wonder if a SATA or USB dvd would still have this problem.

Thanks anyway for the tips Tabris.
Jo
Related resources
January 6, 2007 5:54:38 PM

Some testing update:

My XP2800+ w/ A7N8X-E Dx didn't break a sweat copying the same files using the DVD-RW that was giving me problems (BENQ I just changed out for a Pioneer).

Problem persists on these situations:

1) Main comp, even when transferring files direct from DVD to a portable USB drive.

2) My C2D T7200 laptop (Inspiron 6400).

SATA: The laptop & media center both use single sata drives as only HD's and mce works, laptop doesn't.

Dual-Core/C2D: Both comps with C2D have the issue; is this a dual-core issue or a C2D issue (anyone with an X2 have this problem)?

WinXP: I don't have linux on a dual-core so I don't know if that resolves anything.

Any Ideas?
Thanks,
Jo
January 6, 2007 5:54:55 PM

Damn,

You'll need to find out why the Pioneer optical doesn't want to enter DMA Mode, because PIO Mode is going to hammer the CPU every time that drive is accessed.

The 'CPU' usage will show in Task Manager at the bottom left of the window in the status bar, but the usage will not show up in most other places. (eg: System process is not going to be sitting at 99% or 49% CPU)

May also show up as Kernel Mode CPU usage [red line in chart if enabled], but other than that it'll be 'stealth legacy' I/O to the OS. (for lack of a better description).

It could be the cable, maybe Cable Select is in use vs Master jumpering, or the cable is faulty.

Or the controller the optical drive is on does not support DMA Mode on ATAPI devices ?

ED: The technical term for what is happening is an 'Interrupt Storm' or 'Interrupt Flood' - the reason purely being PIO Mode 1 - 4 is in use
January 6, 2007 6:00:32 PM

Oh, FYI

PIO Mode 1-4 is going to limit the peak throughput of the optical drive too, which may cause burns to fail or give very low quality burns with heaps of resumes being used on the media (more at higher speeds).

Ditto for peak read speed off the drive.
January 6, 2007 6:14:12 PM

I looked on the laptop too and both are in fact using PIO mode (not sure why). I also checked the desktop's DVD & it is definitely set on master.

Thanks for the info Tabris,
Jo
January 6, 2007 6:42:09 PM

MSI's site lists the onboard IDE support as:
Supports PIO, Bus Master operation modes

One of the newegg customer reviews says that BIOS Rev 1.2 allows UDMA, so I downloaded that but I have not done well with BIOS revs - after trying a BIOS rev on my A7N8X-E Dx, I could not boot and even the windows repair function after booting off the XP CD crashed. Can I just update my BIOS rev without losing my RAID or ability to boot off it? If it's risky, I'll just wait until I am reinstalling or going to Vista. As for the laptop, I guess I won't rip DVD's with it either.

Thanks,
Jo
January 6, 2007 6:53:34 PM

Sorry to ask what is probably a dumb question, but where do you go to see what mode the device is using? I can't find anywhere that says PIO or DMA for my DVD burner.

EDIT: So I did some more googling and I found out I was tampering with the wrong item in my device manager. I was playing with the Ultra ATA storage one instead of each IDE channel. I've toggled the settings (back) and to DMA if available, so next time I burn I'll see if I still have the same problems with the computer slowing down.
January 6, 2007 7:18:51 PM

I am having the same problems with my P5B-Deluxe and DVR111-D. It won't go into DMA mode. I ended up testing an old Pioneer DVD-120 and so far it is working great in DMA mode so I think my DVR111D is defective I am going to RMA it and I think you have the same defect and should to.
January 6, 2007 7:33:30 PM

OK I found part of the solution using this website: http://winhlp.com/WxDMA.htm - the gist of it is that Windows can revert to PIO permanently. Windows reverts to PIO to help with scratched / unreadable CD's and after a few errors like this, permanently reverts to PIO. The link provides the registry key to delete to reset the machine to UDMA and this worked on y laptop. Try this ChetCV & let me know if it works.

I also tried this on my desktop without success, so I think I would have to update the bios, but will likely just wait until I am reinstalling and until then rip dvd's on my laptop.

Jo
January 6, 2007 7:46:03 PM

Now that I read your post, I remember something I read in one of the PCF mags. Also about PIO mode being forced.

Have you tried the reg key on your dekstop in safe mode? Is PIO modes in your BIOS disabled?
January 6, 2007 10:25:11 PM

Thanks, I forgot about that little fact regarding a force PIO mode. That makes sense in my case. When I got my new rig up the DVR-111D was starting to give me read issues (slow rips, long seek times, inconsistant read speeds while ripping). It was in DMA mode at the time. After all that it probably force PIO mode.

Still going to RMA my DVR-111D, I really think that something is wrong with it since my old DVD-120 now in my new rig is working beatifully.
January 6, 2007 11:26:13 PM

HOW TO FIX
alright, ive had this issue come up before.

not sure why but ive seen my DVD drive revert to PIO mode, while the other drive on the same IDE cable was in DMA mode.

To fix this, go to device manager and find out what IDE chanell the drive is located on.
sometihng like
Primary IDE
Primary IDE
Secondary IDE

Mine was located on the second Primary IDE
right click on the Primary Ide where the drive was located and press uninstall
restart your computer, and windows will find a new device and set it up correctly in DMA mode.

This works.
January 6, 2007 11:49:16 PM

Quote:
I also tried this on my desktop without success, so I think I would have to update the bios, but will likely just wait until I am reinstalling and until then rip dvd's on my laptop.


I would be stunned if a new board for the core2 duo needs a BIOS update to run in DMA. DMA has been around for years and is the standard, due to the fact that PIO sucks.
January 7, 2007 5:03:19 PM

I uninstalled the Secondary IDE chain from device manager and rebooted but it is still locked in PIO mode. I also changed the MasterDeviceTimingMode from 10 to 2010, but this change is undone when I reboot or start copying from cd.

Jo
January 7, 2007 5:32:14 PM

thats strange, ive done that several times on different computers. Works everytime. I wonder whats going on with yours.
January 7, 2007 10:53:05 PM

Quote:
I uninstalled the Secondary IDE chain from device manager and rebooted but it is still locked in PIO mode. I also changed the MasterDeviceTimingMode from 10 to 2010, but this change is undone when I reboot or start copying from cd.

Jo


Try another IDE cable, one with 80 wires
January 8, 2007 4:31:13 AM

OK I was curious so I updated the BIOS to 1.2 like the newegg reviews said and of course it worked - UDMA Mode 4 and my file transfers are quick now. Well now my DVD drive works correctly and I know some things I didn't before so I'm happy about this experience.

Thanks for the helpful comments - I wouldn't have known what to google for before the PIO vs DMA mode discussion.

Jo
!