Sign in with
Sign up | Sign in
Your question

Cannot Ping OUtside - Cisco Pix 501 HELP!!

Last response: in Networking
Share
July 13, 2006 9:09:26 PM

I cannot seem to get ICMP to allow pings from inside my network to outside addresses. What have I done wrong???? HELP!!

PIX Version 6.3(5)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100

domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list 101 permit icmp any any
access-list 101 permit tcp any interface outside eq smtp
access-list 101 permit tcp any interface outside eq www
access-list 101 permit ip host 0.0.0.0 10.0.1.0 255.255.255.0
access-list 101 permit icmp any any echo-reply
access-list inside_access_in permit ip any any
access-list inside_access_in permit ip host 10.0.1.103 any
access-list 100 permit ip 10.0.1.0 255.255.255.0 192.168.10.0 255.255.255.0
access-list 100 permit icmp any any
access-list outside_int permit icmp any any
access-list inside_access_out permit icmp any any
access-list inside_access_out permit icmp any any echo-reply
access-list outside_access_in permit icmp any any echo-reply
access-list ping_acl permit ip any any
access-list ping_acl permit icmp any any echo-reply
pager lines 24
icmp permit any outside
icmp permit any inside
mtu outside 1500
mtu inside 1500
ip address outside nunya 255.255.255.248
ip address inside 10.0.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool VPNPool 192.168.10.20-192.168.10.30
pdm location 0.0.0.0 255.255.255.255 inside
pdm location 192.168.1.0 255.255.255.255 inside
pdm location 10.0.1.0 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 100
nat (inside) 2 access-list 101 0 0
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface smtp 10.0.1.104 smtp netmask 255.255.255.2
55 0 0
access-group ping_acl in interface outside
route outside 0.0.0.0 0.0.0.0 64.238.109.177 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
service resetinbound
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
telnet 10.0.1.0 255.255.255.255 inside
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh 0.0.0.0 0.0.0.0 inside
ssh timeout 30
console timeout 0
vpdn group PPTP-VPDN-GROUP accept dialin pptp
vpdn group PPTP-VPDN-GROUP ppp authentication pap
vpdn group PPTP-VPDN-GROUP ppp authentication chap
vpdn group PPTP-VPDN-GROUP ppp authentication mschap
vpdn group PPTP-VPDN-GROUP ppp encryption mppe auto
vpdn group PPTP-VPDN-GROUP client configuration address local VPNPool
vpdn group PPTP-VPDN-GROUP client configuration dns 10.0.1.100
vpdn group PPTP-VPDN-GROUP client configuration wins 10.0.1.0
vpdn group PPTP-VPDN-GROUP pptp echo 60
vpdn group PPTP-VPDN-GROUP client authentication local
vpdn username test password *********
vpdn enable outside
terminal width 80

More about : ping cisco pix 501

July 13, 2006 11:44:44 PM

Can you get anywhere outside of your network. Your configuration is definitely jumbled and bit confusing. At the moment I'm thinking its your access-list statements and which one you have applied to the inside interface.

Please clarify what you want the configuration to do exactly (such as build a tunnel) and stuff like that.

Also the first thing to do is remove any access-lists you have applied to inside and outside interfaces and see if anything works.
July 14, 2006 1:43:10 PM

Heres what I think you need to do. First off, remove all the NATing commands you have.


no nat (inside) 0 access-list 100
no nat (inside) 2 access-list 101 0 0
no nat (inside) 1 0.0.0.0 0.0.0.0 0 0
no global (outside) 1 interface


Then apply these commands. I think you are trying to create a LAN to LAN tunnel as well:


nat (inside) 0 access-list 100
nat (inside) 1 10.0.1.0 255.255.255.0
global (outside) 1 ethernet0 >>>I only input the interface name because I'm not sure if your ISP gave you a range of alotted Internet addresses.



Remove the follow ACL's and verify they aren't applied anywhere.

no access-list inside_access_out permit icmp any any
no access-list inside_access_out permit icmp any any echo-reply

no access-list outside_int permit icmp any any

no access-list inside_access_in permit ip any any
no access-list inside_access_in permit ip host 10.0.1.103 any

no access-list 101 permit icmp any any
no access-list 101 permit tcp any interface outside eq smtp
no access-list 101 permit tcp any interface outside eq www
no access-list 101 permit ip host 0.0.0.0 10.0.1.0 255.255.255.0
no access-list 101 permit icmp any any echo-reply


Go from here and let me know how it goes.
June 4, 2009 9:42:29 AM

Dear All,

i am very much confused about my PIX

i have CISCO PIX 6.3(5) having two interfaces
inside with IP = 10.0.0.1/24
outside with IP =192.168.168.1/24

i am connected with Internal interface and my PC(10.0.0.2/24 ) has a gateway of 10.0.0.1

now i want to ping from PC (10.0.0.2/24) to PIX outside interface IP i.e 192.168.168.1.
Please help me how ? by default it is not pinging.

Waiting for urs quickest response.

Regards,
Ishtiaq Ahmed
!