Windows 2000 large disk support (>137 Gig)

Archived from groups: microsoft.public.win2000.general (More info?)

Hello all - hoping to get some help...

I have a 160 Gig Maxtor HDD on a W2K system dual booting with W98.

The motherboard is an Abit KR7A Raid and the disk is on a raid controller,
which supports 48 bit addressing. Lates bios and drivers are used which all
support 144 bit addressing.

SP4 is installed and the large disk bit in the registry is enabled.

The disk is split into 3 roughly equal partitions which were formatted in
DOS as FAT32.

Disk Management reports the disk and each partition correctly with respect
to overall size and free space. The assigned drive letters are a bit all over
the place though. (I have 4 disks, all partitioned, although only 1 > 137 g)

However! Windows 2000 refuses to use the disk beyond 137 gig, and I am
completely lost as to why as everything seems OK. Does it not like that the
disk is partitioned? Does it not like FAT32?

Any ideas would be very welcome!

Thank you
5 answers Last reply
More about windows 2000 large disk support
  1. Archived from groups: microsoft.public.win2000.general (More info?)

    On Wed, 24 Aug 2005 11:35:45 -0700, "Magog" <Magog@discussions.microsoft.com>
    wrote:

    >Hello all - hoping to get some help...
    >
    >I have a 160 Gig Maxtor HDD on a W2K system dual booting with W98.
    >
    >The motherboard is an Abit KR7A Raid and the disk is on a raid controller,
    >which supports 48 bit addressing. Lates bios and drivers are used which all
    >support 144 bit addressing.
    >
    >SP4 is installed and the large disk bit in the registry is enabled.
    >
    >The disk is split into 3 roughly equal partitions which were formatted in
    >DOS as FAT32.
    >
    >Disk Management reports the disk and each partition correctly with respect
    >to overall size and free space. The assigned drive letters are a bit all over
    >the place though. (I have 4 disks, all partitioned, although only 1 > 137 g)
    >
    >However! Windows 2000 refuses to use the disk beyond 137 gig, and I am
    >completely lost as to why as everything seems OK. Does it not like that the
    >disk is partitioned? Does it not like FAT32?
    >
    >Any ideas would be very welcome!
    >
    >Thank you

    I have run 2 x 200 GB drives, the first in 3 partitions and the second in 2 on
    several different motherboards and never had any trouble. My latest board is the
    Intel board which requires either SATA drives or a ATA board to enable the use
    of PATA (parallel drives)
    You say the bit is set for large drive. Try checkinbg on this:

    Start/run/regedit
    select HKEY_LOCAL_MACHINE
    navigate to system/services/atapi/parameters or
    system/currentcontrolset/services/atapi/parameters
    right click for new
    Select Dword name it EnableBigLba (take note of case)
    set value to 1
    end regedit
    reboot

    Borge
  2. Archived from groups: microsoft.public.win2000.general (More info?)

    Hi

    Thanks for your answer.

    That's exactly what I did to set Biglba. Since then, I have run the little
    programme from maxtor which sets the bit and it tells me biglba already set.
    I have also used dumpreg to check. I think I have to believe it is set. But I
    just checked again! I have

    EnableBigLba REG_DWORD=0x1

    It's (sort of) nice to know the partitions shouldn't make a difference, but
    you do not say if you are using FAT32 or NTFS. Does that make a difference? I
    can't think why but I am lost.


    "nesredep egrob" wrote:

    > On Wed, 24 Aug 2005 11:35:45 -0700, "Magog" <Magog@discussions.microsoft.com>
    > wrote:
    >
    > >Hello all - hoping to get some help...
    > >
    > >I have a 160 Gig Maxtor HDD on a W2K system dual booting with W98.
    > >
    > >The motherboard is an Abit KR7A Raid and the disk is on a raid controller,
    > >which supports 48 bit addressing. Lates bios and drivers are used which all
    > >support 144 bit addressing.
    > >
    > >SP4 is installed and the large disk bit in the registry is enabled.
    > >
    > >The disk is split into 3 roughly equal partitions which were formatted in
    > >DOS as FAT32.
    > >
    > >Disk Management reports the disk and each partition correctly with respect
    > >to overall size and free space. The assigned drive letters are a bit all over
    > >the place though. (I have 4 disks, all partitioned, although only 1 > 137 g)
    > >
    > >However! Windows 2000 refuses to use the disk beyond 137 gig, and I am
    > >completely lost as to why as everything seems OK. Does it not like that the
    > >disk is partitioned? Does it not like FAT32?
    > >
    > >Any ideas would be very welcome!
    > >
    > >Thank you
    >
    > I have run 2 x 200 GB drives, the first in 3 partitions and the second in 2 on
    > several different motherboards and never had any trouble. My latest board is the
    > Intel board which requires either SATA drives or a ATA board to enable the use
    > of PATA (parallel drives)
    > You say the bit is set for large drive. Try checkinbg on this:
    >
    > Start/run/regedit
    > select HKEY_LOCAL_MACHINE
    > navigate to system/services/atapi/parameters or
    > system/currentcontrolset/services/atapi/parameters
    > right click for new
    > Select Dword name it EnableBigLba (take note of case)
    > set value to 1
    > end regedit
    > reboot
    >
    > Borge
    >
  3. Archived from groups: microsoft.public.win2000.general (More info?)

    Forgive me but I'm a little confused by your post.
    A 160gb hd partitioned into 3 all correctly identified in disk management
    with a drive letter assigned - yes?

    So what exactly do you mean by;
    > > >However! Windows 2000 refuses to use the disk beyond 137 gig

    Are you saying you have another slave disk that isnt identied/ cannot be
    accessed formated etc in disk management?


    "Magog" <Magog@discussions.microsoft.com> wrote in message
    news:A89B1BD6-B0F9-4E5B-BE3F-5ED2A8FCA531@microsoft.com...
    > Hi
    >
    > Thanks for your answer.
    >
    > That's exactly what I did to set Biglba. Since then, I have run the little
    > programme from maxtor which sets the bit and it tells me biglba already
    set.
    > I have also used dumpreg to check. I think I have to believe it is set.
    But I
    > just checked again! I have
    >
    > EnableBigLba REG_DWORD=0x1
    >
    > It's (sort of) nice to know the partitions shouldn't make a difference,
    but
    > you do not say if you are using FAT32 or NTFS. Does that make a
    difference? I
    > can't think why but I am lost.
    >
    >
    >
    > "nesredep egrob" wrote:
    >
    > > On Wed, 24 Aug 2005 11:35:45 -0700, "Magog"
    <Magog@discussions.microsoft.com>
    > > wrote:
    > >
    > > >Hello all - hoping to get some help...
    > > >
    > > >I have a 160 Gig Maxtor HDD on a W2K system dual booting with W98.
    > > >
    > > >The motherboard is an Abit KR7A Raid and the disk is on a raid
    controller,
    > > >which supports 48 bit addressing. Lates bios and drivers are used which
    all
    > > >support 144 bit addressing.
    > > >
    > > >SP4 is installed and the large disk bit in the registry is enabled.
    > > >
    > > >The disk is split into 3 roughly equal partitions which were formatted
    in
    > > >DOS as FAT32.
    > > >
    > > >Disk Management reports the disk and each partition correctly with
    respect
    > > >to overall size and free space. The assigned drive letters are a bit
    all over
    > > >the place though. (I have 4 disks, all partitioned, although only 1 >
    137 g)
    > > >
    > > >However! Windows 2000 refuses to use the disk beyond 137 gig, and I am
    > > >completely lost as to why as everything seems OK. Does it not like that
    the
    > > >disk is partitioned? Does it not like FAT32?
    > > >
    > > >Any ideas would be very welcome!
    > > >
    > > >Thank you
    > >
    > > I have run 2 x 200 GB drives, the first in 3 partitions and the second
    in 2 on
    > > several different motherboards and never had any trouble. My latest
    board is the
    > > Intel board which requires either SATA drives or a ATA board to enable
    the use
    > > of PATA (parallel drives)
    > > You say the bit is set for large drive. Try checkinbg on this:
    > >
    > > Start/run/regedit
    > > select HKEY_LOCAL_MACHINE
    > > navigate to system/services/atapi/parameters or
    > > system/currentcontrolset/services/atapi/parameters
    > > right click for new
    > > Select Dword name it EnableBigLba (take note of case)
    > > set value to 1
    > > end regedit
    > > reboot
    > >
    > > Borge
    > >
  4. Archived from groups: microsoft.public.win2000.general (More info?)

    On Wed, 24 Aug 2005 17:26:15 -0700, "Magog" <Magog@discussions.microsoft.com>
    wrote:

    Sorry about that, I am on NTSF apart from a Secure Zone 20GB which is FAT32 on
    G: logical which otherwise is NTSF.

    Borge

    >Hi
    >
    >Thanks for your answer.
    >
    >That's exactly what I did to set Biglba. Since then, I have run the little
    >programme from maxtor which sets the bit and it tells me biglba already set.
    >I have also used dumpreg to check. I think I have to believe it is set. But I
    >just checked again! I have
    >
    >EnableBigLba REG_DWORD=0x1
    >
    >It's (sort of) nice to know the partitions shouldn't make a difference, but
    >you do not say if you are using FAT32 or NTFS. Does that make a difference? I
    >can't think why but I am lost.
    >
    >
    >
    >"nesredep egrob" wrote:
    >
    >> On Wed, 24 Aug 2005 11:35:45 -0700, "Magog" <Magog@discussions.microsoft.com>
    >> wrote:
    >>
    >> >Hello all - hoping to get some help...
    >> >
    >> >I have a 160 Gig Maxtor HDD on a W2K system dual booting with W98.
    >> >
    >> >The motherboard is an Abit KR7A Raid and the disk is on a raid controller,
    >> >which supports 48 bit addressing. Lates bios and drivers are used which all
    >> >support 144 bit addressing.
    >> >
    >> >SP4 is installed and the large disk bit in the registry is enabled.
    >> >
    >> >The disk is split into 3 roughly equal partitions which were formatted in
    >> >DOS as FAT32.
    >> >
    >> >Disk Management reports the disk and each partition correctly with respect
    >> >to overall size and free space. The assigned drive letters are a bit all over
    >> >the place though. (I have 4 disks, all partitioned, although only 1 > 137 g)
    >> >
    >> >However! Windows 2000 refuses to use the disk beyond 137 gig, and I am
    >> >completely lost as to why as everything seems OK. Does it not like that the
    >> >disk is partitioned? Does it not like FAT32?
    >> >
    >> >Any ideas would be very welcome!
    >> >
    >> >Thank you
    >>
    >> I have run 2 x 200 GB drives, the first in 3 partitions and the second in 2 on
    >> several different motherboards and never had any trouble. My latest board is the
    >> Intel board which requires either SATA drives or a ATA board to enable the use
    >> of PATA (parallel drives)
    >> You say the bit is set for large drive. Try checkinbg on this:
    >>
    >> Start/run/regedit
    >> select HKEY_LOCAL_MACHINE
    >> navigate to system/services/atapi/parameters or
    >> system/currentcontrolset/services/atapi/parameters
    >> right click for new
    >> Select Dword name it EnableBigLba (take note of case)
    >> set value to 1
    >> end regedit
    >> reboot
    >>
    >> Borge
    >>
  5. Archived from groups: microsoft.public.win2000.general (More info?)

    Still not clear
    You have a 2nd hd that you cannot access?

    "nesredep egrob" <Long. -31,48.21 Lat. 115,47.40> wrote in message
    news:d3crg19j75gc6via55iug7fp63do83opuu@4ax.com...
    > On Wed, 24 Aug 2005 17:26:15 -0700, "Magog"
    <Magog@discussions.microsoft.com>
    > wrote:
    >
    > Sorry about that, I am on NTSF apart from a Secure Zone 20GB which is
    FAT32 on
    > G: logical which otherwise is NTSF.
    >
    > Borge
    >
    > >Hi
    > >
    > >Thanks for your answer.
    > >
    > >That's exactly what I did to set Biglba. Since then, I have run the
    little
    > >programme from maxtor which sets the bit and it tells me biglba already
    set.
    > >I have also used dumpreg to check. I think I have to believe it is set.
    But I
    > >just checked again! I have
    > >
    > >EnableBigLba REG_DWORD=0x1
    > >
    > >It's (sort of) nice to know the partitions shouldn't make a difference,
    but
    > >you do not say if you are using FAT32 or NTFS. Does that make a
    difference? I
    > >can't think why but I am lost.
    > >
    > >
    > >
    > >"nesredep egrob" wrote:
    > >
    > >> On Wed, 24 Aug 2005 11:35:45 -0700, "Magog"
    <Magog@discussions.microsoft.com>
    > >> wrote:
    > >>
    > >> >Hello all - hoping to get some help...
    > >> >
    > >> >I have a 160 Gig Maxtor HDD on a W2K system dual booting with W98.
    > >> >
    > >> >The motherboard is an Abit KR7A Raid and the disk is on a raid
    controller,
    > >> >which supports 48 bit addressing. Lates bios and drivers are used
    which all
    > >> >support 144 bit addressing.
    > >> >
    > >> >SP4 is installed and the large disk bit in the registry is enabled.
    > >> >
    > >> >The disk is split into 3 roughly equal partitions which were formatted
    in
    > >> >DOS as FAT32.
    > >> >
    > >> >Disk Management reports the disk and each partition correctly with
    respect
    > >> >to overall size and free space. The assigned drive letters are a bit
    all over
    > >> >the place though. (I have 4 disks, all partitioned, although only 1 >
    137 g)
    > >> >
    > >> >However! Windows 2000 refuses to use the disk beyond 137 gig, and I am
    > >> >completely lost as to why as everything seems OK. Does it not like
    that the
    > >> >disk is partitioned? Does it not like FAT32?
    > >> >
    > >> >Any ideas would be very welcome!
    > >> >
    > >> >Thank you
    > >>
    > >> I have run 2 x 200 GB drives, the first in 3 partitions and the second
    in 2 on
    > >> several different motherboards and never had any trouble. My latest
    board is the
    > >> Intel board which requires either SATA drives or a ATA board to enable
    the use
    > >> of PATA (parallel drives)
    > >> You say the bit is set for large drive. Try checkinbg on this:
    > >>
    > >> Start/run/regedit
    > >> select HKEY_LOCAL_MACHINE
    > >> navigate to system/services/atapi/parameters or
    > >> system/currentcontrolset/services/atapi/parameters
    > >> right click for new
    > >> Select Dword name it EnableBigLba (take note of case)
    > >> set value to 1
    > >> end regedit
    > >> reboot
    > >>
    > >> Borge
    > >>
    >
Ask a new question

Read More

Windows