Sign in with
Sign up | Sign in
Your question

Can't Boot when Drive on Marvell Cont. on D975xbx2

Last response: in Motherboards
Share
January 9, 2007 4:05:59 PM

I just upgraded my system. It seems to be working mostly fine. A few annoying quirks here and there.

Aside from those, I am having a major problem with the Marvell SATA controller. Whenever a drive is connected to the controller and the controller is enabled the system will not boot-up. The controller recognizes the drive, but after the Marvell configuration screen that shows every time one boots, the system just stops with a blinking cursor in the upper left corner of the display. If I hit F2 to enter the BIOS, I can get into the BIOS (immediately after the Marvell configuration screen), but it will never boot. It's doesn't seem to be dead, more like stuck.

I am not trying to boot from the Marvell controller, just use drives attached to it when I'm booting off the Intel controller. I also tried running the drives in RAID mode off the Marvell but the results were identical.

I tried working with Intel support. THAT was a disaster. I thought buying a motherboard with real support would be a bonus (after running DFI and some others), but the support was worse than useless. It was an insulting waste of time and effort. Their ultimate advice was "contact the manufacturer of each of drives to check for compatibility problems with the Marvell controller." I tried different drives even before calling Intel, and I'm sorry, but if there's a "compatibility problem" with Seagate, Western Digital, and Maxtor, then Marvell has a compatibility problem with the world, not vice versa.

They also suggested "perhaps" swapping out the MB for a new one, but they had no solid information on why, what was going on, or anything else computer related, and so I discount that recommendation. Additionally, I'm already on my second D975xbx2 trying to get this thing running properly. The odds are slim I'd have two bad boards, regardless, this is started to get silly. Everything in the world can't be broken, or can it? What a sad testimonial to the once mighty Intel that they can't even produce a batch of motherboard with more than 33% of them operational.

I'll run down the steps I took to try and isolate the problem: different PSUs, different video cards, different memory, and tried several different drives with varying manufacturers, sizes, SATA configs (150 vs. 300), one drive only, multiple drives, different Marvell connectors, various BIOS settings, like RAID vs. IDE vs. AHCI, etc. all to no avail. Blinking cursor in upper left hand corner. That's what I got.

Other than the CPU & the MB there's nothing else attached to swap out. I doubt its the CPU, which leaves the motherboard. The most difficult part to swap out and I got better things to do than operate as Intel/Marvell's R&D.

The Intel controller does not seem to have any issues.

My two questions are:

I've read some posts form people that complan the Marvel controller "doesn't work at all." Is anybody successfully booting up and then using drives when they are attached to the Marvell controller?

Does anybody have any idea what might be going on here? Is there something I'm missing or is another trip to the PC store in order (& who knows how many more at this rate.). Maybe I should just buy a 6 pack and return 5 after I find a board that works properly (or maybe a 12 pack or case is in order the way things are going).

My system:

Intel Core 2 Duo e6600 CPU
Intel D975xbx2 with updated BIOS (2395, 12/20/06)
Silverstone 750watt PSU (also tried Antec TP 2.0 550 & Thermaltake 480)
Genuine ATI x9150 pro (also tried ATI x700)
OCZ Platinum 7200 DDR2 Memory, 2 sticks, 2 GB (also tried Corsair 6400 pro)
A dozen different hard-drives from various manufacturers from 250GB up to 750GB, but not all connected at the same time.
Lite-on DVD-RW/RAM 18xDVD
A smattering of fans, well, 3 really. two 12cm, 1 8cm.

Any insight would be appreciated.
January 9, 2007 4:11:33 PM

Oops. I noticed a typo in my post. The video card is an ATI x1950 Pro, not a x9150 pro.
January 10, 2007 3:09:21 AM

Maybe I ought to just dump the Intel board altogether.

The problem is, there doesn't seem to be a proliferation of MB with 8 SATA connectors. Oh, sure, DFI has one, but after owning 3 DFI boards I'm tired of their support and the weird little things that don't work properly. I mean, have you seen how many tweaked BIOS are out there just to try and get the memory to work correctly? There must be a dozen or two. Plus the answers on their support Web portal are inane.

So, after working with PCs for over 25 years (yep, August 1981) I considered buyiing a system built completely by somebody else, like Dell, or Sony, or somebody else who isn't me. I've probably hand built 150 PCs in those 25 years, but I'm thinking of leaving the headache to somebody else that has a stack of motherboards, and a stack of memory, and a stack of PSU, sitting right there next to them to swap until it works.

Then I saw the prices. Goodness gracious. They cost twice what I can put one together for. I thought the rule was "the PC you want always costs $3000." In 1981 that 4.77Mhz 8088 was $3000, in 1989 that 80386-40 was $3000, in 1994 that 100Mhz Pentium was $3000, but the system that would most closely match mine is closer to $4500.

Darn it. Where's Gordon Moore when you need a good law on PC pricing?
Related resources
January 13, 2007 4:18:24 AM

Okay people, thanks for nothing.

My little old post is sitting out there and not one of you replies. Meanwhile I've replied to 16 other people's posts.

Are you too jaded, or is my problem just too difficult. Trust me, if it were obvious or easy I'd have fixed it long ago. I've been putting these things together for 25 years. For the math challenged that's as lonog as the PC has existed. August of 1981 the PC was announced, I got my first one in 1982. A friend gave it to me because it was broken. 4.77Mhz 8088 monochrome, no HD, though later I snagged a 20MB.

So what would you do if given a computer that didn't work, knowing that most people didn't even know what a PC was, let alone have seen one, let alone have touched one? You'd do what I did: fix it.

So I usually work out the easy stuff. Its the weird little gotchas (combined with shoddy Chinese manufacturing) that have me here.

Marvell. Intel. SATA. ... Hello? Is anybody out there? Is anybody listening? Wow, there's an echo in here. I can hear water dripping in the background somewhere. Its dank, dark, and claustrophobic. Can anybody help? Hello?
January 13, 2007 4:19:15 AM

Hey, I could do this all night if that's what you want.
January 31, 2007 7:23:31 PM

I found this thread while trying to search for the IDE vs AHCI issue.
I have the Bad Axe 2 and have the Marvell Raid working fine.

My single boot disk on on the ICH7.
SATA is set to IDE (not AHCI or RAID).

Never had an issue with the Marvell working.

What I am having problems with is getting the ICH7 to work as AHCI. F6, yadda yadda still gives me BSOD. Reformatting/etc - new build.
Maybe it does this because I already configured my Marvell?

Tonight I'm going to disable the Marvell, then attempt to install under AHCI. (more for the hot swap than NCQ).

So if it's not there now, try your SATA to IDE.
January 6, 2009 6:12:25 PM

Guys, I know this is a VERY old thread, but I was hoping that one of you might have solved this problem, or come across a solution.

I have the 975XBX2 as well, and it is definitely quirky when it comes to running SATA drives on both the Intel and Marvell controllers. All of my Intel SATA ports are full (two raid 1's) so I hooked up a Seagate 750 GB drive to one of the Marvell controllers. It boots fine the first time, but after that the system hangs indefinitely and won't boot. Once I remove the drive, all is well. I have updated to the latest drivers, BIOS, etc. and nothing seems to work. Did you ever sort this out on your end?

BTW, running Vista Ultimate. 8600GT card, E6600 (not overclocked), 4GB RAM.
February 18, 2010 7:52:47 PM

So, I ran across the exact same problem as the OP.
All I had to do was cycle the HDD boot order until the right one was on top.
This was made a bit difficult, because all 6 drives are the same make/model,
and there is no way to tell which is which. Stupid Intel. So, I just kept
pushing the top drive in the boot order to the bottom until it booted.
4 drives on the Intel SATA, and 2 drives on the Marvell, with the boot
loader on one of the Intel ports. Works fine now.


If Intel had any brains, they would list the HDD by both port number and
HDD make/model.

Anonymous
a b V Motherboard
April 24, 2010 7:59:18 AM

I had the same problem with Marvell on Intel D975XBX2 board, which would lose RAID entirely after I installed Windows on it. So, my solution was to use Intel controller for the HDD RAID, add an IDE DVD-ROM drive to boot/install from, and then add a SATA DVD burner to Marvell controller. This setup seems to work so far, BUT now I am having problems with Windows 7 Ultimate 64bit recognizing the new Blu-ray burner I added and connected to Marvell controller. The m/b BIOS and the Marvell BIOS are seeing it, Windows doesn't.
Anonymous
a b V Motherboard
May 5, 2010 7:59:27 PM

Did any one find a solution for the above problem?
!