Sign in with
Sign up | Sign in
Your question

Windows Installer & Services Issue

Last response: in Windows 2000/NT
Share
September 12, 2005 1:14:53 PM

Archived from groups: microsoft.public.win2000.general,microsoft.public.win2000.setup (More info?)

I'm having some problems on one of our servers. I'm thinking it's a Windows
Installer issue.

The main issue with the server is that I cannot install or uninstall any
applications. It just hangs. I've tried to uninstall our Veritas
BackupExec 9.1 and it will say preparing to remove application and just sit
there. I tried in Safe Mode and it says it cannot access the installer (not
sure if that's a normal error). I've tried this with other applications and
they are all the same.

I've tried unregistering the msiexec and re-registering it. I'm using
Windows Installer 3.1 v2 and I did check to make sure the msi.dll is the
correct version. It's 3.1.4000.2435

I also am having problems with the services mmc console. Whenever I try to
stop or start or change the startup of a service the mmc hangs.

I'm using Windows 2000 Server, with SP4. No errors in either the app or
system log. Everything runs normally at startup.

I can't get my Veritas BackupExec to recognize there's a tape in the drive
to run backups...that's the original problem.

Any help is appreciated!

Thanks!
-Beau
Anonymous
September 12, 2005 5:49:04 PM

Archived from groups: microsoft.public.win2000.general,microsoft.public.win2000.setup (More info?)

This may or may not be related to your problem but, A few weeks ago I started
having problems with MSI3.1 and Veritas Backup Exec. I could not remove or
install anything and my tape drives were in an "Offline" status. I contacted
my vendor about the strange problems I was having and he said that I needed
to boot into safe mode and disable my APC services. He indicated to me a
problem with my APC software version 6.x that caused problems with several
Windows components and Applications. I made the corrections and my system
started working properly..
I wouldnt have thought another application would cause these seemingly
unrelated problems,,,but it did. here is a link the the APC artical.


http://www.apc.com/solutions/display.cfm?ID=DEA020F8-50...

also

http://nam-en.apc.com/cgi-bin/nam_en.cfg/php/enduser/st...




"Beau" wrote:

> I'm having some problems on one of our servers. I'm thinking it's a Windows
> Installer issue.
>
> The main issue with the server is that I cannot install or uninstall any
> applications. It just hangs. I've tried to uninstall our Veritas
> BackupExec 9.1 and it will say preparing to remove application and just sit
> there. I tried in Safe Mode and it says it cannot access the installer (not
> sure if that's a normal error). I've tried this with other applications and
> they are all the same.
>
> I've tried unregistering the msiexec and re-registering it. I'm using
> Windows Installer 3.1 v2 and I did check to make sure the msi.dll is the
> correct version. It's 3.1.4000.2435
>
> I also am having problems with the services mmc console. Whenever I try to
> stop or start or change the startup of a service the mmc hangs.
>
> I'm using Windows 2000 Server, with SP4. No errors in either the app or
> system log. Everything runs normally at startup.
>
> I can't get my Veritas BackupExec to recognize there's a tape in the drive
> to run backups...that's the original problem.
>
> Any help is appreciated!
>
> Thanks!
> -Beau
>
>
>
Anonymous
September 12, 2005 5:52:04 PM

Archived from groups: microsoft.public.win2000.general,microsoft.public.win2000.setup (More info?)

Sorry,,,Just realized the MVP listed above answered it....



"Beau" wrote:

> I'm having some problems on one of our servers. I'm thinking it's a Windows
> Installer issue.
>
> The main issue with the server is that I cannot install or uninstall any
> applications. It just hangs. I've tried to uninstall our Veritas
> BackupExec 9.1 and it will say preparing to remove application and just sit
> there. I tried in Safe Mode and it says it cannot access the installer (not
> sure if that's a normal error). I've tried this with other applications and
> they are all the same.
>
> I've tried unregistering the msiexec and re-registering it. I'm using
> Windows Installer 3.1 v2 and I did check to make sure the msi.dll is the
> correct version. It's 3.1.4000.2435
>
> I also am having problems with the services mmc console. Whenever I try to
> stop or start or change the startup of a service the mmc hangs.
>
> I'm using Windows 2000 Server, with SP4. No errors in either the app or
> system log. Everything runs normally at startup.
>
> I can't get my Veritas BackupExec to recognize there's a tape in the drive
> to run backups...that's the original problem.
>
> Any help is appreciated!
>
> Thanks!
> -Beau
>
>
>
Related resources
Anonymous
September 12, 2005 8:18:37 PM

Archived from groups: microsoft.public.win2000.general,microsoft.public.win2000.setup (More info?)

Hi,

You haven't by any chance PowerChute 6.x UPS software (APC) installed
on the computer?

If so, upgrade it to v7 or uninstall it and see if that helps.


PowerChute 6.x cases a lot of issues, much more than what is described
here:

CRITICAL UPDATE REQUIRED PowerChute Business Edition - Customers Using
6.x Must Upgrade to 7.x due to Java Runtime Environment expiration
http://nam-en.apc.com/cgi-bin/nam_en.cfg/php/enduser/st...

Microsoft have published a knowledge base article for this issue as well:

System with APC Powerchute 6.x UPS Software gives strange symptoms
http://support.microsoft.com/kb/555386/


This is how you can disable the PowerChute service if you are unable to
uninstall it:

Start Regedit.exe

Locate the key
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\APCPBESERVER
Set the "Start" value to 4 (means disabled)

Locate the key
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\APCPBEAGENT
Set the "Start" value to 4 (means disabled)

Reboot the computer.


Regards,
Torgeir

Beau wrote:

> I'm having some problems on one of our servers. I'm thinking it's a Windows
> Installer issue.
>
> The main issue with the server is that I cannot install or uninstall any
> applications. It just hangs. I've tried to uninstall our Veritas
> BackupExec 9.1 and it will say preparing to remove application and just sit
> there. I tried in Safe Mode and it says it cannot access the installer (not
> sure if that's a normal error). I've tried this with other applications and
> they are all the same.
>
> I've tried unregistering the msiexec and re-registering it. I'm using
> Windows Installer 3.1 v2 and I did check to make sure the msi.dll is the
> correct version. It's 3.1.4000.2435
>
> I also am having problems with the services mmc console. Whenever I try to
> stop or start or change the startup of a service the mmc hangs.
>
> I'm using Windows 2000 Server, with SP4. No errors in either the app or
> system log. Everything runs normally at startup.
>
> I can't get my Veritas BackupExec to recognize there's a tape in the drive
> to run backups...that's the original problem.
>
> Any help is appreciated!
>
> Thanks!
> -Beau
>
>


--
torgeir, Microsoft MVP Scripting and WMI, Porsgrunn Norway
Administration scripting examples and an ONLINE version of
the 1328 page Scripting Guide:
http://www.microsoft.com/technet/scriptcenter/default.m...
September 13, 2005 12:53:33 PM

Archived from groups: microsoft.public.win2000.general,microsoft.public.win2000.setup (More info?)

Thanks...that fixed the problem! I appreciate the help!
-Beau

"~Qsecofr" <Qsecofr@discussions.microsoft.com> wrote in message
news:411FA341-441E-429C-9A0D-0436167FD472@microsoft.com...
> Sorry,,,Just realized the MVP listed above answered it....
>
>
>
> "Beau" wrote:
>
>> I'm having some problems on one of our servers. I'm thinking it's a
>> Windows
>> Installer issue.
>>
>> The main issue with the server is that I cannot install or uninstall any
>> applications. It just hangs. I've tried to uninstall our Veritas
>> BackupExec 9.1 and it will say preparing to remove application and just
>> sit
>> there. I tried in Safe Mode and it says it cannot access the installer
>> (not
>> sure if that's a normal error). I've tried this with other applications
>> and
>> they are all the same.
>>
>> I've tried unregistering the msiexec and re-registering it. I'm using
>> Windows Installer 3.1 v2 and I did check to make sure the msi.dll is the
>> correct version. It's 3.1.4000.2435
>>
>> I also am having problems with the services mmc console. Whenever I try
>> to
>> stop or start or change the startup of a service the mmc hangs.
>>
>> I'm using Windows 2000 Server, with SP4. No errors in either the app or
>> system log. Everything runs normally at startup.
>>
>> I can't get my Veritas BackupExec to recognize there's a tape in the
>> drive
>> to run backups...that's the original problem.
>>
>> Any help is appreciated!
>>
>> Thanks!
>> -Beau
>>
>>
>>
!