Sign in with
Sign up | Sign in
Your question

Hard drive won't boot

Last response: in Storage
Share
January 12, 2007 3:17:14 AM

Ok, first off I need to tell everyone that I have little experience in hard drives and RAID arrays,(less than anything else) I know the basics about RAID and I assembled my first homebuilt computer some 1.5 years ago. I used a WD2500KS for the hard drive on a Gigabyte GA-K8NXP-SLI mobo. I recently had a fairly serious windows error, and formatted the hard drive and did a fresh install of XP. After installing all of my drivers I decided to try and hook up my old IDE hard drive from a different computer as a slave to transfer some information. I'm assuming that is where I messed up. At first I booted like normal with the SATA drive and the IDE didn't show up in my computer, but it did show in device manager. I uninstalled the drivers and then let windows re-install them, still no dice. So I then went into my raid array and without thinking it through all the way I deleted my raid array with the Delete option. It asked if I wanted to clear the disk and I said yes. I enabled the IDE raid in my CMOS and configured the new array with the IDE on slave and the SATA on master, with the SATA booting as 1 and the IDE as 2. They were set in JBOD. I then tried to boot and got nothing. It went straight through both drives, onto my floppy, and then tried booting from CD. I disconnected the IDE drive and put the SATA back in a single JBOD array. Now I can't get the drive to boot at all. I know windows is there and in perfect condition. My Bios still recognizes the drive as well as my raid utility. I put my windows install disk in and went through the driver adding with F6 (nvidia raid and storage drivers are needed for this mobo) and let it load up. After accepting the agreement it showed the drive as 238gigs (same size as before) of unpartitioned space. I am stuck. I don't know whether it is a simple fix by installing the drivers again or if I will have to format and re-install. If it is just the drivers that need installing is there any way other than through F6 with windows install to do it? I really don't want to format again. If it is not the drivers, is there something in my Bios that should be changed? I have everything set the way it was before I tried connecting the IDE to the best of my knowledge. Any help is greatly appreciated.

More about : hard drive boot

January 12, 2007 4:04:54 AM

Disconnect the IDE.

Pop in the XP cd (put it first in the boot order,floppy, boot hd) and let the install take you to the first repair screen - press r taking you to the Recovery Console. If it asks for a password, just hit Enter. The installed XP should be listed. At the prompt type in both of these one at a time (hitting Enter):

fixboot
fixmbr

Take out the cd, reboot and pray.

Let us know; there are a couple of other things to try.
January 12, 2007 4:19:04 AM

ok, I followed those steps, and when I entered Fixboot, It gave me an error stating that the drive was not accessible, and fixmbr was successful. After rebooting the Hdd did not load the OS. If I have to reformat it isn't a total crisis. After reading around it seems that the mobo I used is pretty finicky about SATA Hdd's and people have had problems of varying types. Any other ideas?
January 12, 2007 5:23:58 AM

Try fixboot again. I'm sorry I gave it to you the wrong order. If the mbr worked - fixboot may do it. Worth a try. But it sounds like the RAID utility killed the partition.

Did you enable RAID for one drive? Why? JBOD on two different controllers?

Looks like a fresh install will have to be.

A note on dropping in old hd's, to do whatever with them. You can't set them up as Slave on the Primary IDE connection by itself. Set them up as Master on the Secondary IDE connection. If there's a cd/dvd on there now, rejumper it to Slave. Remember - Master on the end, Slave in the middle. You should hook it up that way now.

Rehook your Caviar up, disable RAID - there is no benefit with only one drive. Pop in the XP and go. Remember the boot order. List the old IDE last. I would delete any partition the install finds on the WD first.
Related resources
!