Sign in with
Sign up | Sign in
Your question

limited or no connectivity

Last response: in Networking
Share
July 27, 2006 1:02:09 PM

I have 2 computers on a wireless network. I have a linksys WRT54GS speedboost router. Yesterday afternoon I suddenly was not able to access the internet. Every page I went to gave me a "page cannot be displayed error."
When I rebooted I got an error message saying "limited or no connectivity." When I try to repair the network connection it says that it cannot get an IP address.

When I hook my laptop up directly to my cable modem, I can get internet.......but when I hook up my pc directly to the modem, I keep getting that limited connectivity error and no internet.
When i try to repair my network connection it says that it cannot get an IP address.

I cant get online with either my laptop or pc through the router even though my laptop picks up the wireless signal just fine.
My pc is getting an IP from the router, but I can't get online.

I've unhooked the modem and router several times before hooking them back up and nothing is working.
I've reformatted and had the cable company come out to check the lines.

Please help!!!

More about : limited connectivity

July 27, 2006 1:49:23 PM

Have you tried resetting the router to default using the reset button?

You say that your laptop is able to get online directly connected to the modem, but not your desktop. I'm wondering if your modem only allows one MAC address to lease an IP. Hook your modem up to the PC, and then reset the modem by unplugging it for a few seconds. Once it comes back up, try to repair your connection on the PC and I bet it gets an IP.

If it does, then do the same thing with the router. Connect the router to the modem, then reboot the modem. After it comes up, reboot the router the same way so it will try to lease an IP.

A lot of providers only allow the modem to talk to one MAC address as a way to prevent you just plugging the modem into a switch and having all your PCs get public IP addresses.
July 27, 2006 2:34:09 PM

Quote:
Have you tried resetting the router to default using the reset button?

You say that your laptop is able to get online directly connected to the modem, but not your desktop. I'm wondering if your modem only allows one MAC address to lease an IP. Hook your modem up to the PC, and then reset the modem by unplugging it for a few seconds. Once it comes back up, try to repair your connection on the PC and I bet it gets an IP.

If it does, then do the same thing with the router. Connect the router to the modem, then reboot the modem. After it comes up, reboot the router the same way so it will try to lease an IP.

A lot of providers only allow the modem to talk to one MAC address as a way to prevent you just plugging the modem into a switch and having all your PCs get public IP addresses.


Yes, I reset my router... same situation.

I unplugged my modem, unhooked the coaxial cable from the back of it, let it sit for a long time and also had my computer shut down. I connected the cable modem directly to my pc, plugged everything back in, booted my computer, and it was not able to connect at all. In the network connection window there is a red "X" saying 'not connected'

If I unhook everything again and let it sit for a while, then hook everything up to the router and plug it all back in.. I get the wireless signal with my laptop, it says there is a connection in the network connection window, but I cannot get online.. every page is "page cannot be displayed"
I get IPs from my router for both the pc and the laptop when the router is going, everything in ipconfig looks good on both machines... but no internet.

So.....

1--- PC hooked directly to cable modem: no connection

2--- PC and Laptop w/router: No connection, but I get good signal with laptop and correct IP's for each

3--- Laptop hooked directly to cable modem: fine

Could it be my pc network card?
Related resources
July 27, 2006 2:50:08 PM

I doubt it could be the network card since you're getting IPs from the router but no Internet.

When you are rebooting the modem, are you waiting for it to actually boot up and sync with the cable system before you turn on the PC?

I would connect everything back up the normal way with the router connected to the modem, bring up the modem first, then the router, and then use a PC to check the status page on the router to see if it is getting an IP address on the WAN. If it isn't then your ISP might be up to some sort of more devious tactics regarding their modems and leasing to more than one MAC address, or even maybe only "allowed" MAC addresses?

If it does get an IP, call a friend and have them ping it to see if it's actually online. If you can, enable the remote admin on the router so they can try to login (just to make sure it's actually your router they're pinging).

If the router is getting an IP, and your computers are getting IPs, but you still can't get online, then something is probably FUBAR with the router.
July 27, 2006 4:47:59 PM

Quote:
I doubt it could be the network card since you're getting IPs from the router but no Internet.

When you are rebooting the modem, are you waiting for it to actually boot up and sync with the cable system before you turn on the PC?

I would connect everything back up the normal way with the router connected to the modem, bring up the modem first, then the router, and then use a PC to check the status page on the router to see if it is getting an IP address on the WAN. If it isn't then your ISP might be up to some sort of more devious tactics regarding their modems and leasing to more than one MAC address, or even maybe only "allowed" MAC addresses?

If it does get an IP, call a friend and have them ping it to see if it's actually online. If you can, enable the remote admin on the router so they can try to login (just to make sure it's actually your router they're pinging).

If the router is getting an IP, and your computers are getting IPs, but you still can't get online, then something is probably FUBAR with the router.


Its not the router because I have completely unhooked it and ran the cable directly to my modem and it says that my IP address is: 0.0.0.0.
After a few minutes and a refresh it gives me the IP of 169.254.155.....
This is after I unplugged the modem and coaxial, let them sit, plugged them back in, let it come online and then booted my computer. I also rebooted just my computer after that and still the same thing.

When I hook everything up to my router as you suggested above.. letting the modem come up first, then plugging in the router, then booting the pc.... I get an IP for both my laptop and pc. On the router page, under router status almost everything is zeros.
but on the local network tab, it shows IP(192.168.1.1), MAC, and subnet.

I have called my ISP numerous times over the last 2 days, they came out yesterday and tested the lines and came inside and checked out the modem.. each time they insist there is nothing wrong on their end. The modem is working, I can get online with my laptop hooked directly to it, so they wont go any further.. they say the problem is within my computer.

I also just bought a new nic card, and it doesn't change anything.
I've also reformatted my computer so its running on just the basics because I cannot get online to do any updates.
July 27, 2006 5:54:06 PM

Quote:
Its not the router because I have completely unhooked it and ran the cable directly to my modem and it says that my IP address is: 0.0.0.0.


Then call the ISP back and tell them to fix it.
September 17, 2006 1:49:06 PM

I know this is and old post but I think I know the solution.

Is your ISP Cox Cable? Many of their domain servers have changed their subnet mask to 255.255.254.0. this will cause your issues as the default mask on your router is 255.255.255.0. (the ISP tech service will claim not to know what a subnet mask is so you wont get help there)

Cox internet security suite has been known to trash a computers ability to use a router beyon all other help than a reformat.
Try changing your subnet mask on your router to 255.255.254.0 and see if you can't get an addy. Check your routers addy to be sure it makes sense also. The addy it replies with will tell you what is happening on the ISP side of the network.
!