Sign in with
Sign up | Sign in
Your question

Connection drop with Intel Pro Wireless 3945 A/G Mini Card

Last response: in Networking
Share
July 29, 2006 7:05:21 PM

My sister just got a new Dell Inspiron E1505 that came with an Intel Pro Wireless 3945 a/g mini card and it has been an adventure to get the internet or any networking at all to work with the laptop. I instantly formatted the laptop since it came included with so much junk. I reinstalled Windows XP Pro SP2 and installed all the drivers for the video card, chipset, sound, and so on using all the drivers on Dell's support section. The drivers loaded fine for all hardware and was ready to go and I began setting up the network and it began have problems.

The wireless router I am trying to connect it to is a Netgear WGT624 using WEP 128 bit, mac filtering, and I have broadcasting disabled and it is using DHCP currently. Now these settings work fine for my laptop with an Intel Pro Wireless 2200, my father’s laptop with a Linksys WPC54G, my PSP, DS and everything else we have tried to connect to it, but this new laptop just does not want to work.

The drivers on Dell's site for the Intel card come with the software and I installed the software and tried to get it to work first with that. I could not get it to work without broadcasting, so I turned on broadcasting and it started working. So I began browsing the internet and then it just cut out and totally dropped the connection and the network entirely. It says that I need to enable radio even though it’s checked off at the bottom and was just working on radio 1 minute earlier. So, my first theory was to uninstall the software and try to use Windows wireless configuration which for some reason would not work without broadcasting either. So, I turned broadcasting back on for the windows one and I was able to connect. Once it connected, I tried the internet and got nothing. Now it never disconnects from the network, or it at least seems not to, but I never get the internet. At least with the Intel software I get the internet for five minutes.

My next theory was to totally disable the Windows wireless configuration and I proceeded to disable its service. So I did that and it did nothing different with the Intel software. It still connects for about five minutes and then just drops the entire connection. I was going to try switching to static IPs, but I am not sure if that would have anything to do with it or not. I am beginning to think it might be something with the card, but if it were the card I assume it would just not work period, so I don't know. The laptop also has a Broadcom 440x that is enabled but not in use at this time, but it will be needed in the future.

I also get an interesting message when the computer is on battery and tries to go to standby. I get the following:

"The device driver for the 'Intel PRO/Wireless 3945ABG Network Connection' device is preventing the machine from entering standby. Please close all applications and try again. If the problem persists, you may need to update this driver."

I had a feeling that it may be something with the driver. I went to Intel's site:

http://support.intel.com/support/wireless/wlan/sb/cs-01...

Those appear to be newer drivers, but I could be wrong. I tried those drivers before, but when I tried to apply the new drivers it said that it was no different then the ones currently on there. So, I did not try installing the software that came with that driver though, as I tried this new driver when I was trying to get it to work with the Windows wireless configuration. I guess I could try installing this new version of the software and maybe that will get it to work. I am running out of things to try and I really do not want to have to deal with any tech support people right now, so any assistance anyone could give me for this problem would be greatly appreciated.

Here are the specs and current driver versions:

Chipset: Intel Mobile Chispset, 1.66 GHZ Intel Core Duo T2300E. Driver: 7.2.2.1006, A09

Wireless Card: Intel Pro Wireless 3945 A/G Mini Card. Driver: 10.1.1.7

Wired Card: Broadcom 440x. Driver: 4.37.0.0

Modem: Conexant HDA D110 MDC v.92. Driver: 7.38.0.0

Video: Intel GMA 950. Driver: 6.14.0010.4543

Sound: SigmaTel Audio STAC 92XX. Driver: 5.10.4995.0001

Card Reader: Ricoh R5C832. Driver: 6.0.4069.1

Touch Pad: Synaptics Touchpad. Driver: 8.2.4.6

That is pretty much every driver that I installed. Also to note that when it has a connection it is getting an excellent signal at 54.0 Mbps. Thanks again.
July 30, 2006 1:13:35 PM

That is a std problem with wireless hardware and MS. MS energy saver policy is to turn off anything and everthing to make the battery last. It's not smart enough to see that you are using it.

You need check the energy management cp. Then check the properties of the card. There is a setting that you can uncheck so the power managment want turn off the card. SET to ALWAYS ON.
July 30, 2006 3:42:31 PM

In the properties for the card there was a check box enabled that says:

"Allow the computer to turn off this device to save power"

I unchecked the box and restarted the computer and I tested out the internet.
Even with the checkbox off it still continued to do the same thing that it did before. It gets the internet for the first five minutes and then it just drops the connection. There is nothing inside the windows power management that deals with it from what I can see from. Should I try a particular power management program that may completely stop this? Thanks for the suggestion and any further assistance would be greatly appreciated.
Related resources
July 30, 2006 6:43:58 PM

Does it do the same thing with the other wireless card?

Disable the other wireless card. Do not need both running.

Did you restart after make the changes?
July 31, 2006 8:06:16 AM

I had exactly same problem on the same notebook I was helping setup for a friend.

Blue68F100 is right. It has to do with the power settings for the Intel Pro wireless card.

I dont have the computer anymore so trying to recall from memory.

Go to Control Panel->System->Hardware Tab->Device Manager. Select Intel Pro under Network Adapters. Right Click and Select Properties. Under Advanced tab, there is a setting for Power Management. If I recall correctly, this is a slider with Max Battery on one end and Max performance on the other. You have to set it to Max Performance. This fixed it for me.

It maybe a bit different as it appears you are using a newer driver version but the general direction above should help you get to the same settings.

Hope it works. Good luck!
August 2, 2006 12:49:07 AM

I finally got it to work. I played around with the settings you guys recommended and it finally started working for good, not just for five minutes. Thanks for all the help.
September 18, 2006 7:23:30 PM

The one variable that you haven't described is the wireless card in your laptop. Based on the symptoms you've described, I would bet it's an Intel card (you can check your device manager to verify.) The problem is described below in both a link and a freehand description.

If it is an Intel (or Dell manufactured by Intel) you'll be happy to know there IS a solution. The problem has to do with an "undocumented feature" of the wireless called PSP (Power Save Polling) that works primarily when your laptop is running on the battery. This permits your wireless device to shut off devices (primarily newer routers) that it's connecting to in order to save power. The references on the Intel site (below) show you how to minimize the impact using your PC’s and Intel’s Power Management settings. To correct the problem permanently, however, you'll need to do the following:

You'll need to upgrade the firmware of your router to the latest available.

You'll also need to upgrade your Intel wireless driver to the latest available (from either Dell or Intel).

Then you'll need to make the following changes to the Wireless Router Settings:
Under the Advanced Wireless Settings:
Change the Beacon interval from 100 to 50

Change the fragmentation threshold from 2346 to 2306

Change the RTS threshold from 2347 to 2304.

Updating the router firmware and wireless device driver will fix the problem by about 80%. The three additional changes should make the problem "go away."

http://support.intel.com/support/wireless/wlan/sb/cs-00...
September 11, 2007 12:25:53 PM

Hello,

I also have an Intel pro/Wireless 3945 ABG, not in a Dell computer but in a Fujitsu-Siemens Amilo Pi 1536 notebook.
I have it just 1 day but I can't connect to my access point. Windows doesn't find any wireless network, and the Odyssey client that is delivered with the notebook does neither.
Now I've read the problem of gameniac85 but I don't understand how he has fixed that problem. Something with putting on broadcasting? I'm only 17 and I don't like experimenting or changing settings in my router... There are also 2 other computers connected to that router...

I have a Philips router, SNA 6501. I think all the settings are standard (i let the internet provider guy set up everything). No portforwarding.

I already changed the power managment setting of my intel network card in the device manager (just changed "standard value" to "maximum performance"). I hope that's ok...
I also downloaded the latest driver for the Intel Pro/Wireless 3945ABG, version 11.1.1.11

Now I hope someone can h[][/]elp me, it seems that you guys know what you're talking about. I really need an internet connection for my university studies.

I'm running a Windows Xp Home edition (I did'nt format it like gameniac85, but I disabled all the rubbish)

Thanks and excuse me for my english. I'm from Belgium.
Karel
September 17, 2007 5:31:21 PM

Similar problem with a Lenovo T60. Setting the Intel ProSet Power Management to maximum performance, does solve the problem. HOWEVER, whenever I sleep, power down, etc. the setting goes back to "Default". Anyone know how I can disable the "feature" of going back to Default?
October 8, 2008 6:35:34 PM

I realise this is an old issue, but thought I would add this. Yes, if you use the Intel Advanced power properties, the card will work, but as has been pointed out, the settings are lost if you reboot.

However, there might be a way to get around that. On the Sony laptop that was driving me nuts until I found this page, there's a part under the "Display/Screensaver/Power" section called "VAIO Power Management." Under the Wireless LAN section, changing the setting from "Power Saving" to "Standard" seems to have fixed this problem for me. And this setting has stayed no matter how many times I reboot the PC.

Granted this will only work for a Sony laptop, but other manufacturers might have a similar power section.
December 14, 2008 12:55:35 PM

hi everyone; i have been seeking a positive answer to this issue, however not of the replies were satisfying since i have tried all of the solutions offered by good intention. nearly one year later since i started i solved the problem and here it is:
this is unfortunatly intel wireles 3945 agn problem at all. i came to solution by simply changin security protocol; when i applied my security on the router as "TKIP or WEP or ANY OTHER" except "AES" protocol. the protocol TKIP especially disconnects ramdomly whn i start to watch movie online or download somthing which were my obvious symptoms i have been experiencing. yesterday i changed the protocol from modem at first from TKIP to AES and also adjusted my intel pro/wireless adaptor on the notebook accordingly and that woked great. it is no matter you installed the latest software from intel the problem will continue as before as interminent loss ol connection. thus pls follow the way i did and you will see everything will work fine and you will not see any disconnection. pls share your feedback with me at candilite@hotmail.com and if you can go further advise intel to fix this bug accordingly since i dont think my english is enough to tell in detail. i apologise for my poor english also since i am from turkey and can expain this way only.
kind regards
Anonymous
a b F Wireless
November 23, 2009 3:12:51 PM

BeckoningChasm said:
I realise this is an old issue, but thought I would add this. Yes, if you use the Intel Advanced power properties, the card will work, but as has been pointed out, the settings are lost if you reboot.

However, there might be a way to get around that. On the Sony laptop that was driving me nuts until I found this page, there's a part under the "Display/Screensaver/Power" section called "VAIO Power Management." Under the Wireless LAN section, changing the setting from "Power Saving" to "Standard" seems to have fixed this problem for me. And this setting has stayed no matter how many times I reboot the PC.

Granted this will only work for a Sony laptop, but other manufacturers might have a similar power section.



Hi,
I am having the same problem on my Sony Vaio. Where do I find "Display/Screensaver/Power. Where do I find it? Under Vaio Power Management, I did not see Power Setting options --Standard or Power Saving. Could you pl. elaborate--step by step? Many thanks. -- Ned
Anonymous
a b F Wireless
November 25, 2009 6:55:11 PM

BeckoningChasm said:
I realise this is an old issue, but thought I would add this. Yes, if you use the Intel Advanced power properties, the card will work, but as has been pointed out, the settings are lost if you reboot.

However, there might be a way to get around that. On the Sony laptop that was driving me nuts until I found this page, there's a part under the "Display/Screensaver/Power" section called "VAIO Power Management." Under the Wireless LAN section, changing the setting from "Power Saving" to "Standard" seems to have fixed this problem for me. And this setting has stayed no matter how many times I reboot the PC.

Granted this will only work for a Sony laptop, but other manufacturers might have a similar power section.


BeckoningChasm -- I don't what you are referring to when you say "I found this page". Which page and where can I find it? I have Sony VGN-FS875P/H running Win XP. About 4 yrs old. I am not sure if it has this page or "Display/Screensaver/Power" you are referring to. It is almost impossible to access the Internet because of this problem. Would greatly appreciate your further insight. Is there any I can speak with you over the phone?
Many thanks.
Ned
January 17, 2010 7:06:50 PM

I am having the same problem with a Lenovo x60t. it keeps losing connection after 5 mins. I have to right click-->disable / enable and it works for another 5 mins. please help!
January 26, 2010 12:54:16 PM

motamedn said:
I am having the same problem with a Lenovo x60t. it keeps losing connection after 5 mins. I have to right click-->disable / enable and it works for another 5 mins. please help!

Me too! I ordered a replacement, am going to install it in a few min...
April 25, 2011 5:48:34 AM

BeckoningChasm said:
I realise this is an old issue, but thought I would add this. Yes, if you use the Intel Advanced power properties, the card will work, but as has been pointed out, the settings are lost if you reboot.

However, there might be a way to get around that. On the Sony laptop that was driving me nuts until I found this page, there's a part under the "Display/Screensaver/Power" section called "VAIO Power Management." Under the Wireless LAN section, changing the setting from "Power Saving" to "Standard" seems to have fixed this problem for me. And this setting has stayed no matter how many times I reboot the PC.

Granted this will only work for a Sony laptop, but other manufacturers might have a similar power section.

I understand this is a very old message but my Sony VAIO is driving me crazy, i manage to follow your instructions to "VAIO Power Management" but there is no option of changing the setting from Power Saving to Standard. Thanks
Ed
January 5, 2012 10:31:55 AM

Hi everyone, hopefully my reply will help out as I have just spent the last 3 days with the same problem of the internet dropping every 5 minutes and FINALLY after following all the great advice on this thread I stumbled across a solution I thought only fair to share as I know how stressfull problems are to sort.

I have a Acer aspire 5920 laptop with the Intel R pro wireless 3945ABG internet card

same problem of the internet dropping every 5 mins, as stated I tried all the above methods with no solution and then I remebered I had updated the driver for the above wireless card 3 days ago so I re installed the old driver and I now have no problems (touch wood) after 24 hours.
I did this by entering START then CONTROL PANEL , selected classic view from left column, clicked on DEVICE MANAGER, then clicked on the plus on Network adapters which opens up your intel wireless 3945 card. Right click and select PROPERTIES which opens up the properties box, then at the top select the DRIVER tab, click the ROLL BACK DRIVER option , this then reverts back to the previous driver and I no longer have any problems.

Hope this can be of some help to another frustrated computer user :D 

!