Serious GFX card problem - Please help

Hey everybody

Here's the story. I've just bought some components for an upgrade.
A PSU, CPU HSF and a Powercolor Radeon X1950 Pro 512MB.

I proceed to installation, but already encounter a problem - I forget to uninstall the previous nVidia driver before removing the matching card.
I carried on with installation, plugged the monitor into the new ATi card, everything boots, all is well.
I uninstall the nVidia driver and attempt to install the ATi driver. This is where the problems start.

After clicking on 'Install xxxx driver' on the ATi installer, the full screen splash screen pops up, and everything crashes to a halt. The entire system freezes up, even the mouse, nothing can be done.

Basically, after this happened, I spent the rest of the day trying to find a solution. Here's a list of what I've tried. In order.

- Run Driver Cleaner.
- Format and installed XP64bit (I was previously using XP Home).
- Install ATi driver on clean format, same crash happens.
- Format back to XP Home. Try it again on clean install. Same crash.
- Download latest ATi driver and another older version. Both crash the same way.
- Install Omega driver. Same crash.
- Update Motherboard driver. No change.

I'm pretty much out of solutions. Please help me!

My system specs are:
P4 3.0Ghz
ASUS P5LD2 mobo
2 X 512MB Corsair value RAM
Powercolor Radeon x1950 Pro 512MB
previously card was Leadtek Quadro FX 540 128MB.
Silverstone 500W PSU with two 12V rail at 18Amps each.

Somebody suggested it maybe insufficient power. The card suggests 450W with 12V at 30Amps, but does this mean 30Amps on a single rail? Or both combined?

Your help would be greatly appreciated.
51 answers Last reply
More about serious card problem help
  1. Ok... I'm gonna put my old card back in just to make there's no problems with the rest of the system.
  2. I doubt it's a power supply problem, but that can't be ruled out. I'm leaning towards a bad card... On the software side of things you've done pretty much everything you can, so the problem isn't there.

    Either way it's either not enough power OR the card is bad. MY suggestion would be to RMA the card. If it still locks up then you need more power... but if it doesn't then you just saved yourself another $150 for a more powerful PSU.

    good luck and god speed son.
  3. Hey thanks man.
    I'm gonna call the store up now.

    Btw, my old card is in again and works fine, so there's nothing wrong with the system.

    EDIT: I've just sent out their RMA request form. Requested for refund.
    Screw ATi, I'm going back to nVida.
  4. lol. don't blame ATI... blame powercolour.
  5. ^ That's true.

    Should have listened to my friend when he said Powercolor sucks. :(
  6. next time go with the Sapphire Radeon X1950Pro. i dont know much about ati's products and all, but i've heard that they are a trustworth company.
  7. The X1950Pro isnt supported on many of the Cat. releases. Are you using the drivers that came on your factory install CD?
  8. Quote:
    next time go with the Sapphire Radeon X1950Pro. i dont know much about ati's products and all, but i've heard that they are a trustworth company.

    I'm hoping that this post is just a joke, if it's not, then :roll:

    Sapphire makes the "Built by ATi" cards anyways.
  9. Quote:
    The X1950Pro isnt supported on many of the Cat. releases. Are you using the drivers that came on your factory install CD?


    I have tried the factory CD, two other downloaded Catalyst drivers and the Omega driver.
    The all have the same result, ending in exactly the same crash.
  10. While your drivers install, they enable the features of your card, if something on the card isn't working, or the features start drawing more power than whats available, your system will hang/crash. I went through it with a 7800GS a while back, my graphics slot wasn't putting out enough juice, so I had to flash my mobo bios to fix the problem.

    Good luck.
  11. So you updated your BIOS are it worked?

    My PSU is 500W with two 12V rails at 18Amps. The card suggests a 450W with 12V at 30Amps. I don't know if that's 30Amps on a single rail or the total added.
  12. Quote:
    So you updated your BIOS are it worked?


    Yes, my post's about it are buried here somewhere.
  13. BIOS flash successful.
    Is there anything else that I should do before trying the ATi card again?

    Thanks.
  14. It was a newer bios wasn't it?
  15. Way newer I believe.
    I check the version before flash and it was 09XX the new one is 1702.
  16. Cross your fingers and try the card man...
  17. Wish me luck! :?
  18. Good luck man :!:
  19. Luck and new BIOS couldn't save it. :cry:
    Back to the shop for this card.
  20. Quote:
    next time go with the Sapphire Radeon X1950Pro. i dont know much about ati's products and all, but i've heard that they are a trustworth company.

    I'm hoping that this post is just a joke, if it's not, then :roll:

    Sapphire makes the "Built by ATi" cards anyways.

    as i said...i dont know jack sh17 about ati or the companies that make ati cards... i know nvidia.
  21. by any chan¿ce you have sygate firewall or a older version of the zonealarm?
    I heard there was some errors with catalyst and some versions of sygate causing a total crash.

    in other hand, tried running in safe mode?
    or try using the msconfig tool to remove everything except the driver inthe startmenu and the "services"
    so you know your card is fully defective.
  22. ...or try it in another machine.....with the drivers.
  23. Quote:
    So you updated your BIOS are it worked?

    My PSU is 500W with two 12V rails at 18Amps. The card suggests a 450W with 12V at 30Amps. I don't know if that's 30Amps on a single rail or the total added.


    You don't just add up the amps from both rails. Does it say a wattage below the +12V rails or better yet can you tell me the brand and model?

    Chances are that PSU is putting out around 25-26A and not 32A and possibly lower. Could be the source of the problem.
  24. Unfortunately, there isn't another machine that I can try the card on.

    The PSU is Silverstone Element ST50EF 500W.

    On the specs it says "Combined +12V: 432W/36A"

    Also, my friend mentions that it's a possibility that the PCI-e connector on the PSU could possibly be configured differently from what the GFX card needs?
    Would be it relevant to try using the card's own molex adapter?
    EDIT: I've had a look at the card's adapter, and the configuration appears to be the same, i.e. Black wires on top and yellow on the bottom.
  25. I've sent the card back to the shop. They tested it and have just emailed me saying it works...

    So... It's not a faulty card... I'm totally confused, why the hell wouldn't it work on my computer???
  26. hmm...well, either the shop is screwing with you so they dont have to send you a new one or your computer just will not support the card at all. i dont remember if you covered this already, but have you tried putting the card in someone elses computer? or just try a different card all together. and hell, if the card works for them, but not for you, get yourself your money back and get another card.
  27. Thanks LambofGod.
    I don't have another computer I could try the card on.

    I previously had a Leadtek Quadro FX 540 card which never had a problem.

    EDIT: I'll see if I can take my PC to their store and see what they can do about it.
  28. Well what a spot of luck (well in your case no). I just bought the same card but the 256mb version. When I put it in my system (if my motherboard arrives in the next year :roll: ) with a 430W psu with a single 18A 12V rail, I'll tell you if its a psu problem or not :lol:
  29. ^Ah, excellent. Thanks. Look forward to it soon. :D
  30. Ok then the PSU is no problem :?
  31. have you tried updating all of the drivers you can? sometimes even a small bios setting can screw your entire system up. check your peg link frequency. default is 100. if it's set to auto, the bios might change it up.

    usually when i have computer problems, i rip the power cord out of the wall, curse a lot, throw things, curse some more, plug the pc back in and start it back up (while cursing at it...), keep trying, and it eventually runs fine (once in a while, i kick my door open for extra "umph"). i dont think that will work for you though.
  32. ^ Software-wise, I did everything I could, including updating BIOS.

    I don't know this 'peg link frequency though'. I'll look it up.
    Thanks.

    EDIT: In my motherboard manual it has a setting called "PCI Express Frequency". Is this is it? It states that it is set to auto by default.
    I'll check out what frequency it's on now.

    EDIT: To alter this setting, I have to set the overclock mode to manual - default is auto. Once I set it to manual, it gives a list of all the overclockable components. All are set to auto but the CPU has a value of 200.

    The PCI-e frequency is indeed set to auto, and can be set to values of 90 - 150. I'm don't know much about this stuff so I didn't touch it. :?
  33. We use Radeon cards at work for dual output displays, we were alwys having a problem with the latest ATI drivers and catalyst control centre. Poking around google we found some need the .net framework 2 fix for ATI.

    Of course this assumes there is no hardware fault :) Not sure if this will help but may be worth a try.

    Freak
  34. ^ Glad you bought it up, freak.
    I have heard about this .Net thing being related to the driver issues.

    I remember snooping around in the Catalyst driver folder after installing it (it didn't work ofcourse).
    I opened up the 'installation configuration.txt' file, or some name along that tune, and under one of the entries it read something along the lines of "Detect .Net framework on install: 0". 0 in this case referring to 'no'.
  35. Could you elaborate on this fix freak1982?
  36. Quote:
    AMD/ATI have released their latest set of video card drivers for the ATI Radeon line of video cards. New 32 and 64-bit drivers are available for Windows XP. Note that the .NET framework (1.x or 2.0) is required if you want to run these drivers with the Catalyst Control Center.


    Could this possibly have been the culprit?

    EDIT: Also, about the PEG BIOS controls.
    I've found them. Their are a few entries under chipset settings.
    - Peg butter length
    - Link latency
    - PEG root control
    - PEG link mode
    - Slot power (!) This allows the adjustment of power supplied to the PCI-e slot, this may have been a cause.
  37. when i put my system together the peg link was set to auto, and it made my system unstable. it wasnt till i set the peg link to manual at 100 that it became stable, thats why i suggested it.
  38. I'm going to take my computer to the store now and see if they can get it working.
  39. Hahaha! You won't believe this.
    The guy at the store got it working in minutes.
    He said he installed the drivers only, so it must have been the Catalyst software that was causing all the trouble.

    Would anybody please care to tell me how one goes about installing only the driver from the CD?
  40. Well, you can do it from Windows directly (install new drivers and search them out on CD) or you can download JUST drivers w/ no catalyst control center from ATI's website.
  41. ^ Excellent, thanks.

    I'm still wondering why the Catalyst software screws up though.
    What benefits do I get from the software? Do I really need it?
  42. It probably screws up because you don't have the .NET framework or something. If you want to keep messing with the catalyst control center you can always download this .net 2.0 update:

    http://www.microsoft.com/downloads/details.aspx?familyid=0856EACB-4362-4B0D-8EDD-AAB15C5E04F5&displaylang=en

    Catalyst Control Center allows you to do things like monitoring your temperature, color-correction, and advanced graphics card settings. Nothing incredibly useful for the average user. Plus, you can always download ATI Tool to check temps and OC:

    http://www.techpowerup.com/atitool/downloads.php

    Anyway, glad you got it working at least. :D
  43. Thanks for link.
    I actually found the .Net install on the ATi CD, lol.
    The sad thing is, I install it then tried running the Catalyst software again, but it still won't install.

    Oh well, I'll just have to leave it.
  44. Strange. So, have you tried running any games to make sure you are OK? Any torture tests?
  45. ^ Yeah, the card's working alright, that' for sure.

    Just as a test, I went into the ATi driver CD, found the driver folder and tried running just the driver setup, but it doesn't work either. :?
    I'm hoping installing it through Windows will work or I'm screwed, because I have to install it again after I format.
  46. Catalyst control centre, the scourge of video-related software. Bloated, RAM hog (sometimes well over 100mb), takes forever to load... why ATI (or should I say AMD?), why? Reminds me of x-fi drivers. Use ATI Tray Tools instead. Does all that CCC does and more and uses only a fraction of the RAM and takes minimal time to load.
  47. Go here:

    http://ati.amd.com/support/drivers/xp/radeonx-xp.html

    Download the one that says "Display Driver Only", and you should be OK.
  48. ecca: Thanks, I'll get this ATi Tray Tools. Hopefully it won't crash.

    dean7: Thanks for the link.
    The funny thing is, I've just uninstall the driver as a test. Rebooted, and now all of a sudden, Windows decides to automatically detect the card and installed the drivers. :roll:

    EDIT: The Tray Tool works fine. :D
    Cheers.
  49. Well, it auto-detected and installed this time because you already installed the drivers it needs, so even though you clicked "uninstall" it didn't remove the drivers from your HDD and was able to find them this time. Make sense?
Ask a new question

Read More

Graphics Cards Graphics Product