Sign in with
Sign up | Sign in
Your question

Do you think my Power Supply is dieing?

Last response: in Components
Share
January 16, 2007 8:24:20 PM

I built my own PC from Newegg.com about 2 years ago and it worked perfect until about 3 months ago. Now every time I click shutdown from Windows it gets to the part where all the power is supposed to go out but it doesn't. The screen just goes black but the computer is still on (I can see the lights and hear it) It never did that before. I even reinstalled Windows to see if that would fix it but it didn't. I tried using my brothers graphics card/memory stick and it still isn't shutting down unless I switch the power supply button in the back of the PSU off each time I shut down. Does anyone know if this is a common PSU dieing problem or is it something else? Also, it seems like my PC takes longer to start up than it used to. It used to start up in like 20 seconds but now it takes about 1 and a half to 2 minutes.

This is the Power supply I have
APEVIA ATX-AS520W-BK ATX 520W Power Supply 115/230 V CB IEC 950/ TUV EN 60950/ UL 1950/ CSA 950 - Retail
http://www.newegg.com/Product/Product.asp?Item=N82E1681...

I have an ABIT NF7 Motherboard, 3000+ AthlonXP and a GeForce6800GT

More about : power supply dieing

January 16, 2007 9:33:28 PM

I just tried using my brothers PSU on my PC and it's still doing the same thing so you're right about that. I'm gonna check my motherboard out now and make sure all the switches are in tight. I'll probably get that better PSU anyway since mine is crap. Thanks
!