Sign in with
Sign up | Sign in
Your question

My Documents Folder Redirection Stuck on Wrong Path

Last response: in Windows 2000/NT
Share
June 24, 2004 1:32:04 AM

Archived from groups: microsoft.public.win2000.group_policy (More info?)

I apologize in advance if this has been covered already but I did some
exhaustive searching and could not come up with a solution.

I have a client with a Windows 2000 server and a number of Windows XP
workstations. The network and all hardware was setup by someone prior
to me so I'm not completely familiar with all of the details, however,
I do know that the My Documents folder for each user is setup with
folder redirection to the server and offline file synchronization is
taking place. I checked the GPO in the Active Directory Users and
Groups MMC on the server to confirm that this was the setup.

At any rate, here's the problem. Some of the users can login to their
PCs and the My Docs folder is properly redirected to the folder
'\\server\users\%USERNAME%' while a few others login and their My Docs
folder is redirected to a folder with the name '\\server\users\user'
(with 'user' being the actual name of the folder). The problem is
that the users that are redirected to the 'user' folder are storing
their docs in the same place and they don't particularly want the
other people to see their docs. In other words, they would prefer to
have their own folders.

I performed an experiment with the receptionist who is experiencing
this issue and had her login to another PC on the network. At that
workstation, her My Docs folder was properly redirected to
'\\server\users\%USERNAME%' but of course there were no documents
actually stored in the My Docs redirected folder when she logged into
the network from this PC. It would seem as though the redirection has
either been hard-coded on several of the workstations or something
else is up...

Here's what I've tried. I tried using the command 'gpupdate /force'
at the workstation and I also tried a command on the server 'secedit
/refresh user_policy' but neither made a difference for the
receptionist upon restarts or logoff/logon. I did manage to locate a
couple of registry keys that contained the path '\\server\users\user'
on the receptionist's PC while she was logged in, but was afraid to
change them as I didn't want to lose any data or cause problems in
some other way. Also, I feel like the policy should change these
paths since it (the policy) appears to be configured correctly. Is
there any way that the policy is somehow not recognizing the correct
username when these users login and redirecting them to this 'user'
folder by default? Any suggestions on how to get this working
properly short of editing the registry? If I have to edit the registry
on each workstation in order to get it working I will, but I'd feel
better hearing it from someone with a little more knowledge.

I don't have much experience with GPOs so any and all assistance is
very much appreciated.

Thank you for your time and assistance,

Drivie
June 28, 2004 3:05:34 AM

Archived from groups: microsoft.public.win2000.group_policy (More info?)

Any assistance at all, please?

Thank you,

Drivie

drivie@hotmail.com (Dan) wrote in message news:<e5bf79ee.0406232032.3ba38559@posting.google.com>...
> I apologize in advance if this has been covered already but I did some
> exhaustive searching and could not come up with a solution.
>
> I have a client with a Windows 2000 server and a number of Windows XP
> workstations. The network and all hardware was setup by someone prior
> to me so I'm not completely familiar with all of the details, however,
> I do know that the My Documents folder for each user is setup with
> folder redirection to the server and offline file synchronization is
> taking place. I checked the GPO in the Active Directory Users and
> Groups MMC on the server to confirm that this was the setup.
>
> At any rate, here's the problem. Some of the users can login to their
> PCs and the My Docs folder is properly redirected to the folder
> '\\server\users\%USERNAME%' while a few others login and their My Docs
> folder is redirected to a folder with the name '\\server\users\user'
> (with 'user' being the actual name of the folder). The problem is
> that the users that are redirected to the 'user' folder are storing
> their docs in the same place and they don't particularly want the
> other people to see their docs. In other words, they would prefer to
> have their own folders.
>
> I performed an experiment with the receptionist who is experiencing
> this issue and had her login to another PC on the network. At that
> workstation, her My Docs folder was properly redirected to
> '\\server\users\%USERNAME%' but of course there were no documents
> actually stored in the My Docs redirected folder when she logged into
> the network from this PC. It would seem as though the redirection has
> either been hard-coded on several of the workstations or something
> else is up...
>
> Here's what I've tried. I tried using the command 'gpupdate /force'
> at the workstation and I also tried a command on the server 'secedit
> /refresh user_policy' but neither made a difference for the
> receptionist upon restarts or logoff/logon. I did manage to locate a
> couple of registry keys that contained the path '\\server\users\user'
> on the receptionist's PC while she was logged in, but was afraid to
> change them as I didn't want to lose any data or cause problems in
> some other way. Also, I feel like the policy should change these
> paths since it (the policy) appears to be configured correctly. Is
> there any way that the policy is somehow not recognizing the correct
> username when these users login and redirecting them to this 'user'
> folder by default? Any suggestions on how to get this working
> properly short of editing the registry? If I have to edit the registry
> on each workstation in order to get it working I will, but I'd feel
> better hearing it from someone with a little more knowledge.
>
> I don't have much experience with GPOs so any and all assistance is
> very much appreciated.
>
> Thank you for your time and assistance,
>
> Drivie
!