Sata Upgrade Gone Awry

I just got a 250GB WD Sata and was really excited to move my OS off a piece of junk 7200RPM 80GB IDE drive.

Before I started, I had the 80GB IDE and 3 other IDE HDD's in Raid0 (I think thats what raid zero is... which ever C: and 3 extra storage drives is called) sorry for the newbness.

So I managed to shuffle around the data and cut it down to 3 HDDs in total plus the new SATA. I got the SATA to show in windows XP Pro after installing Silicon Image SATA drivers, and using the WD Data Lifeguard Tools SW, I formated it as "New Boot Device" option. It proceeded to copy the existing C:/ (which was a fresh XP install) and then said it had to reboot my system, which i thought was it's way of 'updating' my boot settings.

Well, it didnt work as planned and I can't figure out how to set the BIOS to go to the SATA1 Drive first, instead of the IDE0 like it has for 3 years now :P

Anyone see what I am doing wrong? or have a suggestion?

PS. The IDE HDDs are in IDE_0 (2 of them) and IDE_1( just 1) and the SATA is in SATA1

Thanks in advance!
12 answers Last reply
More about sata upgrade awry
  1. Set your bios from IDE to RAID.
    Exit out and re-enter bios.
    There should be a new listing under boot options.
    This should be your new sata drive.
  2. Thanks for the quick response.

    In my BIOS (gigabyte mobo) under > Advanced BIOS Features

    SATA/RAID/SCSI BOOT ORDER -> Sata (?)
    First Boot -> Cdrom
    Second Boot Device -> HDD-0
    Third Boot Device -> HDD-1

    in the list of options for boot devices there is no mention of SATA, just FLOPPY (I dont have a floppy drive), LS120, HDD-0, SCSI, CDROM, HDD-1,HDD-2, ZIP, USB-ETC., LAN,DISABLE

    Under > Integrated Peripherals

    Onboard H/W Serial ATA -> Enabled
    Serial ATA Function -> BASE (? or RAID)
    Onbaord ATA/RAID Device -> Enabled
    RAID Controller Function -> ATA (? or RAID)

    Hopefully that can give some more detail about my mistake

    Thanks again
  3. Hmm, got carried away switching things around

    it slipped past the BIOS load screen and the RAID driver started "scanning IDE drives"

    No array detected.

    then it said it created one and restarted the computer..

    I am now hiding in the bios till further notice :'( and posting off my laptop.
  4. Don't follow his recommendation to use the RAID setting, since your controller is "base" compatible and your BIOS allows it to be detected like that.
  5. whats your motherboard model number. ill research it a little more.
  6. Its a gigabyte P4Titan667 (? from the label) BIOS tells me its a 8INXP.

    For fun i pulled out the IDE_0 and put it in the empty IDE_3

    The computer did its thing and windows XP said it was loading and presto when i got in i checked and it loaded off the SATA.

    However, none of the IDE drives showed up in My Computer : /

    Im back at the BIOS now.

    I am going to try replacing the IDE_0 cable and disable second and thrid boot devices. It seems to go to the SATA drive if nothing else is available, but i still want the IDE to work as well : P

    ** Just tried it and the IDE_0 HDD-0 booted up.

    I am very much Appreciating the late night help
  7. well thats good news on the booting off the SATA.

    this is an P4 board correct?

    having trouble locating the manual from gigabyte website.
  8. YEs its a P4 2.8Ghz

    I think this whole problem stems from me not having a floppy drive to put the SATA drivers on so i can just fresh install XP Pro on it and do the whole "F6" Bit.

    The weird things is of course, when no IDE drives are in, it boots of the SATA... otherwise it seems it wont do anything but boot the HDD in IDE_0 slot 0
  9. i remember a few older boards i had that you couldnt use the sata and IDE hard drives at the same time.

    I used a Promise TX controller to bypass this as they work with just about anything.

    Probably not the case here. Probably just missing a setting somewhere but you never know. When you reconnect the IDE drives you need to check the bios as it tends to reset your boot options to start off the IDE drives. You will have to set it back to the raid controller and the SATA drive in boot option.

    Ill see what i can dig up but it is well past bed time. Keep working on it, not much you can do to screw things up in the bios, theres always the reset jumper. :wink:
  10. I could always nuke the other OS....

    on another note, would a BIOS update do anything?

    I just want a damn SATA C:/ drive already : /

    Thanks again for your help, i'll see what kicks up tomorrow
  11. definitely would not nuke the other OS yet. to many things can go wrong before you get the situation worked out. you may end up needing it before this is all over with.

    im off to bed. ill check up on things in the morning.
  12. Check the advanced menu for something called "Hard Drive Boot Order" or similar.
Ask a new question

Read More

SATA Western Digital Storage