Custom ADM File

Archived from groups: microsoft.public.win2000.group_policy (More info?)

I am trying to create a custom ADM file and when I change
the KEYNAME value to the required one to change, it no
longer shows in Group Policy Editor. Two KEYNAME values
are shown, it only appears when the "colon ed" line is
active.

Attached adm file

CLASS MACHINE

CATEGORY !!categoryname

CATEGORY !!Home
; KEYNAME "SOFTWARE\Policies\System"
KEYNAME "SOFTWARE\Compaq\Easy Access
Buttons\Schemes\Compaq\2"
POLICY !!policyname
PART !!labeltext EDITTEXT REQUIRED
VALUENAME "Assignment"
END PART
END POLICY
END CATEGORY
END CATEGORY

[strings]

categoryname="COMPAQ"
Home="Home Button"
policyname="Home URL"
explaintext="This policy disables the autoplay feature on
the selected drive(s)"
labeltext="URL"
3 answers Last reply
More about custom file
  1. Archived from groups: microsoft.public.win2000.group_policy (More info?)

    Group Policy editor by default hides policies that modify registry values
    outside of the 4 special policy keys. In order for you to see the policy
    you need to do the following:

    On Windows 2000:
    1. Select Administrative Templates
    2. Under the View menu at the top remove the check from "Show policies only"

    On Windows XP/2003
    1. Select Administrative Templates
    2. Under the View menu at the top, click Filtering
    3. Uncheck "Only show policy settings that can be fully managed"
    Note: anytime this policy is edited you will need to remove that check to
    see it.

    --
    Gary Mudgett, MCSE, MCSA
    Windows 2000/2003 Directory Services

    =====================================================
    When responding to posts, please "Reply to Group" via
    your newsreader so that others may learn and benefit
    from your issue.
    =====================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.


    "Martin Powell" <martin.powell@itnetplc.com> wrote in message
    news:2d07701c46972$e5d81b70$a301280a@phx.gbl...
    > I am trying to create a custom ADM file and when I change
    > the KEYNAME value to the required one to change, it no
    > longer shows in Group Policy Editor. Two KEYNAME values
    > are shown, it only appears when the "colon ed" line is
    > active.
    >
    > Attached adm file
    >
    > CLASS MACHINE
    >
    > CATEGORY !!categoryname
    >
    > CATEGORY !!Home
    > ; KEYNAME "SOFTWARE\Policies\System"
    > KEYNAME "SOFTWARE\Compaq\Easy Access
    > Buttons\Schemes\Compaq\2"
    > POLICY !!policyname
    > PART !!labeltext EDITTEXT REQUIRED
    > VALUENAME "Assignment"
    > END PART
    > END POLICY
    > END CATEGORY
    > END CATEGORY
    >
    > [strings]
    >
    > categoryname="COMPAQ"
    > Home="Home Button"
    > policyname="Home URL"
    > explaintext="This policy disables the autoplay feature on
    > the selected drive(s)"
    > labeltext="URL"
    >
  2. Archived from groups: microsoft.public.win2000.group_policy (More info?)

    I have spent months thinking it was an error with the
    configuration of the ADM file...

    ....is there a reason this is the default?? Can it be
    disabled, so that it always show ALL policies?

    >-----Original Message-----
    >Group Policy editor by default hides policies that
    modify registry values
    >outside of the 4 special policy keys. In order for you
    to see the policy
    >you need to do the following:
    >
    >On Windows 2000:
    >1. Select Administrative Templates
    >2. Under the View menu at the top remove the check
    from "Show policies only"
    >
    >On Windows XP/2003
    >1. Select Administrative Templates
    >2. Under the View menu at the top, click Filtering
    >3. Uncheck "Only show policy settings that can be fully
    managed"
    >Note: anytime this policy is edited you will need to
    remove that check to
    >see it.
    >
    >--
    >Gary Mudgett, MCSE, MCSA
    >Windows 2000/2003 Directory Services
    >
    >=====================================================
    >When responding to posts, please "Reply to Group" via
    >your newsreader so that others may learn and benefit
    >from your issue.
    >=====================================================
    >This posting is provided "AS IS" with no warranties, and
    confers no rights.
    >
    >
    >"Martin Powell" <martin.powell@itnetplc.com> wrote in
    message
    >news:2d07701c46972$e5d81b70$a301280a@phx.gbl...
    >> I am trying to create a custom ADM file and when I
    change
    >> the KEYNAME value to the required one to change, it no
    >> longer shows in Group Policy Editor. Two KEYNAME values
    >> are shown, it only appears when the "colon ed" line is
    >> active.
    >>
    >> Attached adm file
    >>
    >> CLASS MACHINE
    >>
    >> CATEGORY !!categoryname
    >>
    >> CATEGORY !!Home
    >> ; KEYNAME "SOFTWARE\Policies\System"
    >> KEYNAME "SOFTWARE\Compaq\Easy Access
    >> Buttons\Schemes\Compaq\2"
    >> POLICY !!policyname
    >> PART !!labeltext EDITTEXT REQUIRED
    >> VALUENAME "Assignment"
    >> END PART
    >> END POLICY
    >> END CATEGORY
    >> END CATEGORY
    >>
    >> [strings]
    >>
    >> categoryname="COMPAQ"
    >> Home="Home Button"
    >> policyname="Home URL"
    >> explaintext="This policy disables the autoplay feature
    on
    >> the selected drive(s)"
    >> labeltext="URL"
    >>
    >
    >
    >.
    >
  3. Archived from groups: microsoft.public.win2000.group_policy (More info?)

    The intent is to have the preferred place for policies to be in the Policy
    keys where they are managed by the group policy engine. Polcies outside of
    those are not managed and are tatooed to the registry (they will persist
    unless a revese policy is applied)
    Those keys are under the HKLM and HKCU paths:
    ....\Software\Policies
    ....\SOFTWARE\Microsoft\Windows\CurrentVersion\policies

    Windows 2000 will keep the setting that it was changed to as it sets the
    following value in the registry:
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Group Policy
    Editor
    ShowPoliciesOnly = 1

    Windows XP/2003 do not appear to save this setting so it must be redone each
    time the editor is started.

    --
    Gary Mudgett, MCSE, MCSA
    Windows 2000/2003 Directory Services

    =====================================================
    When responding to posts, please "Reply to Group" via
    your newsreader so that others may learn and benefit
    from your issue.
    =====================================================
    This posting is provided "AS IS" with no warranties, and confers no rights.

    "Martin Powell" <anonymous@discussions.microsoft.com> wrote in message
    news:2c9fa01c46a42$e8056530$a601280a@phx.gbl...
    > I have spent months thinking it was an error with the
    > configuration of the ADM file...
    >
    > ...is there a reason this is the default?? Can it be
    > disabled, so that it always show ALL policies?
    >
    > >-----Original Message-----
    > >Group Policy editor by default hides policies that
    > modify registry values
    > >outside of the 4 special policy keys. In order for you
    > to see the policy
    > >you need to do the following:
    > >
    > >On Windows 2000:
    > >1. Select Administrative Templates
    > >2. Under the View menu at the top remove the check
    > from "Show policies only"
    > >
    > >On Windows XP/2003
    > >1. Select Administrative Templates
    > >2. Under the View menu at the top, click Filtering
    > >3. Uncheck "Only show policy settings that can be fully
    > managed"
    > >Note: anytime this policy is edited you will need to
    > remove that check to
    > >see it.
    > >
    > >--
    > >Gary Mudgett, MCSE, MCSA
    > >Windows 2000/2003 Directory Services
    > >
    > >=====================================================
    > >When responding to posts, please "Reply to Group" via
    > >your newsreader so that others may learn and benefit
    > >from your issue.
    > >=====================================================
    > >This posting is provided "AS IS" with no warranties, and
    > confers no rights.
    > >
    > >
    > >"Martin Powell" <martin.powell@itnetplc.com> wrote in
    > message
    > >news:2d07701c46972$e5d81b70$a301280a@phx.gbl...
    > >> I am trying to create a custom ADM file and when I
    > change
    > >> the KEYNAME value to the required one to change, it no
    > >> longer shows in Group Policy Editor. Two KEYNAME values
    > >> are shown, it only appears when the "colon ed" line is
    > >> active.
    > >>
    > >> Attached adm file
    > >>
    > >> CLASS MACHINE
    > >>
    > >> CATEGORY !!categoryname
    > >>
    > >> CATEGORY !!Home
    > >> ; KEYNAME "SOFTWARE\Policies\System"
    > >> KEYNAME "SOFTWARE\Compaq\Easy Access
    > >> Buttons\Schemes\Compaq\2"
    > >> POLICY !!policyname
    > >> PART !!labeltext EDITTEXT REQUIRED
    > >> VALUENAME "Assignment"
    > >> END PART
    > >> END POLICY
    > >> END CATEGORY
    > >> END CATEGORY
    > >>
    > >> [strings]
    > >>
    > >> categoryname="COMPAQ"
    > >> Home="Home Button"
    > >> policyname="Home URL"
    > >> explaintext="This policy disables the autoplay feature
    > on
    > >> the selected drive(s)"
    > >> labeltext="URL"
    > >>
    > >
    > >
    > >.
    > >
Ask a new question

Read More

Policy Compaq Software Windows