unable to set registry entry on windows xp clients

Archived from groups: microsoft.public.win2000.group_policy (More info?)

For some reason I am unable to set registry entries on windows xp clients.
Software and policy settings take, but my policy to add a reg entry do not.
I know my adm file is good since windows 2000 clients work.

I get an error in the event log that states:

Event Type: Error
Event Source: Userenv
Event Category: None
Event ID: 1096
Date: 7/23/2004
Time: 4:55:20 PM
User: NT AUTHORITY\SYSTEM
Computer: L12352542
Description:
Windows cannot access the registry policy file,
\\lab.net\sysvol\lab.net\Policies\{31B2F340-016D-11D2-945F-00C04FB984F9}\Machine\registry.pol.
(The parameter is incorrect. ).

For more information, see Help and Support Center at
http://go.microsoft.com/fwlink/events.asp.

Here is a copy of my adm file I am using

CLASS MACHINE
CATEGORY "SYSTEM"
POLICY "environment variable"
KEYNAME "SYSTEM\CurrentControlSet\Control\Session Manager\Environment"
PART "environment variable" TEXT
END PART
PART "environment variable" EDITTEXT
VALUENAME "Mysettings"
END PART
END POLICY
END CATEGORY

Please help!!!

John
2 answers Last reply
More about unable registry entry windows clients
  1. Archived from groups: microsoft.public.win2000.group_policy (More info?)

    So I guess no one has encountered this problem???


    "John Bleakley" <bleaklj@autodesk.com> wrote in message
    news:O82jcJScEHA.2660@TK2MSFTNGP12.phx.gbl...
    > For some reason I am unable to set registry entries on windows xp clients.
    > Software and policy settings take, but my policy to add a reg entry do
    > not. I know my adm file is good since windows 2000 clients work.
    >
    > I get an error in the event log that states:
    >
    > Event Type: Error
    > Event Source: Userenv
    > Event Category: None
    > Event ID: 1096
    > Date: 7/23/2004
    > Time: 4:55:20 PM
    > User: NT AUTHORITY\SYSTEM
    > Computer: L12352542
    > Description:
    > Windows cannot access the registry policy file,
    > \\lab.net\sysvol\lab.net\Policies\{31B2F340-016D-11D2-945F-00C04FB984F9}\Machine\registry.pol.
    > (The parameter is incorrect. ).
    >
    > For more information, see Help and Support Center at
    > http://go.microsoft.com/fwlink/events.asp.
    >
    > Here is a copy of my adm file I am using
    >
    > CLASS MACHINE
    > CATEGORY "SYSTEM"
    > POLICY "environment variable"
    > KEYNAME "SYSTEM\CurrentControlSet\Control\Session Manager\Environment"
    > PART "environment variable" TEXT
    > END PART
    > PART "environment variable" EDITTEXT
    > VALUENAME "Mysettings"
    > END PART
    > END POLICY
    > END CATEGORY
    >
    > Please help!!!
    >
    > John
    >
    >
  2. Archived from groups: microsoft.public.win2000.group_policy (More info?)

    Sounds like a problem with SYSVOL rather than the ADM. What that error is
    saying is that the client can't read the actual settings file from the GPT
    portion of the GPO. Is this happening on all clients or just some? For the
    client where its happening, open a command shell and type echo %logonserver%
    to find out which DC its authenticating with. Then go to that DC under
    %windir%\sysvol\sysvol\lab.net\Policies\{31B2F340-016D-11D2-945F-00C04FB984F
    9}\Machine. Then verify that registry.pol exists. Next, check the
    permissions on the file (and its parent folder) and verify that they are the
    same as the same file and folder on the PDC role holder DC in the domain.
    Also, check the size of registry.pol on both DCs. Let us know how that comes
    out.


    -------
    Darren Mar-Elia
    MS-MVP-Windows Management
    http://www.gpoguy.com


    "John Bleakley" <bleaklj@hotmail.com> wrote in message
    news:OHLvzQLeEHA.1644@tk2msftngp13.phx.gbl...
    > So I guess no one has encountered this problem???
    >
    >
    > "John Bleakley" <bleaklj@autodesk.com> wrote in message
    > news:O82jcJScEHA.2660@TK2MSFTNGP12.phx.gbl...
    > > For some reason I am unable to set registry entries on windows xp
    clients.
    > > Software and policy settings take, but my policy to add a reg entry do
    > > not. I know my adm file is good since windows 2000 clients work.
    > >
    > > I get an error in the event log that states:
    > >
    > > Event Type: Error
    > > Event Source: Userenv
    > > Event Category: None
    > > Event ID: 1096
    > > Date: 7/23/2004
    > > Time: 4:55:20 PM
    > > User: NT AUTHORITY\SYSTEM
    > > Computer: L12352542
    > > Description:
    > > Windows cannot access the registry policy file,
    > >
    \\lab.net\sysvol\lab.net\Policies\{31B2F340-016D-11D2-945F-00C04FB984F9}\Mac
    hine\registry.pol.
    > > (The parameter is incorrect. ).
    > >
    > > For more information, see Help and Support Center at
    > > http://go.microsoft.com/fwlink/events.asp.
    > >
    > > Here is a copy of my adm file I am using
    > >
    > > CLASS MACHINE
    > > CATEGORY "SYSTEM"
    > > POLICY "environment variable"
    > > KEYNAME "SYSTEM\CurrentControlSet\Control\Session Manager\Environment"
    > > PART "environment variable" TEXT
    > > END PART
    > > PART "environment variable" EDITTEXT
    > > VALUENAME "Mysettings"
    > > END PART
    > > END POLICY
    > > END CATEGORY
    > >
    > > Please help!!!
    > >
    > > John
    > >
    > >
    >
    >
Ask a new question

Read More

Policy Registry Windows XP Windows