Sign in with
Sign up | Sign in
Your question

IDE socket problems

Last response: in Motherboards
Share
January 21, 2007 6:25:44 PM

Hi guys, I'll try and keep this brief as to not confuse things: My friend was having troubles with her computer, I offered to fix it, and straight away thought it'd need a new motherboard, I ordered one (an Asrock P4i65g) and even after countless hours and help from a couple of friends it just wasn't booting up.

Anyway, I decided to go back to the original motherboard and work with that. It boots into Windows just fine, but it hangs at regular intervals; when you first login, it sits and does nothing until you press ctrl, alt and delete, also if you try to open a window that references the CD drive it'll hang too, although everything other than that particular window works just fine.

I ran an IDE test and it came back as saying only the HDD was present, so after much messing around with jumpers etc I eventually swapped the IDE cables around (at the motherboard end) and now the CD-RW works just fine, but the HDD doesn't. Hmm.

I'm 99% certain it's a problem with the IDE socket, I've checked and there doesn't appear to be any bent pins so I can't really understand why it would suddenly just stop. Any advice would be very much appreciated, I've been working on this for a silly amount of hours now and would just love to reach a conclusion. If there's anything I can do other than have to buy and fit yet another motherboard that'd be fantastic! :)  Thanks

More about : ide socket problems

January 21, 2007 8:21:33 PM

I've just tried connecting the HDD and CD drive using the same cable now, and it's still only detecting one drive. I'm completely at a loss with this :/ 
January 21, 2007 9:05:32 PM

Scrap that, nothing is working at all now; I've just tried all sorts of IDE/jumper combinations and it isn't detecting either of the CD drives nor the HDD. Tried using the exact original set up for the hard drive too; coming up saying no boot device and it can't see the HDD at all. FFS!
Related resources
January 21, 2007 9:41:11 PM

Usually not a good idea to put an optical drive and hard drive on the same cable. Try setting the hard drive to master, connect it to the end of the cable. Don't connect anything to the middle of the cable. Connect other end to one of the ide ports. See what happens. Also, you need to list her PC specs.
January 21, 2007 9:53:53 PM

Quote:
Scrap that, nothing is working at all now; I've just tried all sorts of IDE/jumper combinations and it isn't detecting either of the CD drives nor the HDD. Tried using the exact original set up for the hard drive too; coming up saying no boot device and it can't see the HDD at all. FFS!


Surely the pins on both HDD/optical drive wasn't bent or something?Have you tried another cable(s)?
January 21, 2007 10:23:09 PM

this problem happens because the drives aren't set to master or slave. There is a section on the back of these drives beside the ide cable slot where you may change the drive to a master or slave. (the two pin thing, sorry i dont know what its called). YOu can google which pins the block must be on so you may use both of them at the same time on one ide cable.
January 22, 2007 7:34:06 AM

Huge thanks for the replies guys, I'll try to cover them in as much detail as possible, but I'm still not having any luck at all :( 

- I originally only wanted to try them on the same cable as a test, if it worked I was going to just re-install Windows and then consider getting a USB CD drive since I thought the IDE socket on the motherboard was dead.

- I've tried the hard drive set to both master and cable select with it now on it's own IDE cable (it's a shorter cable that only has one IDE slot on it anyway) and it's still not recognising it at all.

- I've checked for bent pins and couldn't see any, have also tried a total of three cables now.

- The computer's pretty junk and doesn't mention the jumper/pin positions for the CD drives at least, but I believe they're set correctly anyway, I've tried a few different combinations just in case, all without any luck.

Once again a huge thanks for the replies. Specs are P4 2.4Ghz, 256MB Ram, 40GB HDD. Cheers!
January 22, 2007 6:25:33 PM

I've made a little progress; it can see both of the CD drives now at least! \o/

Still having problems with it randomly hanging in Windows, maybe random isn't the right word, but upon logging on and logging off it takes absolutely ages and just sits there idly without loading anything, likewise when I try to open My Computer or similar. It still speeds up considerably (in fact, it speeds up to 'normal' speeds) as soon as I run Disk Management and it realises what drives are there, which is really odd.

Any suggestions before I try a format please? I know it may be the only option, but I'd be installing an XP SP2 and apparently Dell machines don't like that at all; not to mention I don't have the original drivers!
January 22, 2007 7:02:12 PM

try a totally different cable.. perhaps

ive had issues where the HD refused to detect, using a cable that i knew for a fact that it worked, i grabbed a new cable and it worked perfectly (still working right now in fact)

ATA/IDE drives can be a little funny sometimes, to say the least - get a cable with 2 device sockets on it, set the HD to master, plug it into the end of the cable (make sure the proper end is plugged into the motherboard), if that dont work, change the jumper to cable select

there's no reason to experiment with a CD drive and HDD on one cable, do yurself a favor and just use 2 cables, if you have a much slower device on the same channel as a HDD, the HDD will slow way down when the CD drive is being accessed.

a few companies out there have downloadable drive/controller scanning utilities western digital has a nice one i do believe, it will test the controller for errors and the drive itself, including a full surface scan of the HDD. download it and give it a try. im pretty sure they have an ISO available so you can make a bootable CD, and im pretty sure they have a floppy install as well

cheap to try a new cable, but dont start buying a bunch of parts for a system until you know whats wrong

random hang ups and such can be caused by bad sectors, in fact i have a 40 gig hard drive right now (in a laptop) that had to be formated and partitioned at 18gig in order for it to hold data reliably.
January 22, 2007 7:57:00 PM

Have tried removing and re-adding the drives using Disc Manager, have tried doing a Windows repair but can't because it has XP Pro installed but the CD I have is XP home and am currently running AVG but it hasn't found anything as yet.

I think a lot of these problems came about when she tried installing her new broadband/wireless router, I've just noticed the firewall is disabled and when trying to re-enable it I'm presented with this error - http://img264.imageshack.us/img264/8067/925071245dt.jpg - could it be related?
January 22, 2007 7:59:42 PM

Apologies, only just saw your message!

Have already tried a few different cables, like I said, I've managed to get it working now, the HDD and CD drives are all fine, even in Windows which is ace! \o/ The problem I'm having now is the system keeps hanging, I still think it's related to the IDE but I'm not entirely sure any more.
January 24, 2007 6:51:10 AM

Hmm, just when I thought I was getting somewhere, it's now coming up with an error saying something along the lines of "ntoskrnl.exe is missing or corrupt" - absolute nightmare!

I've just been looking at a great page regarding the problem ( http://www.computerhope.com/issues/ch000646.htm ) and since it's happened so soon after a format I must say I'm a little worried that the HDD is corrupt. Saying that, I did mess around with Boot.ini to change the OS selection timeout change from 30 seconds to 3 seconds, so I'm going to rebuild that too :/ 
January 24, 2007 7:23:48 AM

Man, you're so patient! I would have formatted the partition/drive if I were you....

About missing ntldr, try boot using XP cd, then go to repair console (at the options screen). Try running fixboot

Err... I think I remembered u mention not having winXP cd :? .....
January 24, 2007 8:14:49 AM

Hehe, I've literally just done a format, this error has come up just a few hours after doing that, which is what makes me think it could be a corrupt hard drive? Will run that and try and fix the boot ini though, cheers!
!