Sign in with
Sign up | Sign in
Your question

Another JMicron SATA RAID 0 setup/Win XP install question(s)

Last response: in Overclocking
Share
January 22, 2007 2:14:21 PM

Picked up a pair of 160GB SATA 3.0 HDDs over the weekend and yesterday tried to get Windows XP Pro installed on the SATA RAID 0 array but had no luck.

The mobo is Gigabyte 965P-S3 at bios F7.

I went into the bios and...

1. Set the (Intel) SATA controller to legacy mode
2. Enabled the Gigabyte/JMicron SATA/IDE controller
3. Set the Gigabyte/JMicron controller to RAID + IDE mode
4. Built and configured the RAID 0 array
5. Tried to install Win XP Pro using the F6 key method to load the Gigabyte/JMicron drivers.

At this point everything seems to be going fine - for a while. XP setup reads the floppy and allows me to choose which driver to use then progresses through setup recognizing and allowing me to partition/format the array. However, after formatting the array, XP goes back to loading more stuff and gets to the point where it again tries to load the JMicron drivers from the floppy. At this point XP says it cannot copy the driver from the floppy and asks to try again, exit, or continue without installing the driver.

No matter how many times I "try again" it will not copy the drivers from the floppy. I've tried different floppy discs and different drivers (from the Gigabyte CD and from JMicron website). The floppy drive does work because I can take boot disks I have and start the computer with them.

Eventually, if skip the drivers to continue the XP install, it will fail with BSOD. If I don't do the F6 key thing early in the setup, it will not recognize the HDD array and install fails as well. I have tried all versions of the drivers listed when setup asks me to choose which I'd like to install.

The kicker is that Win2K w/SP3 installs just fine - loading the SATA/RAID drivers using F6, then later in the install Windows picks them off the floppy just fine.

I'm stumped - what am I missing in the Win XP Pro install that allows the Win2K install to work perfectly using the exact same methodology?
January 22, 2007 3:00:18 PM

Last week when I built my rig I had the same problem - but I was using Nvidia's Raid Array on my P5N-E.

I almost began to panick because I wasn't looking to starting my install over again and possibly reformatting my 500gb array.

My problem was my floppy disk. I luckily made a second disk of the raid drivers - popped that in when it said it couldn't copy the files and it worked.

But it was strange that the first disk I used allowed me to boot and set up everything intially but had problems later on. I made a second floppy disk before because I had those disks for 5+ years and wasnt sure how good they were.
January 22, 2007 4:58:23 PM

Well, it must be a problem with Win XP itself or the XP disk I'm using because I just installed Vista RC-1 without a hitch using the same technique, driver disk, etc.
Related resources
January 26, 2007 2:57:59 PM

Had same problem as described above, trying to add the drivers using f6 and a normal fdd drive.. read fine, got the array up, formatted, then winxp asks me to insert the driver disk (thought I just did, silly xpinstaller).. nothing, it ends with me having to reboot.. and having to redo the pre-format routine again..

figured I had a faulty fdd drive after a while, so I went ahead and tried to emulate a usb dongle as floppy, forced and auto.. no go (guess this doesn't work until win vista, go figure..) ..

Second option was to burn a copy of winxp with slipstreamed raid drivers on the cd, still no rock on..

Was giving up after the 20th hour of rebooting and banging my head vs. the table in sheer frustration..

my saviour?

nlite ! .. it can incorporate your raid drivers (or any driver at that) into the install iso (making it bootable, etc, etc, it even comes with a built in burning software, so no need for nero or whatnot to burn the iso)..

not sure if I can post links to other sites here, so I'll just tip you to do a
google search on the word nlite ..
should be the first hit, with the letters OS also in the url..

I'm still regretting not doing even more research, would have saved me tons of cd-r plates trying to get the slipstream way to work, and the hours of plugging and unplugging drives, fdd drives, cd-drives etc.. ><

so, I hope you take heed and try this route for your raid problems..

best of luck,
miga

*Edit*
Oh yeah, the motherboard I was trying to set raid up with is a Asus Commando .. ich8 chippies :)  ..
I absolutely love the raid matrix setup.. raid1 for OS and raid0 for the othe stuff. Windows loading is a breeze :D 
January 26, 2007 5:03:31 PM

Thanks for the reply.

Glad to have more confirmation that it was not just something I was doing wrong.

However, I gave up on the XP Pro install and just went with my XP Home edition.

Vista RC-1 was working decently, but I figured I didn't want to get this thing all loaded up and then have the OS be locked out in a few months.
March 17, 2007 3:24:08 AM

I had teh same problem and I still hunting a solution. I am using a BioStar 350G with 945G & ICH7R chipset, exactly same problem, I think there MUST be a way of solution around this, anyone has advice on this!!
!