Sign in with
Sign up | Sign in
Your question

Cannot install Service pack with Group Policy on W2K

Last response: in Windows 2000/NT
Share
Anonymous
October 18, 2004 12:21:02 PM

Archived from groups: microsoft.public.win2000.group_policy (More info?)

I have assigned a .MSI for W2K SP4 to the Computer Configuration of my Group
Policy. When I reboot a computer that belongs to the OU I have assigned the
GP to, it says 'applying software installation settings' and then 'Installing
Windows 2000 Service Pack 4'. It then flicks over to the logon screen quite
quickly so I know the install won't work as it is far too quick. I have
assigned 'Domain Computers' the Apply Group policy permission on the GPO and
Modify on the folder where the .MSI file is stored. The service pack is not
installed. Any ideas would be much appreciated!
Anonymous
October 18, 2004 4:11:40 PM

Archived from groups: microsoft.public.win2000.group_policy (More info?)

"Lisa" <Lisa@discussions.microsoft.com> wrote in message
news:8626851F-3591-48DC-A58D-54611B8C0451@microsoft.com...
>I have assigned a .MSI for W2K SP4 to the Computer Configuration of my
>Group
> Policy. When I reboot a computer that belongs to the OU I have assigned
> the
> GP to, it says 'applying software installation settings' and then
> 'Installing
> Windows 2000 Service Pack 4'. It then flicks over to the logon screen
> quite
> quickly so I know the install won't work as it is far too quick. I have
> assigned 'Domain Computers' the Apply Group policy permission on the GPO
> and
> Modify on the folder where the .MSI file is stored. The service pack is
> not
> installed. Any ideas would be much appreciated!

http://www.microsoft.com/sus

Matt
MCT, MCSE
Anonymous
October 19, 2004 6:03:50 PM

Archived from groups: microsoft.public.win2000.group_policy (More info?)

Lisa,

A common error that people make on this is that they do not give the Domain
Computers group the read permission on both the NTFS and Share tabs on the
shared folder.

Another common error ( which I am assuming that you did not commit ) is that
they use a mapped network drive when telling AD where the update.msi file is
located. You need to use the UNC format ( \\servername\sharename ).

A third common error is that you do not give it enough time. But, probably
not the case in your situation.

You specifically stated that you assigned the GPO to the OU in which the
computer account objects directly reside. This is good.

For starters, sit down at one of the WIN2000 systems and navigate to the
shared folder where update.msi lives and double-click on that file. Does it
install? If not, does it install from update.exe? Naturally you would need
to do this using either the local Administrator account or a domain user
account that is a member of the Domain Admins group. If it installs
completely and you reboot and all is okay then let's look at one of the
systems where it failed. Do you see any Event IDs ( right click My Computer
and select Manage - just one way to get there )? I would suspect that you
would. You would most probably be looking in the Application log.

Have you looked at GPOTool? At GPResult? What troubleshooting have you
done sofar?

Also, you do not include much information about your network. How many DCs
are there? How many Sites? Are there other GPOs that you have created that
function? Is DNS Set up and configured properly ( DNS is one of the biggest
culprits for just about anything that does not work correctly in Active
Directory! )?

HTH,

Cary

"Lisa" <Lisa@discussions.microsoft.com> wrote in message
news:8626851F-3591-48DC-A58D-54611B8C0451@microsoft.com...
> I have assigned a .MSI for W2K SP4 to the Computer Configuration of my
Group
> Policy. When I reboot a computer that belongs to the OU I have assigned
the
> GP to, it says 'applying software installation settings' and then
'Installing
> Windows 2000 Service Pack 4'. It then flicks over to the logon screen
quite
> quickly so I know the install won't work as it is far too quick. I have
> assigned 'Domain Computers' the Apply Group policy permission on the GPO
and
> Modify on the folder where the .MSI file is stored. The service pack is
not
> installed. Any ideas would be much appreciated!
!