Redirect MyDocs after Novell Login

Archived from groups: microsoft.public.win2000.group_policy (More info?)

I'm in a Novell / Microsoft environment where all the users files are stored
on the Novell servers (H: Drive). I'm rolling out AD, and would like to
force each user's MyDocs folder to be redirected to their H: Drive, but it
doesn't work because the GPO's are applied before the H: Drive mapping is
created.

Can anyone think of a way to force the redirection to happen, even if the h:
drive doesn't yet exist?

I guess if all else fails, I can have their Netware login script set the
local registry key after it runs, but that's a little more manual then I
wanted.

Thanks,
Gabe
13 answers Last reply
More about redirect mydocs novell login
  1. Archived from groups: microsoft.public.win2000.group_policy (More info?)

    Gabe Knuth wrote:
    > I'm in a Novell / Microsoft environment where all the users files are
    > stored on the Novell servers (H: Drive). I'm rolling out AD, and
    > would like to force each user's MyDocs folder to be redirected to
    > their H: Drive, but it doesn't work because the GPO's are applied
    > before the H: Drive mapping is created.
    >
    > Can anyone think of a way to force the redirection to happen, even if
    > the h: drive doesn't yet exist?
    >
    > I guess if all else fails, I can have their Netware login script set
    > the local registry key after it runs, but that's a little more manual
    > then I wanted.
    >
    > Thanks,
    > Gabe

    If you use redirection to "a subfolder under the home directory" and have
    the home directory specified in their ADUC properties, this should work, I'd
    think.
  2. Archived from groups: microsoft.public.win2000.group_policy (More info?)

    Well, I was optimistic there, but it didn't work. Appears to be the same
    problem - the H:\ drive doesn't get connected until after all the Windows
    settings have been configured. The home path IS getting set to H:\, but
    when the MyDocs redirection is being configured, the homedrive\homepath is
    apparently still set to c:\documents and settings\blah blah.

    Any other thoughts? We're closer...

    Thanks much,
    Gabe


    "Lanwench [MVP - Exchange]"
    <lanwench@heybuddy.donotsendme.unsolicitedmail.atyahoo.com> wrote in message
    news:emS#HnEwEHA.3872@TK2MSFTNGP11.phx.gbl...
    > Gabe Knuth wrote:
    > > I'm in a Novell / Microsoft environment where all the users files are
    > > stored on the Novell servers (H: Drive). I'm rolling out AD, and
    > > would like to force each user's MyDocs folder to be redirected to
    > > their H: Drive, but it doesn't work because the GPO's are applied
    > > before the H: Drive mapping is created.
    > >
    > > Can anyone think of a way to force the redirection to happen, even if
    > > the h: drive doesn't yet exist?
    > >
    > > I guess if all else fails, I can have their Netware login script set
    > > the local registry key after it runs, but that's a little more manual
    > > then I wanted.
    > >
    > > Thanks,
    > > Gabe
    >
    > If you use redirection to "a subfolder under the home directory" and have
    > the home directory specified in their ADUC properties, this should work,
    I'd
    > think.
    >
    >
  3. Archived from groups: microsoft.public.win2000.group_policy (More info?)

    Gabe Knuth wrote:
    > Well, I was optimistic there, but it didn't work. Appears to be the
    > same problem - the H:\ drive doesn't get connected until after all
    > the Windows settings have been configured. The home path IS getting
    > set to H:\, but when the MyDocs redirection is being configured, the
    > homedrive\homepath is apparently still set to c:\documents and
    > settings\blah blah.
    >
    > Any other thoughts? We're closer...

    Hm. You're using the default domain policy for this? I do this a lot and
    have never had it not work. Sounds like the computer isn't picking up the
    policy. More info might help.
    >
    > Thanks much,
    > Gabe
    >
    >
    > "Lanwench [MVP - Exchange]"
    > <lanwench@heybuddy.donotsendme.unsolicitedmail.atyahoo.com> wrote in
    > message news:emS#HnEwEHA.3872@TK2MSFTNGP11.phx.gbl...
    >> Gabe Knuth wrote:
    >>> I'm in a Novell / Microsoft environment where all the users files
    >>> are stored on the Novell servers (H: Drive). I'm rolling out AD,
    >>> and would like to force each user's MyDocs folder to be redirected
    >>> to their H: Drive, but it doesn't work because the GPO's are applied
    >>> before the H: Drive mapping is created.
    >>>
    >>> Can anyone think of a way to force the redirection to happen, even
    >>> if the h: drive doesn't yet exist?
    >>>
    >>> I guess if all else fails, I can have their Netware login script set
    >>> the local registry key after it runs, but that's a little more
    >>> manual then I wanted.
    >>>
    >>> Thanks,
    >>> Gabe
    >>
    >> If you use redirection to "a subfolder under the home directory" and
    >> have the home directory specified in their ADUC properties, this
    >> should work, I'd think.
  4. Archived from groups: microsoft.public.win2000.group_policy (More info?)

    The policy is configured for the container that the users are in,
    permissions are set correctly.

    Other items are configured (and working) in the same policy, like Screen
    Saver settings and desktop settings, but it appears that you are correct -
    the MyDocs redirection isn't getting pushed.

    Workstation is WinXP Pro SP1. Novell Client 4.9SP2. Win2k3 AD.

    Any other information that might be helpful?


    "Lanwench [MVP - Exchange]"
    <lanwench@heybuddy.donotsendme.unsolicitedmail.atyahoo.com> wrote in message
    news:eSs3BlFwEHA.3084@TK2MSFTNGP10.phx.gbl...
    > Gabe Knuth wrote:
    > > Well, I was optimistic there, but it didn't work. Appears to be the
    > > same problem - the H:\ drive doesn't get connected until after all
    > > the Windows settings have been configured. The home path IS getting
    > > set to H:\, but when the MyDocs redirection is being configured, the
    > > homedrive\homepath is apparently still set to c:\documents and
    > > settings\blah blah.
    > >
    > > Any other thoughts? We're closer...
    >
    > Hm. You're using the default domain policy for this? I do this a lot and
    > have never had it not work. Sounds like the computer isn't picking up the
    > policy. More info might help.
    > >
    > > Thanks much,
    > > Gabe
    > >
    > >
    > > "Lanwench [MVP - Exchange]"
    > > <lanwench@heybuddy.donotsendme.unsolicitedmail.atyahoo.com> wrote in
    > > message news:emS#HnEwEHA.3872@TK2MSFTNGP11.phx.gbl...
    > >> Gabe Knuth wrote:
    > >>> I'm in a Novell / Microsoft environment where all the users files
    > >>> are stored on the Novell servers (H: Drive). I'm rolling out AD,
    > >>> and would like to force each user's MyDocs folder to be redirected
    > >>> to their H: Drive, but it doesn't work because the GPO's are applied
    > >>> before the H: Drive mapping is created.
    > >>>
    > >>> Can anyone think of a way to force the redirection to happen, even
    > >>> if the h: drive doesn't yet exist?
    > >>>
    > >>> I guess if all else fails, I can have their Netware login script set
    > >>> the local registry key after it runs, but that's a little more
    > >>> manual then I wanted.
    > >>>
    > >>> Thanks,
    > >>> Gabe
    > >>
    > >> If you use redirection to "a subfolder under the home directory" and
    > >> have the home directory specified in their ADUC properties, this
    > >> should work, I'd think.
    >
    >
  5. Archived from groups: microsoft.public.win2000.group_policy (More info?)

    "Gabe Knuth" <news@gabeknuth.com (not for legit emails, use my first name @
    gabeknuth.com for those)> wrote in message
    news:OtHh47FwEHA.1392@tk2msftngp13.phx.gbl...
    > The policy is configured for the container that the users are in,
    > permissions are set correctly.
    >
    > Other items are configured (and working) in the same policy, like Screen
    > Saver settings and desktop settings, but it appears that you are correct -
    > the MyDocs redirection isn't getting pushed.
    >
    > Workstation is WinXP Pro SP1. Novell Client 4.9SP2. Win2k3 AD.
    >
    > Any other information that might be helpful?
    >
    >
    Can you redirect to a UNC path? \\server\%username%

    Just an idea. I'm not too up on folder redirection.

    Matt
    MCT, MCSE
  6. Archived from groups: microsoft.public.win2000.group_policy (More info?)

    Sorry, I should've posted that. I tried that already - no success.

    I think it's odd that just one setting won't apply, but the others will in
    the same policy. The only other time I've seen that is when trying to push
    down a Group Policy Loopback Processing setting in the same policy as Admin
    Template settings. Guess I could try moving the folder redirection setting
    to its own policy.

    "Matt Anderson" <andersonnoapam@dynedge.com> wrote in message
    news:#AyImcGwEHA.1264@TK2MSFTNGP12.phx.gbl...
    >
    > "Gabe Knuth" <news@gabeknuth.com (not for legit emails, use my first name
    @
    > gabeknuth.com for those)> wrote in message
    > news:OtHh47FwEHA.1392@tk2msftngp13.phx.gbl...
    > > The policy is configured for the container that the users are in,
    > > permissions are set correctly.
    > >
    > > Other items are configured (and working) in the same policy, like Screen
    > > Saver settings and desktop settings, but it appears that you are
    correct -
    > > the MyDocs redirection isn't getting pushed.
    > >
    > > Workstation is WinXP Pro SP1. Novell Client 4.9SP2. Win2k3 AD.
    > >
    > > Any other information that might be helpful?
    > >
    > >
    > Can you redirect to a UNC path? \\server\%username%
    >
    > Just an idea. I'm not too up on folder redirection.
    >
    > Matt
    > MCT, MCSE
    >
    >
  7. Archived from groups: microsoft.public.win2000.group_policy (More info?)

    That didn't do it either.

    "Gabe Knuth" <news@gabeknuth.com (not for legit emails, use my first name @
    gabeknuth.com for those)> wrote in message
    news:udMClcOwEHA.2568@TK2MSFTNGP11.phx.gbl...
    > Sorry, I should've posted that. I tried that already - no success.
    >
    > I think it's odd that just one setting won't apply, but the others will in
    > the same policy. The only other time I've seen that is when trying to
    push
    > down a Group Policy Loopback Processing setting in the same policy as
    Admin
    > Template settings. Guess I could try moving the folder redirection
    setting
    > to its own policy.
    >
    > "Matt Anderson" <andersonnoapam@dynedge.com> wrote in message
    > news:#AyImcGwEHA.1264@TK2MSFTNGP12.phx.gbl...
    > >
    > > "Gabe Knuth" <news@gabeknuth.com (not for legit emails, use my first
    name
    > @
    > > gabeknuth.com for those)> wrote in message
    > > news:OtHh47FwEHA.1392@tk2msftngp13.phx.gbl...
    > > > The policy is configured for the container that the users are in,
    > > > permissions are set correctly.
    > > >
    > > > Other items are configured (and working) in the same policy, like
    Screen
    > > > Saver settings and desktop settings, but it appears that you are
    > correct -
    > > > the MyDocs redirection isn't getting pushed.
    > > >
    > > > Workstation is WinXP Pro SP1. Novell Client 4.9SP2. Win2k3 AD.
    > > >
    > > > Any other information that might be helpful?
    > > >
    > > >
    > > Can you redirect to a UNC path? \\server\%username%
    > >
    > > Just an idea. I'm not too up on folder redirection.
    > >
    > > Matt
    > > MCT, MCSE
    > >
    > >
    >
    >
  8. Archived from groups: microsoft.public.win2000.group_policy (More info?)

    Gabe Knuth wrote:
    > That didn't do it either.

    Do you have a computer not running the Novell client, and can you test it
    there?
    >
    > "Gabe Knuth" <news@gabeknuth.com (not for legit emails, use my first
    > name @ gabeknuth.com for those)> wrote in message
    > news:udMClcOwEHA.2568@TK2MSFTNGP11.phx.gbl...
    >> Sorry, I should've posted that. I tried that already - no success.
    >>
    >> I think it's odd that just one setting won't apply, but the others
    >> will in the same policy. The only other time I've seen that is when
    >> trying to push down a Group Policy Loopback Processing setting in
    >> the same policy as Admin Template settings. Guess I could try
    >> moving the folder redirection setting to its own policy.
    >>
    >> "Matt Anderson" <andersonnoapam@dynedge.com> wrote in message
    >> news:#AyImcGwEHA.1264@TK2MSFTNGP12.phx.gbl...
    >>>
    >>> "Gabe Knuth" <news@gabeknuth.com (not for legit emails, use my
    >>> first name @ gabeknuth.com for those)> wrote in message
    >>> news:OtHh47FwEHA.1392@tk2msftngp13.phx.gbl...
    >>>> The policy is configured for the container that the users are in,
    >>>> permissions are set correctly.
    >>>>
    >>>> Other items are configured (and working) in the same policy, like
    >>>> Screen Saver settings and desktop settings, but it appears that
    >>>> you are correct - the MyDocs redirection isn't getting pushed.
    >>>>
    >>>> Workstation is WinXP Pro SP1. Novell Client 4.9SP2. Win2k3 AD.
    >>>>
    >>>> Any other information that might be helpful?
    >>>>
    >>>>
    >>> Can you redirect to a UNC path? \\server\%username%
    >>>
    >>> Just an idea. I'm not too up on folder redirection.
    >>>
    >>> Matt
    >>> MCT, MCSE
  9. Archived from groups: microsoft.public.win2000.group_policy (More info?)

    Ooh...Good call. I'll do that.


    "Lanwench [MVP - Exchange]"
    <lanwench@heybuddy.donotsendme.unsolicitedmail.atyahoo.com> wrote in message
    news:e8z77eTwEHA.536@TK2MSFTNGP11.phx.gbl...
    > Gabe Knuth wrote:
    > > That didn't do it either.
    >
    > Do you have a computer not running the Novell client, and can you test it
    > there?
    > >
    > > "Gabe Knuth" <news@gabeknuth.com (not for legit emails, use my first
    > > name @ gabeknuth.com for those)> wrote in message
    > > news:udMClcOwEHA.2568@TK2MSFTNGP11.phx.gbl...
    > >> Sorry, I should've posted that. I tried that already - no success.
    > >>
    > >> I think it's odd that just one setting won't apply, but the others
    > >> will in the same policy. The only other time I've seen that is when
    > >> trying to push down a Group Policy Loopback Processing setting in
    > >> the same policy as Admin Template settings. Guess I could try
    > >> moving the folder redirection setting to its own policy.
    > >>
    > >> "Matt Anderson" <andersonnoapam@dynedge.com> wrote in message
    > >> news:#AyImcGwEHA.1264@TK2MSFTNGP12.phx.gbl...
    > >>>
    > >>> "Gabe Knuth" <news@gabeknuth.com (not for legit emails, use my
    > >>> first name @ gabeknuth.com for those)> wrote in message
    > >>> news:OtHh47FwEHA.1392@tk2msftngp13.phx.gbl...
    > >>>> The policy is configured for the container that the users are in,
    > >>>> permissions are set correctly.
    > >>>>
    > >>>> Other items are configured (and working) in the same policy, like
    > >>>> Screen Saver settings and desktop settings, but it appears that
    > >>>> you are correct - the MyDocs redirection isn't getting pushed.
    > >>>>
    > >>>> Workstation is WinXP Pro SP1. Novell Client 4.9SP2. Win2k3 AD.
    > >>>>
    > >>>> Any other information that might be helpful?
    > >>>>
    > >>>>
    > >>> Can you redirect to a UNC path? \\server\%username%
    > >>>
    > >>> Just an idea. I'm not too up on folder redirection.
    > >>>
    > >>> Matt
    > >>> MCT, MCSE
    >
    >
  10. Archived from groups: microsoft.public.win2000.group_policy (More info?)

    Nope, still doesn't work. This is nuts!

    "Gabe Knuth" <news@gabeknuth.com (not for legit emails, use my first name @
    gabeknuth.com for those)> wrote in message
    news:OOg5lTbwEHA.1260@TK2MSFTNGP12.phx.gbl...
    > Ooh...Good call. I'll do that.
    >
    >
    > "Lanwench [MVP - Exchange]"
    > <lanwench@heybuddy.donotsendme.unsolicitedmail.atyahoo.com> wrote in
    message
    > news:e8z77eTwEHA.536@TK2MSFTNGP11.phx.gbl...
    > > Gabe Knuth wrote:
    > > > That didn't do it either.
    > >
    > > Do you have a computer not running the Novell client, and can you test
    it
    > > there?
    > > >
    > > > "Gabe Knuth" <news@gabeknuth.com (not for legit emails, use my first
    > > > name @ gabeknuth.com for those)> wrote in message
    > > > news:udMClcOwEHA.2568@TK2MSFTNGP11.phx.gbl...
    > > >> Sorry, I should've posted that. I tried that already - no success.
    > > >>
    > > >> I think it's odd that just one setting won't apply, but the others
    > > >> will in the same policy. The only other time I've seen that is when
    > > >> trying to push down a Group Policy Loopback Processing setting in
    > > >> the same policy as Admin Template settings. Guess I could try
    > > >> moving the folder redirection setting to its own policy.
    > > >>
    > > >> "Matt Anderson" <andersonnoapam@dynedge.com> wrote in message
    > > >> news:#AyImcGwEHA.1264@TK2MSFTNGP12.phx.gbl...
    > > >>>
    > > >>> "Gabe Knuth" <news@gabeknuth.com (not for legit emails, use my
    > > >>> first name @ gabeknuth.com for those)> wrote in message
    > > >>> news:OtHh47FwEHA.1392@tk2msftngp13.phx.gbl...
    > > >>>> The policy is configured for the container that the users are in,
    > > >>>> permissions are set correctly.
    > > >>>>
    > > >>>> Other items are configured (and working) in the same policy, like
    > > >>>> Screen Saver settings and desktop settings, but it appears that
    > > >>>> you are correct - the MyDocs redirection isn't getting pushed.
    > > >>>>
    > > >>>> Workstation is WinXP Pro SP1. Novell Client 4.9SP2. Win2k3 AD.
    > > >>>>
    > > >>>> Any other information that might be helpful?
    > > >>>>
    > > >>>>
    > > >>> Can you redirect to a UNC path? \\server\%username%
    > > >>>
    > > >>> Just an idea. I'm not too up on folder redirection.
    > > >>>
    > > >>> Matt
    > > >>> MCT, MCSE
    > >
    > >
    >
    >
  11. Archived from groups: microsoft.public.win2000.group_policy (More info?)

    Ok, so here's what's new.

    I created a second policy just for folder redirection, which is apparently
    working now, but still not remapping MyDocs to the H:\ drive.

    The problem is what I suspected before - Since the H: drive doesn't exist
    when the GPO is applied, I get a failure event in the Application log. The
    error follows:

    >Error 101
    >Source FolderRedirection

    >Failed to perform redirection of folder My Documents. The new directories
    for the redirectedc folder could not be created. The folder is configured to
    be redirected to <\\%HOMESHARE%%HOMEPATH%>, the final >expanded path was
    <h:\>. The following error occurred: The system cannot find the path
    specified

    so my original problem is confirmed, which begs the question again - can I
    force the GPO to apply, even with that error? Or, can I apply it in or
    after the Novell Login (I know, not exactly the best group to ask)?


    "Gabe Knuth" <GabeKnuth@discussions.microsoft.com> wrote in message
    news:D51D1536-B449-4A97-921E-E26527CE0338@microsoft.com...

    > I'm in a Novell / Microsoft environment where all the users files are
    stored
    > on the Novell servers (H: Drive). I'm rolling out AD, and would like to
    > force each user's MyDocs folder to be redirected to their H: Drive, but it
    > doesn't work because the GPO's are applied before the H: Drive mapping is
    > created.
    >
    > Can anyone think of a way to force the redirection to happen, even if the
    h:
    > drive doesn't yet exist?
    >
    > I guess if all else fails, I can have their Netware login script set the
    > local registry key after it runs, but that's a little more manual then I
    > wanted.
    >
    > Thanks,
    > Gabe
  12. Archived from groups: microsoft.public.win2000.group_policy (More info?)

    Gabe Knuth wrote:
    > Ok, so here's what's new.
    >
    > I created a second policy just for folder redirection, which is
    > apparently working now, but still not remapping MyDocs to the H:\
    > drive.
    >
    > The problem is what I suspected before - Since the H: drive doesn't
    > exist when the GPO is applied, I get a failure event in the
    > Application log. The error follows:
    >
    >> Error 101
    >> Source FolderRedirection
    >
    >> Failed to perform redirection of folder My Documents. The new
    >> directories
    > for the redirectedc folder could not be created. The folder is
    > configured to be redirected to <\\%HOMESHARE%%HOMEPATH%>, the final
    > >expanded path was <h:\>. The following error occurred: The system
    > cannot find the path specified

    Hmmm - curious as to why it specifies %homeshare% instead of the actual UNC
    path? In ADUC I specify \\server\home$\%username for each user's home
    directory....and have never had a problem. I am pretty much a complete moron
    with regards to the finer points of group policy, but this has worked well
    for me in the past. Maybe I'm missing something here?

    >
    > so my original problem is confirmed, which begs the question again -
    > can I force the GPO to apply, even with that error? Or, can I apply
    > it in or after the Novell Login (I know, not exactly the best group
    > to ask)?
    >
    >
    >
    >
    >
    >
    >
    > "Gabe Knuth" <GabeKnuth@discussions.microsoft.com> wrote in message
    > news:D51D1536-B449-4A97-921E-E26527CE0338@microsoft.com...
    >
    >> I'm in a Novell / Microsoft environment where all the users files
    >> are stored on the Novell servers (H: Drive). I'm rolling out AD,
    >> and would like to force each user's MyDocs folder to be redirected
    >> to their H: Drive, but it doesn't work because the GPO's are applied
    >> before the H: Drive mapping is created.
    >>
    >> Can anyone think of a way to force the redirection to happen, even
    >> if the h: drive doesn't yet exist?
    >>
    >> I guess if all else fails, I can have their Netware login script set
    >> the local registry key after it runs, but that's a little more
    >> manual then I wanted.
    >>
    >> Thanks,
    >> Gabe
  13. Archived from groups: microsoft.public.win2000.group_policy (More info?)

    Well, I told the GPO to redirect to ther user's home drive. I think it
    replaced that with %HOMESHARE%%HOMEPATH%, which is the env var for the
    user's home drive.

    So I think the problem goes back to the fact that their home drive doesn't
    yet exist. I'm thinking I'm up a creek...

    Thanks for all your suggestions.

    "Lanwench [MVP - Exchange]"
    <lanwench@heybuddy.donotsendme.unsolicitedmail.atyahoo.com> wrote in message
    news:OOycxSgwEHA.1564@TK2MSFTNGP09.phx.gbl...
    > Gabe Knuth wrote:
    > > Ok, so here's what's new.
    > >
    > > I created a second policy just for folder redirection, which is
    > > apparently working now, but still not remapping MyDocs to the H:\
    > > drive.
    > >
    > > The problem is what I suspected before - Since the H: drive doesn't
    > > exist when the GPO is applied, I get a failure event in the
    > > Application log. The error follows:
    > >
    > >> Error 101
    > >> Source FolderRedirection
    > >
    > >> Failed to perform redirection of folder My Documents. The new
    > >> directories
    > > for the redirectedc folder could not be created. The folder is
    > > configured to be redirected to <\\%HOMESHARE%%HOMEPATH%>, the final
    > > >expanded path was <h:\>. The following error occurred: The system
    > > cannot find the path specified
    >
    > Hmmm - curious as to why it specifies %homeshare% instead of the actual
    UNC
    > path? In ADUC I specify \\server\home$\%username for each user's home
    > directory....and have never had a problem. I am pretty much a complete
    moron
    > with regards to the finer points of group policy, but this has worked well
    > for me in the past. Maybe I'm missing something here?
    >
    > >
    > > so my original problem is confirmed, which begs the question again -
    > > can I force the GPO to apply, even with that error? Or, can I apply
    > > it in or after the Novell Login (I know, not exactly the best group
    > > to ask)?
    > >
    > >
    > >
    > >
    > >
    > >
    > >
    > > "Gabe Knuth" <GabeKnuth@discussions.microsoft.com> wrote in message
    > > news:D51D1536-B449-4A97-921E-E26527CE0338@microsoft.com...
    > >
    > >> I'm in a Novell / Microsoft environment where all the users files
    > >> are stored on the Novell servers (H: Drive). I'm rolling out AD,
    > >> and would like to force each user's MyDocs folder to be redirected
    > >> to their H: Drive, but it doesn't work because the GPO's are applied
    > >> before the H: Drive mapping is created.
    > >>
    > >> Can anyone think of a way to force the redirection to happen, even
    > >> if the h: drive doesn't yet exist?
    > >>
    > >> I guess if all else fails, I can have their Netware login script set
    > >> the local registry key after it runs, but that's a little more
    > >> manual then I wanted.
    > >>
    > >> Thanks,
    > >> Gabe
    >
    >
Ask a new question

Read More

Novell Microsoft Windows