IE Maintainance Policy XP SP2

Archived from groups: microsoft.public.win2000.group_policy (More info?)

Hi

I have an issue with IE Maintainance policy not being applied after
upgrading clients to XP SP2. In particular, home page settings, proxy
settings and favourites are no longer being applied after upgrade.

I read in an earlier post relating to proxy settings that hotfix 888254 from
Microsoft was required to fix this. I obtained this fix, and the proxy
setting issue was resolved. However, home page and favourites policies are
still not being applied.

Can anyone help? Are further hotfixes required?

Windows 2000 domain. 2000 pro clients are not affected.

Regards
P Basham
12 answers Last reply
More about maintainance policy
  1. Archived from groups: microsoft.public.win2000.group_policy (More info?)

    Hi

    Keep in mind that Internet Explorer Maintenance Policy only re-applies when
    it's changed or when it's new. You can alter this behaviour with:

    306915 Internet Explorer Maintenance Group Policies Do Not Apply During
    http://support.microsoft.com/?id=306915

    You might find some reason for the policy not applying if you refer to a
    User Environment Debug log:

    221833 How to enable user environment debug logging in retail builds of
    Windows
    http://support.microsoft.com/?id=221833

    You can also refer to the brndlog.txt file in:

    <user profile>\\Application Data\Microsoft\Internet Explorer

    HTH
    --
    Mark Renoden [MSFT]
    Windows Platform Support Team
    Email: markreno@online.microsoft.com

    Please note you'll need to strip ".online" from my email address to email
    me; I'll post a response back to the group.

    This posting is provided "AS IS" with no warranties, and confers no rights.

    "P Basham" <P Basham@discussions.microsoft.com> wrote in message
    news:97BA4C97-950A-4E7B-89C6-B7BB5A6AC669@microsoft.com...
    > Hi
    >
    > I have an issue with IE Maintainance policy not being applied after
    > upgrading clients to XP SP2. In particular, home page settings, proxy
    > settings and favourites are no longer being applied after upgrade.
    >
    > I read in an earlier post relating to proxy settings that hotfix 888254
    > from
    > Microsoft was required to fix this. I obtained this fix, and the proxy
    > setting issue was resolved. However, home page and favourites policies are
    > still not being applied.
    >
    > Can anyone help? Are further hotfixes required?
    >
    > Windows 2000 domain. 2000 pro clients are not affected.
    >
    > Regards
    > P Basham
  2. Archived from groups: microsoft.public.win2000.group_policy (More info?)

    Mark

    Many thanks for the quick reply. Unfortunately no joy, heres what I did:

    Reset browser settings in pupils OU, IE Maintainance Policy. Re-entered
    values (Proxy, HomePage, URL's).
    Reset registry key NoGPOListChanges to 0 on client machine.
    Deleted Local XP SP2 client Documents and Settings\<username>.
    Rebooted.
    Logged on as <username>

    Again, proxy settings applied, but nothing else.

    Please be aware Application Data folder is stored in users home folder on
    server.

    Here is the entry from todays brndlog.txt relating to <username>
    02/04/2005 10:40:09 ! NoExternalBranding restriction is set. Branding will
    not be applied.
    02/04/2005 10:40:09 Done.

    Windows 2000 Pro clients still behaving nicely.

    Regards
    P Basham
  3. Archived from groups: microsoft.public.win2000.group_policy (More info?)

    Hi

    The NoExternalBranding restriction is usually set via:

    User Configuration\Administrative Templates\Windows Components\Internet
    Explorer\Disable external branding of Internet Explorer.

    This would prevent the application of Maintenance Policy. You might want to
    look through the GPO's that are applying to the user and see if this is set.

    If the policy isn't set, it may be set statically under

    HKCU\Software\Microsoft\Internet Explorer\Restrictions

    HTH
    --
    Mark Renoden [MSFT]
    Windows Platform Support Team
    Email: markreno@online.microsoft.com

    Please note you'll need to strip ".online" from my email address to email
    me; I'll post a response back to the group.

    This posting is provided "AS IS" with no warranties, and confers no rights.


    "P Basham" <PBasham@discussions.microsoft.com> wrote in message
    news:05F88470-2CF3-4344-99F0-819B9F3ECBAE@microsoft.com...
    > Mark
    >
    > Many thanks for the quick reply. Unfortunately no joy, heres what I did:
    >
    > Reset browser settings in pupils OU, IE Maintainance Policy. Re-entered
    > values (Proxy, HomePage, URL's).
    > Reset registry key NoGPOListChanges to 0 on client machine.
    > Deleted Local XP SP2 client Documents and Settings\<username>.
    > Rebooted.
    > Logged on as <username>
    >
    > Again, proxy settings applied, but nothing else.
    >
    > Please be aware Application Data folder is stored in users home folder on
    > server.
    >
    > Here is the entry from todays brndlog.txt relating to <username>
    > 02/04/2005 10:40:09 ! NoExternalBranding restriction is set. Branding will
    > not be applied.
    > 02/04/2005 10:40:09 Done.
    >
    > Windows 2000 Pro clients still behaving nicely.
    >
    > Regards
    > P Basham
    >
    >
    >
    >
    >
  4. Archived from groups: microsoft.public.win2000.group_policy (More info?)

    Mark

    Again, thanks for the reply. We did have the disable branding policy set,
    but after enabling it, we only have the default links & favouites set, our
    url's are not applied.

    The proxy & about:blank policies are now being applied, these are both set
    on the default domain policy. We have two OU's, pupils and staff. On these
    policies we have differing url's set. Neither of the two IE maintainance
    policies are being applied.

    After uninstalling XP SP2 on a machine, all the problems disappear. Windows
    2000 Pro machines and 2003 Server also have no problems. This has to be a bug
    of some discription. Do you know of a fix?

    Regards
    Paul Basham
  5. Archived from groups: microsoft.public.win2000.group_policy (More info?)

    Hi Paul

    This does sound like 888254. I see from your original post that you've
    tried this. Did you also obtain the registry modification that allows this
    fix to take effect?

    Paste the stuff between the **** into a text file and name .reg and run it
    on an effected client. Be careful with word wrapping in your newsreader

    ****
    Windows Registry Editor Version 5.00

    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet
    Explorer\Main\FeatureControl\FEATURE_GPO_BRANDING_WITH_FOLDER_REDIRECTION_KB888254]
    "*"=dword:00000001
    "IEXPLORE.EXE"=dword:00000001
    "EXPLORER.EXE"=dword:00000001
    ****

    If that doesn't resolve the issue, I'd suggest logging a case with Microsoft
    so that a possible additional bug can be investigated.

    Kind regards
    --
    Mark Renoden [MSFT]
    Windows Platform Support Team
    Email: markreno@online.microsoft.com

    Please note you'll need to strip ".online" from my email address to email
    me; I'll post a response back to the group.

    This posting is provided "AS IS" with no warranties, and confers no rights.


    "P Basham" <PBasham@discussions.microsoft.com> wrote in message
    news:26A74BC3-40B7-4551-9E05-5702ECEDFC83@microsoft.com...
    > Mark
    >
    > Again, thanks for the reply. We did have the disable branding policy set,
    > but after enabling it, we only have the default links & favouites set, our
    > url's are not applied.
    >
    > The proxy & about:blank policies are now being applied, these are both set
    > on the default domain policy. We have two OU's, pupils and staff. On these
    > policies we have differing url's set. Neither of the two IE maintainance
    > policies are being applied.
    >
    > After uninstalling XP SP2 on a machine, all the problems disappear.
    > Windows
    > 2000 Pro machines and 2003 Server also have no problems. This has to be a
    > bug
    > of some discription. Do you know of a fix?
    >
    > Regards
    > Paul Basham
  6. Archived from groups: microsoft.public.win2000.group_policy (More info?)

    I just want to add that I installed the patch and installed the new registry
    keys, but the problem remains. I have a group policy that adds a server to
    the trusted sites zone so my users don't have to retype their usernames and
    passwords, they can use integrated authentication instead. According to
    gpresult /z the policy is being applied, but integrated authentication has
    not worked since windows xp sp2. How does a person log a case to get this
    problem looked at?

    Just my two cents on the problem,

    Jason


    "Mark Renoden [MSFT]" <markreno@online.microsoft.com> wrote in message
    news:OI$queVDFHA.228@tk2msftngp13.phx.gbl...
    > Hi Paul
    >
    > This does sound like 888254. I see from your original post that you've
    > tried this. Did you also obtain the registry modification that allows
    > this fix to take effect?
    >
    > Paste the stuff between the **** into a text file and name .reg and run it
    > on an effected client. Be careful with word wrapping in your newsreader
    >
    > ****
    > Windows Registry Editor Version 5.00
    >
    > [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet
    > Explorer\Main\FeatureControl\FEATURE_GPO_BRANDING_WITH_FOLDER_REDIRECTION_KB888254]
    > "*"=dword:00000001
    > "IEXPLORE.EXE"=dword:00000001
    > "EXPLORER.EXE"=dword:00000001
    > ****
    >
    > If that doesn't resolve the issue, I'd suggest logging a case with
    > Microsoft so that a possible additional bug can be investigated.
    >
    > Kind regards
    > --
    > Mark Renoden [MSFT]
    > Windows Platform Support Team
    > Email: markreno@online.microsoft.com
    >
    > Please note you'll need to strip ".online" from my email address to email
    > me; I'll post a response back to the group.
    >
    > This posting is provided "AS IS" with no warranties, and confers no
    > rights.
    >
    >
    >
    > "P Basham" <PBasham@discussions.microsoft.com> wrote in message
    > news:26A74BC3-40B7-4551-9E05-5702ECEDFC83@microsoft.com...
    >> Mark
    >>
    >> Again, thanks for the reply. We did have the disable branding policy set,
    >> but after enabling it, we only have the default links & favouites set,
    >> our
    >> url's are not applied.
    >>
    >> The proxy & about:blank policies are now being applied, these are both
    >> set
    >> on the default domain policy. We have two OU's, pupils and staff. On
    >> these
    >> policies we have differing url's set. Neither of the two IE maintainance
    >> policies are being applied.
    >>
    >> After uninstalling XP SP2 on a machine, all the problems disappear.
    >> Windows
    >> 2000 Pro machines and 2003 Server also have no problems. This has to be a
    >> bug
    >> of some discription. Do you know of a fix?
    >>
    >> Regards
    >> Paul Basham
    >
    >
  7. Archived from groups: microsoft.public.win2000.group_policy (More info?)

    Jason

    I found I had to delete the local C:\Documents and Settings\<username>
    folder before the settings applied to the user.

    HTH
    Paul Basham

    "Jason Dravet" wrote:

    > I just want to add that I installed the patch and installed the new registry
    > keys, but the problem remains. I have a group policy that adds a server to
    > the trusted sites zone so my users don't have to retype their usernames and
    > passwords, they can use integrated authentication instead. According to
    > gpresult /z the policy is being applied, but integrated authentication has
    > not worked since windows xp sp2. How does a person log a case to get this
    > problem looked at?
    >
    > Just my two cents on the problem,
    >
    > Jason
    >
    >
    > "Mark Renoden [MSFT]" <markreno@online.microsoft.com> wrote in message
    > news:OI$queVDFHA.228@tk2msftngp13.phx.gbl...
    > > Hi Paul
    > >
    > > This does sound like 888254. I see from your original post that you've
    > > tried this. Did you also obtain the registry modification that allows
    > > this fix to take effect?
    > >
    > > Paste the stuff between the **** into a text file and name .reg and run it
    > > on an effected client. Be careful with word wrapping in your newsreader
    > >
    > > ****
    > > Windows Registry Editor Version 5.00
    > >
    > > [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet
    > > Explorer\Main\FeatureControl\FEATURE_GPO_BRANDING_WITH_FOLDER_REDIRECTION_KB888254]
    > > "*"=dword:00000001
    > > "IEXPLORE.EXE"=dword:00000001
    > > "EXPLORER.EXE"=dword:00000001
    > > ****
    > >
    > > If that doesn't resolve the issue, I'd suggest logging a case with
    > > Microsoft so that a possible additional bug can be investigated.
    > >
    > > Kind regards
    > > --
    > > Mark Renoden [MSFT]
    > > Windows Platform Support Team
    > > Email: markreno@online.microsoft.com
    > >
    > > Please note you'll need to strip ".online" from my email address to email
    > > me; I'll post a response back to the group.
    > >
    > > This posting is provided "AS IS" with no warranties, and confers no
    > > rights.
    > >
    > >
    > >
    > > "P Basham" <PBasham@discussions.microsoft.com> wrote in message
    > > news:26A74BC3-40B7-4551-9E05-5702ECEDFC83@microsoft.com...
    > >> Mark
    > >>
    > >> Again, thanks for the reply. We did have the disable branding policy set,
    > >> but after enabling it, we only have the default links & favouites set,
    > >> our
    > >> url's are not applied.
    > >>
    > >> The proxy & about:blank policies are now being applied, these are both
    > >> set
    > >> on the default domain policy. We have two OU's, pupils and staff. On
    > >> these
    > >> policies we have differing url's set. Neither of the two IE maintainance
    > >> policies are being applied.
    > >>
    > >> After uninstalling XP SP2 on a machine, all the problems disappear.
    > >> Windows
    > >> 2000 Pro machines and 2003 Server also have no problems. This has to be a
    > >> bug
    > >> of some discription. Do you know of a fix?
    > >>
    > >> Regards
    > >> Paul Basham
    > >
    > >
    >
    >
    >
    >
  8. Archived from groups: microsoft.public.win2000.group_policy (More info?)

    Hi Jason

    If you head to http://support.microsoft.com you'll see a list of support
    options on the left that link to the specific information for your region.

    Kind regards
    --
    Mark Renoden [MSFT]
    Windows Platform Support Team
    Email: markreno@online.microsoft.com

    Please note you'll need to strip ".online" from my email address to email
    me; I'll post a response back to the group.

    This posting is provided "AS IS" with no warranties, and confers no rights.

    "Jason Dravet" <dravet@calumet.purdue.edu> wrote in message
    news:%23RoxPsWDFHA.1396@tk2msftngp13.phx.gbl...
    >I just want to add that I installed the patch and installed the new
    >registry keys, but the problem remains. I have a group policy that adds a
    >server to the trusted sites zone so my users don't have to retype their
    >usernames and passwords, they can use integrated authentication instead.
    >According to gpresult /z the policy is being applied, but integrated
    >authentication has not worked since windows xp sp2. How does a person log
    >a case to get this problem looked at?
    >
    > Just my two cents on the problem,
    >
    > Jason
    >
    >
    > "Mark Renoden [MSFT]" <markreno@online.microsoft.com> wrote in message
    > news:OI$queVDFHA.228@tk2msftngp13.phx.gbl...
    >> Hi Paul
    >>
    >> This does sound like 888254. I see from your original post that you've
    >> tried this. Did you also obtain the registry modification that allows
    >> this fix to take effect?
    >>
    >> Paste the stuff between the **** into a text file and name .reg and run
    >> it
    >> on an effected client. Be careful with word wrapping in your newsreader
    >>
    >> ****
    >> Windows Registry Editor Version 5.00
    >>
    >> [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet
    >> Explorer\Main\FeatureControl\FEATURE_GPO_BRANDING_WITH_FOLDER_REDIRECTION_KB888254]
    >> "*"=dword:00000001
    >> "IEXPLORE.EXE"=dword:00000001
    >> "EXPLORER.EXE"=dword:00000001
    >> ****
    >>
    >> If that doesn't resolve the issue, I'd suggest logging a case with
    >> Microsoft so that a possible additional bug can be investigated.
    >>
    >> Kind regards
    >> --
    >> Mark Renoden [MSFT]
    >> Windows Platform Support Team
    >> Email: markreno@online.microsoft.com
    >>
    >> Please note you'll need to strip ".online" from my email address to email
    >> me; I'll post a response back to the group.
    >>
    >> This posting is provided "AS IS" with no warranties, and confers no
    >> rights.
    >>
    >>
    >>
    >> "P Basham" <PBasham@discussions.microsoft.com> wrote in message
    >> news:26A74BC3-40B7-4551-9E05-5702ECEDFC83@microsoft.com...
    >>> Mark
    >>>
    >>> Again, thanks for the reply. We did have the disable branding policy
    >>> set,
    >>> but after enabling it, we only have the default links & favouites set,
    >>> our
    >>> url's are not applied.
    >>>
    >>> The proxy & about:blank policies are now being applied, these are both
    >>> set
    >>> on the default domain policy. We have two OU's, pupils and staff. On
    >>> these
    >>> policies we have differing url's set. Neither of the two IE maintainance
    >>> policies are being applied.
    >>>
    >>> After uninstalling XP SP2 on a machine, all the problems disappear.
    >>> Windows
    >>> 2000 Pro machines and 2003 Server also have no problems. This has to be
    >>> a
    >>> bug
    >>> of some discription. Do you know of a fix?
    >>>
    >>> Regards
    >>> Paul Basham
    >>
    >>
    >
    >
    >
  9. Archived from groups: microsoft.public.win2000.group_policy (More info?)

    Mark

    Success!! Many thanks.

    You would have thought the guy from Microsoft may have mentioned the .reg
    key to me when I requested the hotfix.

    Again, many thanks.

    Paul Basham
  10. Archived from groups: microsoft.public.win2000.group_policy (More info?)

    Mark

    Success!! Many thanks.

    You would have thought the guy from Microsoft would have mentioned the .reg
    key when I requested the hotfix.

    Thanks again.
    Paul Basham
  11. Archived from groups: microsoft.public.win2000.group_policy (More info?)

    Hi Paul

    This is actually a public article now and contains the registry information
    that's needed:

    888254 You cannot set the Folder Redirection policy setting on a Windows
    http://support.microsoft.com/?id=888254

    Kind regards
    --
    Mark Renoden [MSFT]
    Windows Platform Support Team
    Email: markreno@online.microsoft.com

    Please note you'll need to strip ".online" from my email address to email
    me; I'll post a response back to the group.

    This posting is provided "AS IS" with no warranties, and confers no rights.

    "P Basham" <PBasham@discussions.microsoft.com> wrote in message
    news:1513F0EC-6580-48C8-867C-E34909243A83@microsoft.com...
    > Mark
    >
    > Success!! Many thanks.
    >
    > You would have thought the guy from Microsoft may have mentioned the .reg
    > key to me when I requested the hotfix.
    >
    > Again, many thanks.
    >
    > Paul Basham
  12. Archived from groups: microsoft.public.win2000.group_policy (More info?)

    Thanks, I will give that a try. I am sorry it took so long to respond, but
    I was sick last week.

    Jason

    "P Basham" <PBasham@discussions.microsoft.com> wrote in message
    news:832E22A0-EB75-4A54-A139-5C40C3CBBDD2@microsoft.com...
    > Jason
    >
    > I found I had to delete the local C:\Documents and Settings\<username>
    > folder before the settings applied to the user.
    >
    > HTH
    > Paul Basham
    >
    > "Jason Dravet" wrote:
    >
    >> I just want to add that I installed the patch and installed the new
    >> registry
    >> keys, but the problem remains. I have a group policy that adds a server
    >> to
    >> the trusted sites zone so my users don't have to retype their usernames
    >> and
    >> passwords, they can use integrated authentication instead. According to
    >> gpresult /z the policy is being applied, but integrated authentication
    >> has
    >> not worked since windows xp sp2. How does a person log a case to get
    >> this
    >> problem looked at?
    >>
    >> Just my two cents on the problem,
    >>
    >> Jason
    >>
    >>
    >> "Mark Renoden [MSFT]" <markreno@online.microsoft.com> wrote in message
    >> news:OI$queVDFHA.228@tk2msftngp13.phx.gbl...
    >> > Hi Paul
    >> >
    >> > This does sound like 888254. I see from your original post that you've
    >> > tried this. Did you also obtain the registry modification that allows
    >> > this fix to take effect?
    >> >
    >> > Paste the stuff between the **** into a text file and name .reg and run
    >> > it
    >> > on an effected client. Be careful with word wrapping in your
    >> > newsreader
    >> >
    >> > ****
    >> > Windows Registry Editor Version 5.00
    >> >
    >> > [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet
    >> > Explorer\Main\FeatureControl\FEATURE_GPO_BRANDING_WITH_FOLDER_REDIRECTION_KB888254]
    >> > "*"=dword:00000001
    >> > "IEXPLORE.EXE"=dword:00000001
    >> > "EXPLORER.EXE"=dword:00000001
    >> > ****
    >> >
    >> > If that doesn't resolve the issue, I'd suggest logging a case with
    >> > Microsoft so that a possible additional bug can be investigated.
    >> >
    >> > Kind regards
    >> > --
    >> > Mark Renoden [MSFT]
    >> > Windows Platform Support Team
    >> > Email: markreno@online.microsoft.com
    >> >
    >> > Please note you'll need to strip ".online" from my email address to
    >> > email
    >> > me; I'll post a response back to the group.
    >> >
    >> > This posting is provided "AS IS" with no warranties, and confers no
    >> > rights.
    >> >
    >> >
    >> >
    >> > "P Basham" <PBasham@discussions.microsoft.com> wrote in message
    >> > news:26A74BC3-40B7-4551-9E05-5702ECEDFC83@microsoft.com...
    >> >> Mark
    >> >>
    >> >> Again, thanks for the reply. We did have the disable branding policy
    >> >> set,
    >> >> but after enabling it, we only have the default links & favouites set,
    >> >> our
    >> >> url's are not applied.
    >> >>
    >> >> The proxy & about:blank policies are now being applied, these are both
    >> >> set
    >> >> on the default domain policy. We have two OU's, pupils and staff. On
    >> >> these
    >> >> policies we have differing url's set. Neither of the two IE
    >> >> maintainance
    >> >> policies are being applied.
    >> >>
    >> >> After uninstalling XP SP2 on a machine, all the problems disappear.
    >> >> Windows
    >> >> 2000 Pro machines and 2003 Server also have no problems. This has to
    >> >> be a
    >> >> bug
    >> >> of some discription. Do you know of a fix?
    >> >>
    >> >> Regards
    >> >> Paul Basham
    >> >
    >> >
    >>
    >>
    >>
    >>
Ask a new question

Read More

Policy Internet Explorer Windows XP Microsoft Proxy Windows