Read Only Problem

Archived from groups: microsoft.public.windowsxp.basics (More info?)

I have a problem and no one seems to be able to help.
I am running WinXP Home which came with the computer.
MS Site: Simple File Sharing is always turned on in Windows XP Home
Edition-based computers.

I have a folder called C:\DecoTechCatalogInch
The problem is that it is Read Only.
The check mark is grey not black
When I click on it, the check mark goes away.
I click on apply.
But when I click on properties again it is checked with the grey check mark.

The problem has gone to most of my other folders.
I have never had this problem before.
I ran Norton AntiVirus and did not find any Viruses.
I booted up in Safe Mode and the same problem.
It looks like a permissions problem but I do not see any place to change
anything that would help.
4 answers Last reply
More about read problem
  1. Archived from groups: microsoft.public.windowsxp.basics (More info?)

    The gray state means...

    [[Microsoft calls this a tri-mode flag. When it has gray in the background,
    it indicates that some file or folder anywhere under that particular folder
    has been set to Read-only.

    This checkmark does not actually control the Read-only attribute on the
    child files and folder. It just displays their status.]]

    Rally 'Round the Tri-Mode Flag
    http://www.mcpmag.com/columns/article.asp?EditorialsID=652

    Read-only means nothing for folders...

    [[Unlike the Read-only attribute for a file, the Read-only attribute for a
    folder is typically ignored by Windows, Windows components and accessories,
    and other programs.]]

    Basically this means nothing for folders.

    [[Windows Explorer uses the Read-Only attribute to determine whether or not
    the folder is customized.]]
    Unable to Remove Read-Only Attribute from Folder
    http://support.microsoft.com/kb/256614/EN-US/

    HOW TO: Take Ownership of a File or Folder in Windows XP
    http://support.microsoft.com/default.aspx?scid=kb;en-us;308421

    --
    Hope this helps. Let us know.

    Wes
    MS-MVP Windows Shell/User

    In news:Ok%23Qb2JFFHA.1084@tk2msftngp13.phx.gbl,
    Ted.Knudson <tedNews1(aatt)pulsarusa.com> hunted and pecked:
    > I have a problem and no one seems to be able to help.
    > I am running WinXP Home which came with the computer.
    > MS Site: Simple File Sharing is always turned on in Windows XP Home
    > Edition-based computers.
    >
    > I have a folder called C:\DecoTechCatalogInch
    > The problem is that it is Read Only.
    > The check mark is grey not black
    > When I click on it, the check mark goes away.
    > I click on apply.
    > But when I click on properties again it is checked with the grey
    > check mark.
    >
    > The problem has gone to most of my other folders.
    > I have never had this problem before.
    > I ran Norton AntiVirus and did not find any Viruses.
    > I booted up in Safe Mode and the same problem.
    > It looks like a permissions problem but I do not see any place to
    > change anything that would help.
  2. Archived from groups: microsoft.public.windowsxp.basics (More info?)

    That attribute is meaningless insofar as the user is concerned. All XP
    folders show read as read only by default.

    If you are having a problem accessing or reading files within the folder,
    it's likely a file ownership issue.

    Note, file ownership and permissions supersede administrator rights. How
    you resolve it depends upon which version of XP you are running.

    XP-Home

    Unfortunately, XP Home using NTFS is essentially hard wired for "Simple File
    Sharing" at system level.

    However, you can set XP Home permissions in Safe Mode. Reboot, and start
    hitting F8, a menu should eventually appear and one of the
    options is Safe Mode. Select it. Note, it will ask for the administrator's
    password. This is not your administrator account, rather it is the
    machine's administrator account for which users are asked to create a
    password during setup.

    If you created no such password, when requested, leave blank and press
    enter.

    Open Explorer, go to Tools and Folder Options, on the view tab, scroll to
    the bottom of the list, if it shows "Enable Simple File Sharing" deselect it
    and click apply and ok. If it shows nothing or won't let you make a change,
    move on to the next step.

    Navigate to the files, right click, select properties, go to the Security
    tab, click advanced, go to the Owner tab and select the user that was logged
    on when you were refused permission to access the files. Click apply and
    ok. Close the properties box, reopen it, click add and type in the name of
    the user you just enabled. If you wish to set ownership for everything in
    the folder, at the bottom of the Owner tab is the following selection:
    "Replace owner on subcontainers and objects," select it as well.

    Once complete, you should be able to do what you wish with these files when
    you log back on as that user.

    XP-Pro

    If you have XP Pro, temporarily change the limited account to
    administrative. First, go to Windows Explorer, go to Tools, select Folder
    Options, go to the View tab and be sure "Use Simple File Sharing" is not
    selected. If it is, deselect it and click apply and ok.

    If you wish everything in a specific folder to be accessible to a user,
    right click the folder, select properties, go to the Security tab, click
    Advanced, go to the Owner tab,
    select the user you wish to have access, at the bottom of the box, you
    should see a check box for "Replace owner on subcontainers and objects,"
    place a check in the box and click apply and ok.

    The user should now be able to perform necessary functions on files in the
    folder even as a limited account. If not, make it an admin account again,
    right click the folder, select Properties, go to the Security tab and be
    sure the user is listed in the user list. If not, click add and type the
    user name in the appropriate box, be sure the user has all the necessary
    permissions checked in the permission list below the user list, click apply
    and ok.

    That should do it and allow whatever access you desire for that folder even
    in a limited account.
    --
    Michael Solomon MS-MVP
    Windows Shell/User
    Backup is a PC User's Best Friend
    DTS-L.Org: http://www.dts-l.org/

    "Ted.Knudson" <tedNews1(aatt)pulsarusa.com> wrote in message
    news:Ok%23Qb2JFFHA.1084@tk2msftngp13.phx.gbl...
    >I have a problem and no one seems to be able to help.
    > I am running WinXP Home which came with the computer.
    > MS Site: Simple File Sharing is always turned on in Windows XP Home
    > Edition-based computers.
    >
    > I have a folder called C:\DecoTechCatalogInch
    > The problem is that it is Read Only.
    > The check mark is grey not black
    > When I click on it, the check mark goes away.
    > I click on apply.
    > But when I click on properties again it is checked with the grey check
    > mark.
    >
    > The problem has gone to most of my other folders.
    > I have never had this problem before.
    > I ran Norton AntiVirus and did not find any Viruses.
    > I booted up in Safe Mode and the same problem.
    > It looks like a permissions problem but I do not see any place to change
    > anything that would help.
    >
  3. Archived from groups: microsoft.public.windowsxp.basics (More info?)

    Thanks that solved the problem

    Ted

    "Wesley Vogel" <123WVogel955@comcast.net> wrote in message
    news:Ohy1L5JFFHA.3972@TK2MSFTNGP15.phx.gbl...
    > The gray state means...
    >
    > [[Microsoft calls this a tri-mode flag. When it has gray in the
    > background,
    > it indicates that some file or folder anywhere under that particular
    > folder
    > has been set to Read-only.
    >
    > This checkmark does not actually control the Read-only attribute on the
    > child files and folder. It just displays their status.]]
    >
    > Rally 'Round the Tri-Mode Flag
    > http://www.mcpmag.com/columns/article.asp?EditorialsID=652
    >
    > Read-only means nothing for folders...
    >
    > [[Unlike the Read-only attribute for a file, the Read-only attribute for a
    > folder is typically ignored by Windows, Windows components and
    > accessories,
    > and other programs.]]
    >
    > Basically this means nothing for folders.
    >
    > [[Windows Explorer uses the Read-Only attribute to determine whether or
    > not
    > the folder is customized.]]
    > Unable to Remove Read-Only Attribute from Folder
    > http://support.microsoft.com/kb/256614/EN-US/
    >
    > HOW TO: Take Ownership of a File or Folder in Windows XP
    > http://support.microsoft.com/default.aspx?scid=kb;en-us;308421
    >
    > --
    > Hope this helps. Let us know.
    >
    > Wes
    > MS-MVP Windows Shell/User
    >
    > In news:Ok%23Qb2JFFHA.1084@tk2msftngp13.phx.gbl,
    > Ted.Knudson <tedNews1(aatt)pulsarusa.com> hunted and pecked:
    >> I have a problem and no one seems to be able to help.
    >> I am running WinXP Home which came with the computer.
    >> MS Site: Simple File Sharing is always turned on in Windows XP Home
    >> Edition-based computers.
    >>
    >> I have a folder called C:\DecoTechCatalogInch
    >> The problem is that it is Read Only.
    >> The check mark is grey not black
    >> When I click on it, the check mark goes away.
    >> I click on apply.
    >> But when I click on properties again it is checked with the grey
    >> check mark.
    >>
    >> The problem has gone to most of my other folders.
    >> I have never had this problem before.
    >> I ran Norton AntiVirus and did not find any Viruses.
    >> I booted up in Safe Mode and the same problem.
    >> It looks like a permissions problem but I do not see any place to
    >> change anything that would help.
    >
  4. Archived from groups: microsoft.public.windowsxp.basics (More info?)

    "Ted.Knudson" <tedNews1(aatt)pulsarusa.com> wrote:

    >I have a folder called C:\DecoTechCatalogInch
    >The problem is that it is Read Only.
    >The check mark is grey not black
    >When I click on it, the check mark goes away.

    Read only is an attribute that has no meaning for folders (the
    directories are always open for writing), and XP makes an alternative
    use of it. You can change it and on Apply it will ask if you want the
    change applied to all contained objects, but the display of it for the
    folder will revert to greyed

    If a program is refusing to run because of this it is the program's
    fault for testing something it should not. Complain to the authors


    --
    Alex Nichol MS MVP (Windows Technologies)
    Bournemouth, U.K. Alexn@mvps.D8E8L.org (remove the D8 bit)
Ask a new question

Read More

Read Only Windows XP