Sign in with
Sign up | Sign in
Your question

GPO Software deployment not working from W2K3 Cluster shar..

Last response: in Windows 2000/NT
Share
May 5, 2005 1:08:44 PM

Archived from groups: microsoft.public.win2000.group_policy (More info?)

All,

I am trying to deploy an application (MSI) via a GPO to workstation. The
source path is located on a cluster share (Windows 2003 Clustering) that is
accessible by Authenticated Users group.

When the workstation boots it says its installing the application but does
not finish. I have turned on windows installer logging it shows error 1706
(Source is invalid due to missing/inaccessible package).

When I deploy the software from a non-clustered server share or from a
workstation share, it works fine. Does anybody know why I can't deploy
software via a GPO, via Computer settings, when the source software resides
on a cluster?

Thanks in advance.

Shawn
May 11, 2005 3:45:35 PM

Archived from groups: microsoft.public.win2000.group_policy (More info?)

All,

Thought I would post the answer I got on cluster newsgroup for this
issue...this may help somebody...someday

Shawn
----------------------

Mike,

This is what I was missing...configured Kerberos Authentication option on
Cluster Group, moved software to cluster share, pushed out GPO for software
deployment pointing to MSI application on cluster...worked first time...no
errors what so ever.

Thanks so much for solution.

Shawn

--------------------

"Mike Rosado [MSFT]" <mikeros@online.microsoft.com> wrote in message
news:HGotf%23wUFHA.2184@TK2MSFTNGXA01.phx.gbl...
> Hi Shawn,
>
> For computer assigned packages to work properly, they need to be stored on
> a fileserver that supports Kerberos authentication. This is because the
> computer's machine account is used for authentication, and this requires
> Kerberos. Users can access files using both Kerberos and NTLM.
>
> So make sure that the Network Name resource in the group that has the File
> Share resource storing the MSI Package has the box checked on the
> Parameters tab for Kerberos Authentication option enabled.
>
> --------------------
> Hope this helps,
> Mike Rosado
> Windows 2000 MCSE + MCDBA
> Microsoft Enterprise Platform Support
> Windows NT/2000/2003 Cluster Technologies
>
> ====================================================
> When responding to posts, please "Reply to Group" via your newsreader so
> that others may learn and benefit from your issue.
> ====================================================
"shawn" <shawnl@ecar.org> wrote in message
news:o akwQOXUFHA.2128@TK2MSFTNGP14.phx.gbl...
> All,
>
> I am trying to deploy an application (MSI) via a GPO to workstation. The
> source path is located on a cluster share (Windows 2003 Clustering) that
> is accessible by Authenticated Users group.
>
> When the workstation boots it says its installing the application but does
> not finish. I have turned on windows installer logging it shows error
> 1706 (Source is invalid due to missing/inaccessible package).
>
> When I deploy the software from a non-clustered server share or from a
> workstation share, it works fine. Does anybody know why I can't deploy
> software via a GPO, via Computer settings, when the source software
> resides on a cluster?
>
> Thanks in advance.
>
> Shawn
>
!