Sign in with
Sign up | Sign in
Your question

Numlock Key Disabled PLEASE HELP

Tags:
Last response: in Windows 2000/NT
Share
Anonymous
September 15, 2005 12:35:10 PM

Archived from groups: microsoft.public.win2000.group_policy (More info?)

Hello All. I am working on a Windows 2000 PC. Only when a certain user logs
in the Numlock key doesn't work. It can't be a hardware problem because I've
tried switching out the keyboard and that has no effect. Also, with the
numlock key off the arrows and functions on the number keys on the keypad
work. It's just that when the numlock key is on, nothing appears when you
type a number when logged on as this user. When I log in as myself the
number keypad and numlock key function normally. Even when I boot into safe
mode with the affected user's login the numlock key still doesn't work for
him. I rooted around in the registry and Under HKEY_CURRENT_USER and
HKEY_LOCAL_MACHINE and I could not find anything under Control Panel,
Keyboard that seemed out of place. I also looked under the Local Computer
Policy in the MMC. Does anyone know of a registry setting that could disable
the numlock key for a certain user, or can anyone think of any other
configuration setting to check??? Thanks!
--
Regards,
Adrienne

More about : numlock key disabled

September 16, 2005 9:06:11 PM

Archived from groups: microsoft.public.win2000.group_policy (More info?)

Hi,

Try looking at this reg key:

HKCU\Control Panel\Keyboard
"InitialKeyboardIndicators" ="2"

Setting this key to "0" will disable the numlock key for the current user.
Seeting it to "2" should enable it and force it to preserve the state it was
in from the previous logon.

Hope this works for you!

Bill


"Adrienne" <Adrienne@discussions.microsoft.com> wrote in message
news:468E9498-A82E-4B19-97C0-1F10105234C8@microsoft.com...
> Hello All. I am working on a Windows 2000 PC. Only when a certain user
> logs
> in the Numlock key doesn't work. It can't be a hardware problem because
> I've
> tried switching out the keyboard and that has no effect. Also, with the
> numlock key off the arrows and functions on the number keys on the keypad
> work. It's just that when the numlock key is on, nothing appears when you
> type a number when logged on as this user. When I log in as myself the
> number keypad and numlock key function normally. Even when I boot into
> safe
> mode with the affected user's login the numlock key still doesn't work for
> him. I rooted around in the registry and Under HKEY_CURRENT_USER and
> HKEY_LOCAL_MACHINE and I could not find anything under Control Panel,
> Keyboard that seemed out of place. I also looked under the Local
> Computer
> Policy in the MMC. Does anyone know of a registry setting that could
> disable
> the numlock key for a certain user, or can anyone think of any other
> configuration setting to check??? Thanks!
> --
> Regards,
> Adrienne
Anonymous
September 16, 2005 9:06:12 PM

Archived from groups: microsoft.public.win2000.group_policy (More info?)

Thank you for replying Bill. I actually already checked that particular
registry value. It was correctly set at 2 already. : ( But thank you
anyway!
--
Regards,
Adrienne


"user" wrote:

> Hi,
>
> Try looking at this reg key:
>
> HKCU\Control Panel\Keyboard
> "InitialKeyboardIndicators" ="2"
>
> Setting this key to "0" will disable the numlock key for the current user.
> Seeting it to "2" should enable it and force it to preserve the state it was
> in from the previous logon.
>
> Hope this works for you!
>
> Bill
>
>
> "Adrienne" <Adrienne@discussions.microsoft.com> wrote in message
> news:468E9498-A82E-4B19-97C0-1F10105234C8@microsoft.com...
> > Hello All. I am working on a Windows 2000 PC. Only when a certain user
> > logs
> > in the Numlock key doesn't work. It can't be a hardware problem because
> > I've
> > tried switching out the keyboard and that has no effect. Also, with the
> > numlock key off the arrows and functions on the number keys on the keypad
> > work. It's just that when the numlock key is on, nothing appears when you
> > type a number when logged on as this user. When I log in as myself the
> > number keypad and numlock key function normally. Even when I boot into
> > safe
> > mode with the affected user's login the numlock key still doesn't work for
> > him. I rooted around in the registry and Under HKEY_CURRENT_USER and
> > HKEY_LOCAL_MACHINE and I could not find anything under Control Panel,
> > Keyboard that seemed out of place. I also looked under the Local
> > Computer
> > Policy in the MMC. Does anyone know of a registry setting that could
> > disable
> > the numlock key for a certain user, or can anyone think of any other
> > configuration setting to check??? Thanks!
> > --
> > Regards,
> > Adrienne
>
>
>
Related resources
March 24, 2006 9:58:25 PM

The mousekeys has been turned on.

To deactivate:

Go to Control Panel
Open Accessibility Options
Click on Mouse Tab
Uncheck "use MouseKeys"
May 27, 2010 8:37:24 PM

OK. That was genius!
!