Cannot access https Websites

Archived from groups: microsoft.public.windowsxp.basics (More info?)

I cannot access Websites that are "https" (not the usual "http:") type.
On one such https site, I got a message saying "The Page cannot be
displayed". On another site, an error box pops up to say "The connection
to that site is
refused"

I think it has to do with my IE browser settings, which is set at the
recommended Medium Level. But whether it is set to Low, Medium or High,
the problem persists

My PC is a DELL Pentium IV 1.2GB, 256 Rmb, 40gb Hard Disk, runs Win XP. The
Win XP's Firewall settings are OFF.

Please advise. Thank you and Happy Chinese New Year to you.
2 answers Last reply
More about cannot access https websites
  1. Archived from groups: microsoft.public.windowsxp.basics (More info?)

    "Jimmy Hsu" <hotjava@singnet.com.sg> wrote:

    >I cannot access Websites that are "https" (not the usual "http:") type.

    See "How to Troubleshoot Possible Causes of Internet Connection
    Problems" (http://support.microsoft.com/?kbid=314095) and "How to
    troubleshoot problems accessing secure Web pages with Internet
    Explorer 6 Service Pack 2"
    (http://support.microsoft.com/?kbid=870700).

    --
    (tm)
  2. Archived from groups: microsoft.public.windowsxp.basics (More info?)

    Jimmy Hsu wrote:
    > I cannot access Websites that are "https" (not the usual "http:") type.
    > On one such https site, I got a message saying "The Page cannot be
    > displayed". On another site, an error box pops up to say "The connection
    > to that site is
    > refused"
    >
    > I think it has to do with my IE browser settings, which is set at the
    > recommended Medium Level. But whether it is set to Low, Medium or High,
    > the problem persists
    >
    > My PC is a DELL Pentium IV 1.2GB, 256 Rmb, 40gb Hard Disk, runs Win XP. The
    > Win XP's Firewall settings are OFF.
    >
    > Please advise. Thank you and Happy Chinese New Year to you.
    >
    >
    >
    I doubt if this is the problem, but open IE go to Help > About IE
    and make sure it says Cipher Strength: 128 bits
    If not you need to upgrade IE.

    gls858
Ask a new question

Read More

Windows XP