Windows 2K server permissions/ Excel .tmp files

Archived from groups: microsoft.public.win2000.security (More info?)

I'm attempting to restrict a file share's security so
that a group of users can modify/save existing .xls
documents, but not delete them.

By setting the directory's security disallow delete, this
works. The problem is, when a user modifies/saves
the .xls file, a .tmp file is created also, and is not
deleted. Does anyone know of a workaround for not
allowing a user to delete files in this directory without
a buildup of .tmp files. The autorecover option in .xls
has no effect on this.
1 answer Last reply
More about windows server permissions excel files
  1. Archived from groups: microsoft.public.win2000.security (More info?)

    You might try to configure a Scheduled Task with admin credentials or use the AT
    command to delete the .tmp files at scheduled time or at startup/shutdown when it is
    not likely users are using the folder. I don't know of any other work around if users
    are sharing a common folder as they would then be able to delete other users files.
    You may look at giving creator owner delete permissions to the folder which would
    allow the owner of the file to delete it but I am not sure if that would work in your
    situation depending on how ownership is assigned after a user modifies a file, but
    you could test it out.--- Steve


    "Fitspire" <anonymous@discussions.microsoft.com> wrote in message
    news:24d6901c46051$98bbabb0$a601280a@phx.gbl...
    > I'm attempting to restrict a file share's security so
    > that a group of users can modify/save existing .xls
    > documents, but not delete them.
    >
    > By setting the directory's security disallow delete, this
    > works. The problem is, when a user modifies/saves
    > the .xls file, a .tmp file is created also, and is not
    > deleted. Does anyone know of a workaround for not
    > allowing a user to delete files in this directory without
    > a buildup of .tmp files. The autorecover option in .xls
    > has no effect on this.
Ask a new question

Read More

Security Permissions Windows