Sign in with
Sign up | Sign in
Your question

no power AHH! brand new PC and the PSU LED wont even light

Tags:
  • Power Supplies
  • LED Monitor
  • Components
Last response: in Components
Share
February 9, 2007 5:15:20 AM

I ordered all these parts from newegg, put em all in the case (Antec P-180(pain in the ass case)) and the PSU wouldnt power. Not even the LED on the PSU lit up. I have NO IDEA how to figure this out. PLEASE HELP i dont know where to start checking

system:
-mushkin 550200 ATX12V 550W Power Supply
-AMD Athlon 64 X2 4600+ Windsor 2.4GHz Socket AM2 Processor
-GIGABYTE GA-M59SLI-S5 Socket AM2 NVIDIA nForce 590 SLI
-CORSAIR XMS2 2GB (2 x 1GB) 240-Pin DDR2 SDRAM DDR2 800
-Western Digital Caviar SE16 250GB 7200 RPM SATA 3.0Gb/s Hard Drive
-Western Digital Caviar SE 80 gig

More about : power ahh brand psu led wont light

February 9, 2007 9:04:38 AM

You've plugged both the 24 pin and 4 pin aux cable into the motherboard right ?

Make sure nothings shorting.
February 9, 2007 5:12:21 PM

yeah i did all that. i tried just hooking up the core stuff (ram, video, cpu) and nothing... when i wiggled the front panel connectors, the psu makes a short, soft, almost inaudible noise but nothing happens, and when i switch the psu back off the lights dim very lightly for a brief second. i'm going to try take the mobo out of the case incase its grounding out or something but if there's any other suggestions, please let me know.
Related resources
February 9, 2007 5:15:11 PM

also, i screwed the psu's ground wire under one of the screws that holds the mobo in place. is that correct?
February 9, 2007 6:02:49 PM

thank you very much, i'll try that. i'm not gonna get zapped with the paperclip?
February 9, 2007 7:57:48 PM

OK so i shorted the power switch connector with a small screwdriver and the power supply turned on along with the 2 fans i left connected. I turned it back off and then reconnected the front panel power switch and turned the psu on again and nothing. We're getting somewhere! now i just dont know where to go from here.
February 9, 2007 8:16:59 PM

IT WORKS!! i love you guys. i dont know exactly what fixed it. i'm assuming the ground wire attached to the mobo was the culprit. everything seems to be fine, now i just update bios and all that good stuff. THANKS AGAIN!
!