Sign in with
Sign up | Sign in
Your question

Help! New Router but Thunderbird won't connect!

Last response: in Networking
Share
October 12, 2006 1:17:18 PM

Hey everyone. I just got a new Linksys WRT54GS (not sure which version) to replace my old D-Link DI-614+ (which I think I killed through massive amounts of torrenting).

I hooked it up and got the wireless going. My laptop seemed to pick up the connection fine, however, my desktop equiped with a D-Link wireless card couldn't pick up the signal. I looked around some FAQs and found out that I could enable MS's Wireless Zero Connection and it would work. I did so and the card picked up the connection. Happy times.

Here's my problem. Whenever I try to use an e-mail program like Outlook or Thunderbird and send something it gives me an error saying that it can't connect to the SMTP server. I tried forwarding the ports, changing to different ports and forwarding those, and fooling around with my account settings but nothing worked. I know it has something to do with my card because it works fine on my laptop.

I was wondering if anyone could help me out. I'm thinking it has something to do with the wireless zero configuration, but what would I know since I'm a pure novice when it comes to these things. Thanks for any help you can give me.
October 12, 2006 8:25:59 PM

Do you have any kind of host based firewall (i.e. windows firewall, symantec client security, etc) running? with the new router your probably getting a different ip address (dlink iirc is 192.168.2.0/24 and linksys is 192.168.1.0/24) so if you are running a host based firewall you may need to allow 192.168.2.0/24 as a trusted network.

if your not using a host based firewall ignore this!
October 12, 2006 8:30:56 PM

That was my immediate thought as well... sounds like a firewall is misbehaving. Try (temporarily at least) turning off all firewall functions and see if your email will work.
Related resources
October 12, 2006 8:31:38 PM

That error message accours when it can't find the mail server. Your router should had no impact if it has internet access. Check you mail settings on your pc's. In particular port used and server.

If you did your original setup with the old router, its possiable that the MAC address is registerd with the old router's Mac. Try cloneing it into the new router and see what happens. If that is the case, contact your ISP and have it reset. Then remove the clone.
October 12, 2006 11:47:35 PM

First I'd like to say thanks for all the suggestions. Unfortunatly I've tried everything you have recommended. I removed everything resembling the Symantec name from this PC, I turned off windows firewall and turned off Zone Alarm. Didn't work. I tried cloning the MAC address from the PC hooked up to the router. Still didn't work. I set up static ips for each pc on my network and set up a DMZ, which I thought would be a sure thing, but yet it still doesn't work. I'm starting to get a bit discouraged. Is there anyway for my wireless card to pick up the network without using Wireless Zero Connection? If there's anything else you can think of, please let me know.
October 13, 2006 12:06:39 AM

Haha I just got it to work. The DMZ pulled through when I disabled the DHCP Server. I'm just wordering if I'm significantly more at risk right now now that all the ports are open. It's just like being hooked up directly to the modem, no? Zone Alarm should be enough, right?
October 13, 2006 12:25:48 AM

Working in a DMZ, you might as well throw the router away. You have no security.

Try blowing the router settings back to factory. Then set it backup. You have located the problem. For some reason the router is blocking port 110 or 587 on some servers.
October 13, 2006 12:56:01 AM

I reset the router and updated the firmware. I cloned the MAC address and forwarded port 110 and 25. Disabled the DMZ, enabled DCHP server. And...It Worked! I think it was the MAC address to begin with since that's the only thing that seemed to change before I set up the DMZ. All I had to do was set the ports back in my account settings to the defaults. Thanks a lot everyone! I learned a bunch about routers today *whew*.
October 13, 2006 5:00:35 PM

You forwarded the ports (110,25) on your router to your computers? Are you running a SMTP/POP3 mail SERVER on your computer?
!