Sign in with
Sign up | Sign in
Your question

Power Light and HDD Light

Last response: in Systems
Share
February 11, 2007 5:03:31 AM

Hi, I just recently got all my parts for my build and got everything up and running, There's just one problem, my power and hdd lights don't light up, well they do, but not when their supposed to. It's really weird, I'll tell you all what i observed.
If I turn my computer on just normally, the light are off before and after i turn it on. But one way i can get them to come on is if i turn off my power supply and turn it back on, the computer will be off but both the hdd light and power light will be lit. I'm pretty sure i hooked everything up right using the diagrams. Also would using 2 hdd's make it so the light doesn't work or would it not affect anything?
I have a Lian Li V1200 plus II, and an evga 680i mobo, Is it possible that the positives are on the negative and negatives on the positives, and should i try the inverse or could that be bad. Or maybe i got it all mixed up... I'm just so confused about something thats probably so simple. Any help would be greatly appreciated. Thanks.

More about : power light hdd light

February 11, 2007 6:36:26 AM

Quote:
Hi, I just recently got all my parts for my build and got everything up and running, There's just one problem, my power and hdd lights don't light up, well they do, but not when their supposed to. It's really weird, I'll tell you all what i observed.
If I turn my computer on just normally, the light are off before and after i turn it on. But one way i can get them to come on is if i turn off my power supply and turn it back on, the computer will be off but both the hdd light and power light will be lit. I'm pretty sure i hooked everything up right using the diagrams. Also would using 2 hdd's make it so the light doesn't work or would it not affect anything?
I have a Lian Li V1200 plus II, and an evga 680i mobo, Is it possible that the positives are on the negative and negatives on the positives, and should i try the inverse or could that be bad. Or maybe i got it all mixed up... I'm just so confused about something thats probably so simple. Any help would be greatly appreciated. Thanks.
Yeah, if you're sure, try reversing the +/-. If that isn't it, then they have to be on the wrong pins. And no, 2 drives won't cause HDD light to not work. GL :) 
February 11, 2007 2:36:00 PM

Congrats on encountering one of the many evga 680i issues. The locations of the power & hdd connectors are correct, except the manual is wrong about the + & -. Reverse each of the connector in their original locations.
Related resources
!