Sign in with
Sign up | Sign in
Your question

Permissions revert to full accesss to everyone

Last response: in Windows 2000/NT
Share
Anonymous
August 10, 2004 6:33:20 PM

Archived from groups: microsoft.public.win2000.security (More info?)

Hi,

I'm really stumped here and any help is greatly appriciated.

My d:\ drive has permissions like this:

administrator -> full access
everyone -> read, list, execute

I have a mounted drive under d:\ (say, d:\www\test). That folder is
permissioned as full control for everyone. I don't get it. I went up
the dir tree and can't find that permission anywhere. I have no idea
where it got it from. I go up a level to the folder with the correct
permissioning and tell it to reset permissions on children - it looks
like it's doing something - but it's doesn't do a thing.

What gives?
Anonymous
August 11, 2004 8:27:01 AM

Archived from groups: microsoft.public.win2000.security (More info?)

I don't know offhand why that happened but you can manually set permissions to what
you want for that drive. If it shows it has inherited permissions, then select
advanced and uncheck "inherit from parent... ". You will be prompted to remove or
copy current permissions. I suggest you select copy and then apply. You should now
have explicit permissions for that drive and you can configure them to your
eeds. --- Steve


"coolneo" <coolneo@yahoo.com> wrote in message
news:185c1582.0408101333.52d3a605@posting.google.com...
> Hi,
>
> I'm really stumped here and any help is greatly appriciated.
>
> My d:\ drive has permissions like this:
>
> administrator -> full access
> everyone -> read, list, execute
>
> I have a mounted drive under d:\ (say, d:\www\test). That folder is
> permissioned as full control for everyone. I don't get it. I went up
> the dir tree and can't find that permission anywhere. I have no idea
> where it got it from. I go up a level to the folder with the correct
> permissioning and tell it to reset permissions on children - it looks
> like it's doing something - but it's doesn't do a thing.
>
> What gives?
Anonymous
August 11, 2004 10:05:18 AM

Archived from groups: microsoft.public.win2000.security (More info?)

Thanks, the problem with this is that I have hundreds of folders like
this. It won't be pretty. Could it be that the mount point does not
inherit permissions from parents?

"Steven L Umbach" <n9rou@n0-spam-for-me-comcast.net> wrote in message news:<pehSc.283848$Oq2.236840@attbi_s52>...
> I don't know offhand why that happened but you can manually set permissions to what
> you want for that drive. If it shows it has inherited permissions, then select
> advanced and uncheck "inherit from parent... ". You will be prompted to remove or
> copy current permissions. I suggest you select copy and then apply. You should now
> have explicit permissions for that drive and you can configure them to your
> eeds. --- Steve
>
>
> "coolneo" <coolneo@yahoo.com> wrote in message
> news:185c1582.0408101333.52d3a605@posting.google.com...
> > Hi,
> >
> > I'm really stumped here and any help is greatly appriciated.
> >
> > My d:\ drive has permissions like this:
> >
> > administrator -> full access
> > everyone -> read, list, execute
> >
> > I have a mounted drive under d:\ (say, d:\www\test). That folder is
> > permissioned as full control for everyone. I don't get it. I went up
> > the dir tree and can't find that permission anywhere. I have no idea
> > where it got it from. I go up a level to the folder with the correct
> > permissioning and tell it to reset permissions on children - it looks
> > like it's doing something - but it's doesn't do a thing.
> >
> > What gives?
Related resources
Anonymous
August 11, 2004 11:01:23 AM

Archived from groups: microsoft.public.win2000.security (More info?)

Thanks, the problem with this is that I have hundreds of folders like
this. It won't be pretty. Could it be that the mount point does not
inherit permissions from parents?

"Steven L Umbach" <n9rou@n0-spam-for-me-comcast.net> wrote in message news:<pehSc.283848$Oq2.236840@attbi_s52>...
> I don't know offhand why that happened but you can manually set permissions to what
> you want for that drive. If it shows it has inherited permissions, then select
> advanced and uncheck "inherit from parent... ". You will be prompted to remove or
> copy current permissions. I suggest you select copy and then apply. You should now
> have explicit permissions for that drive and you can configure them to your
> eeds. --- Steve
>
>
> "coolneo" <coolneo@yahoo.com> wrote in message
> news:185c1582.0408101333.52d3a605@posting.google.com...
> > Hi,
> >
> > I'm really stumped here and any help is greatly appriciated.
> >
> > My d:\ drive has permissions like this:
> >
> > administrator -> full access
> > everyone -> read, list, execute
> >
> > I have a mounted drive under d:\ (say, d:\www\test). That folder is
> > permissioned as full control for everyone. I don't get it. I went up
> > the dir tree and can't find that permission anywhere. I have no idea
> > where it got it from. I go up a level to the folder with the correct
> > permissioning and tell it to reset permissions on children - it looks
> > like it's doing something - but it's doesn't do a thing.
> >
> > What gives?
Anonymous
August 12, 2004 3:21:15 AM

Archived from groups: microsoft.public.win2000.security (More info?)

Hmm. I have not used mounted drives much. I wonder if they get their permissions from
the empty folder you mount them on. Since you have a lot of drives to set permissions
on you may want to look at using the command line utilities of cacls, xcacls, or
fileacl [free download]. For cacls or xcacls you can use the /e switch to modify
existing permissions or use just /g to replace current permissions and you can list
permissions for more than one group/user at a time. Fileacl is much more powerful if
you need to do advanced file configuration. --- Steve

http://support.microsoft.com/default.aspx?scid=kb;en-us;318754

"coolneo" <coolneo@yahoo.com> wrote in message
news:185c1582.0408110504.2b8a331c@posting.google.com...
> Thanks, the problem with this is that I have hundreds of folders like
> this. It won't be pretty. Could it be that the mount point does not
> inherit permissions from parents?
>
> "Steven L Umbach" <n9rou@n0-spam-for-me-comcast.net> wrote in message
news:<pehSc.283848$Oq2.236840@attbi_s52>...
> > I don't know offhand why that happened but you can manually set permissions to
what
> > you want for that drive. If it shows it has inherited permissions, then select
> > advanced and uncheck "inherit from parent... ". You will be prompted to remove or
> > copy current permissions. I suggest you select copy and then apply. You should
now
> > have explicit permissions for that drive and you can configure them to your
> > eeds. --- Steve
> >
> >
> > "coolneo" <coolneo@yahoo.com> wrote in message
> > news:185c1582.0408101333.52d3a605@posting.google.com...
> > > Hi,
> > >
> > > I'm really stumped here and any help is greatly appriciated.
> > >
> > > My d:\ drive has permissions like this:
> > >
> > > administrator -> full access
> > > everyone -> read, list, execute
> > >
> > > I have a mounted drive under d:\ (say, d:\www\test). That folder is
> > > permissioned as full control for everyone. I don't get it. I went up
> > > the dir tree and can't find that permission anywhere. I have no idea
> > > where it got it from. I go up a level to the folder with the correct
> > > permissioning and tell it to reset permissions on children - it looks
> > > like it's doing something - but it's doesn't do a thing.
> > >
> > > What gives?
Anonymous
August 12, 2004 11:13:15 AM

Archived from groups: microsoft.public.win2000.security (More info?)

There are two places to set permissions for mounted volumes (argh).
The first is in the obvious place - and that's where I have been
setting it. The second is under the "Advanced" option in the first
properties tab. So dopey.


"Steven L Umbach" <n9rou@n0-spam-for-me-comcast.net> wrote in message news:<LRxSc.290059$XM6.242025@attbi_s53>...
> Hmm. I have not used mounted drives much. I wonder if they get their permissions from
> the empty folder you mount them on. Since you have a lot of drives to set permissions
> on you may want to look at using the command line utilities of cacls, xcacls, or
> fileacl [free download]. For cacls or xcacls you can use the /e switch to modify
> existing permissions or use just /g to replace current permissions and you can list
> permissions for more than one group/user at a time. Fileacl is much more powerful if
> you need to do advanced file configuration. --- Steve
>
> http://support.microsoft.com/default.aspx?scid=kb;en-us;318754
>
> "coolneo" <coolneo@yahoo.com> wrote in message
> news:185c1582.0408110504.2b8a331c@posting.google.com...
> > Thanks, the problem with this is that I have hundreds of folders like
> > this. It won't be pretty. Could it be that the mount point does not
> > inherit permissions from parents?
> >
> > "Steven L Umbach" <n9rou@n0-spam-for-me-comcast.net> wrote in message
> news:<pehSc.283848$Oq2.236840@attbi_s52>...
> > > I don't know offhand why that happened but you can manually set permissions to
> what
> > > you want for that drive. If it shows it has inherited permissions, then select
> > > advanced and uncheck "inherit from parent... ". You will be prompted to remove or
> > > copy current permissions. I suggest you select copy and then apply. You should
> now
> > > have explicit permissions for that drive and you can configure them to your
> > > eeds. --- Steve
> > >
> > >
> > > "coolneo" <coolneo@yahoo.com> wrote in message
> > > news:185c1582.0408101333.52d3a605@posting.google.com...
> > > > Hi,
> > > >
> > > > I'm really stumped here and any help is greatly appriciated.
> > > >
> > > > My d:\ drive has permissions like this:
> > > >
> > > > administrator -> full access
> > > > everyone -> read, list, execute
> > > >
> > > > I have a mounted drive under d:\ (say, d:\www\test). That folder is
> > > > permissioned as full control for everyone. I don't get it. I went up
> > > > the dir tree and can't find that permission anywhere. I have no idea
> > > > where it got it from. I go up a level to the folder with the correct
> > > > permissioning and tell it to reset permissions on children - it looks
> > > > like it's doing something - but it's doesn't do a thing.
> > > >
> > > > What gives?
Anonymous
August 13, 2004 12:02:23 AM

Archived from groups: microsoft.public.win2000.security (More info?)

Glad you figured it out. We all complicate our own lives some days. As long as it is
not every day we should be fine. --- Steve

"coolneo" <coolneo@yahoo.com> wrote in message
news:185c1582.0408120613.7d2d2f6b@posting.google.com...
> There are two places to set permissions for mounted volumes (argh).
> The first is in the obvious place - and that's where I have been
> setting it. The second is under the "Advanced" option in the first
> properties tab. So dopey.
>
>
> "Steven L Umbach" <n9rou@n0-spam-for-me-comcast.net> wrote in message
news:<LRxSc.290059$XM6.242025@attbi_s53>...
> > Hmm. I have not used mounted drives much. I wonder if they get their permissions
from
> > the empty folder you mount them on. Since you have a lot of drives to set
permissions
> > on you may want to look at using the command line utilities of cacls, xcacls, or
> > fileacl [free download]. For cacls or xcacls you can use the /e switch to modify
> > existing permissions or use just /g to replace current permissions and you can
list
> > permissions for more than one group/user at a time. Fileacl is much more powerful
if
> > you need to do advanced file configuration. --- Steve
> >
> > http://support.microsoft.com/default.aspx?scid=kb;en-us;318754
> >
> > "coolneo" <coolneo@yahoo.com> wrote in message
> > news:185c1582.0408110504.2b8a331c@posting.google.com...
> > > Thanks, the problem with this is that I have hundreds of folders like
> > > this. It won't be pretty. Could it be that the mount point does not
> > > inherit permissions from parents?
> > >
> > > "Steven L Umbach" <n9rou@n0-spam-for-me-comcast.net> wrote in message
> > news:<pehSc.283848$Oq2.236840@attbi_s52>...
> > > > I don't know offhand why that happened but you can manually set permissions
to
> > what
> > > > you want for that drive. If it shows it has inherited permissions, then
select
> > > > advanced and uncheck "inherit from parent... ". You will be prompted to
remove or
> > > > copy current permissions. I suggest you select copy and then apply. You
should
> > now
> > > > have explicit permissions for that drive and you can configure them to your
> > > > eeds. --- Steve
> > > >
> > > >
> > > > "coolneo" <coolneo@yahoo.com> wrote in message
> > > > news:185c1582.0408101333.52d3a605@posting.google.com...
> > > > > Hi,
> > > > >
> > > > > I'm really stumped here and any help is greatly appriciated.
> > > > >
> > > > > My d:\ drive has permissions like this:
> > > > >
> > > > > administrator -> full access
> > > > > everyone -> read, list, execute
> > > > >
> > > > > I have a mounted drive under d:\ (say, d:\www\test). That folder is
> > > > > permissioned as full control for everyone. I don't get it. I went up
> > > > > the dir tree and can't find that permission anywhere. I have no idea
> > > > > where it got it from. I go up a level to the folder with the correct
> > > > > permissioning and tell it to reset permissions on children - it looks
> > > > > like it's doing something - but it's doesn't do a thing.
> > > > >
> > > > > What gives?
!