Sign in with
Sign up | Sign in
Your question

DYNDNS address not working

Last response: in Networking
Share
October 17, 2006 5:07:21 PM

Hello there,

I am trying to set up file sharing between two of my computers (one at work, the other at home). I have a dynamic IP address assigned from my ISP. Also my computer is behind a netgear router. Port forwarding is enabled (80 and 411). I have tried to set up an account at dyndns.com but I don't think it is working properly. When I check their web site, it is displaying the correct external IP address for my router. But I cannot ping the router or communicate with it from any outside computer. I have two questions:

1) How can I test my dns name to see if it is funtioning or not?
2) How can I troubleshoot this to identify exactly what my problem is?

many thanks!

More about : dyndns address working

October 18, 2006 12:46:58 AM

1. Do you have ping enabled for the wan port on your router? Some routers default to not allow ping.

2. You say you are port forwarding port 80. To which public port? To test, you will need to point your browser to http://<your dyndns domain>:<public port #>.

3. If DynDns is correctly showing the IP address on your router's wan port then DynDns is working properly.
October 19, 2006 5:40:36 PM

Hey, thanks a lot for your help! I followed your recomendations but I am still not able to connect or ping (or get any response) from my DynDns. Here is what is going on:

1) Ping was not enabled on the wan port on my router. I enabled it.

2) I tried checking my domain with:

http://<your dyndns domain>:<public port #>.

the request timed out. I am not really sure what you mean by "which public port". I am still trying to figure this stuff out...any direction would be appreciated.

3) DynDns is showing the correct IP address, I guess that means the problem is on my end. What could be holding me up?

Thanks! :D 
Related resources
October 19, 2006 7:09:10 PM

1. Ok, so now you can ping your domain?

2. Public ports are ports that are open on the WAN (internet) side of your router. Private ports are ports open on the LAN (your network) side. Some ISP's block port 80. If they do and you are running a web server, you will need to port forward. For example, you can port forward public port 8080 to private port 80. Then you should be able to go to http://<your_domain>:8080 to get to your web site.
October 20, 2006 3:50:28 PM

1) It looks like I can ping my domain :)  and my DynDns account is reporting the correct IP address.

2) I am still having a hard time connecting to my hub. I receive a message that "the connection was activley refused". I think this might mean that my ISP (Verizon DSL) may be blocking the public port.

I tried the site canyouseeme.org to find out what ports are open/closed.

It looks like a lot of my public ports are blocked. On ports 80, 411, 467, 468 etc... the site times out waiting for a response. Once on port 80 I recieved a message "the connection was activley refused ..." but I could not replicate this message, on second attempt it just timed out.

In the program DC++ I also recieve the "activley refused message..."

I tried using a higher port number (40000), I forwarded that port on my router and canyouseeme.org reported success in connecting to that port. I am not sure how to forward a public port to a private port on my router though (I will be looking at portforward.com for the answer)

I can now ping my public IP address or DynDns name and recieve a reply. Also, I know that my isp is not blocking port 40000. What should I do next to attain connectivity?
October 23, 2006 4:06:17 PM

Quote:
2) I am still having a hard time connecting to my hub. I receive a message that "the connection was activley refused". I think this might mean that my ISP (Verizon DSL) may be blocking the public port.


Hub? Unless the hub is manageable, you can't connect to it.

Quote:
I tried the site canyouseeme.org to find out what ports are open/closed.

It looks like a lot of my public ports are blocked. On ports 80, 411, 467, 468 etc... the site times out waiting for a response. Once on port 80 I recieved a message "the connection was activley refused ..." but I could not replicate this message, on second attempt it just timed out.

In the program DC++ I also recieve the "activley refused message..."

I tried using a higher port number (40000), I forwarded that port on my router and canyouseeme.org reported success in connecting to that port. I am not sure how to forward a public port to a private port on my router though (I will be looking at portforward.com for the answer)

I can now ping my public IP address or DynDns name and recieve a reply. Also, I know that my isp is not blocking port 40000. What should I do next to attain connectivity?


You have only opened port 40000, you have not forwarded it. Forwarding is slightly different in each router. Consult your router manual for port forwarding. It's sometimes listed as a virtual server. For a web server it should be set to TCP, private port 80, public port 40000. Now when you connect to port 40000 from the internet (not local network), you should see your web server.
October 23, 2006 4:35:50 PM

sorry if I'm unclear...i am still trying to figure some things out.

My goal is to be able to share large files between my two computers (office and home) using DC++. I want the office computer to host a private hub that only I have access to. I am using YnHub for this. I got the hub up and running (i think) but was unable to connect from my home computer using DC++. After a little poking around (google...) I decided that the problem was most likely the DynDns name not getting me to my machine and/or my router or isp not letting in any external traffic. Does this seem like the cause of the problem to you?

I did access the settings for port 40000 under the menu option "port forwarding" (sounds right to me).

What is the best (or easiest) way to test my setup (I want to see if DynDns forwards requests to my public address which in turn is forwarded through my router to my local machine)?

Thanks for your help!
October 24, 2006 1:42:30 AM

If you have turned on wan ping on your router (which you said you did) and you can ping <your domain> from work, then DynDns is working fine.

From portforward.com:
Choose a port for DC++ to run on, and enter it into the Port box. If you want to use the standard default port enter 1412 into that box. This is the port you will have to forward to run DC++, so remember it. You need to forward the TCP and UDP protocols of the port you chose in your router.

Your ISP should not be blocking port 1412, so try setting up DC++ with the default ports. You need to make sure your router has port 1412 open for both TCP and UDP protocols. Also, if you are running a firewall, you'll need to make sure these ports are open on the firewall too.

At work, set up your DC++ client to use <your domain> as the host/server with port 1412 (default).

More info here: linky

Thats about all the help I can give you. Your router manual should be able to get you thru the rest. Good luck.
October 25, 2006 1:10:03 AM

I currently have a DSL connection with 1.5mbit down, and 384kbit up. I am currently running a server with XP Pro, Apache 2.0.53, and Cerberus FTP Server. I am behind a Linksys wireless router, which I have port forwarding external port 80 to 80 inside to the internal IP inside my network. I am also routing port 21 for FTP. I am also using dyndns.org to update my dynamic IP address. I am running DirectUpdate to push the IP update. Your setup seems to be about right, it may be your ISP blocking port 80. Luckily, my ISP doesn't care. Have had this setup for about 1 1/2 years and its been rock solid.

Here is my web page hosted from my server:
http://amdgamingrig.dyndns.org

If all you want to do is transfer files, I would reccomend just setting up an FTP server. I run Cerberus FTP server which is freeware and works great. Very easy to use. You can require logins which map to folders on your computer. Also has the ability to ban IP's.
!