EFS Encrypted File Prompt/warning

Archived from groups: microsoft.public.win2000.security (More info?)

Hello,
I'm trying to find a way to stop "Encyrpted File" prompts from being
displayed.

Symptoms:
XP Pro client copies an encrypted file to a network share, they get a prompt
"The file 'blah.txt' cannot be copied or moved without losing its
encryption. You can to choose to ignore this error and continue, or cancel"

Ideal result:
No prompt, just ignore by default.

Reasons:
I use a little application to copy users "My Documents" to a network share.
We do not want to have encrypted data on our server - to make restore
operations easier - so I have disabled the NTFSEncryptedFilesystem, via the
registry, on all our file share servers. (delete the value
NTFSEncryptedFilesystem on the servers)
Experience has shown using roaming profiles is not the best way to backup
users data, nor Offline files (i.e. redirected My Documents)
This by itself works well until you start using EFS.

Thanks,
andyr
1 answer Last reply
More about encrypted file prompt warning
  1. Archived from groups: microsoft.public.win2000.security (More info?)

    I believe you can use the XCOPY /G command to avoid this prompt. If you use
    the GUI/UI, this is a security feature to prevent users from accidentally
    decrypting their files.

    --


    David B. Cross [MS]

    --
    This posting is provided "AS IS" with no warranties, and confers no rights.

    http://support.microsoft.com

    "pipex Newsgroups" <andyr111@hotmail.com> wrote in message
    news:10jopjbbfj5ks81@corp.supernews.com...
    > Hello,
    > I'm trying to find a way to stop "Encyrpted File" prompts from being
    > displayed.
    >
    > Symptoms:
    > XP Pro client copies an encrypted file to a network share, they get a
    > prompt
    > "The file 'blah.txt' cannot be copied or moved without losing its
    > encryption. You can to choose to ignore this error and continue, or
    > cancel"
    >
    > Ideal result:
    > No prompt, just ignore by default.
    >
    > Reasons:
    > I use a little application to copy users "My Documents" to a network
    > share.
    > We do not want to have encrypted data on our server - to make restore
    > operations easier - so I have disabled the NTFSEncryptedFilesystem, via
    > the
    > registry, on all our file share servers. (delete the value
    > NTFSEncryptedFilesystem on the servers)
    > Experience has shown using roaming profiles is not the best way to backup
    > users data, nor Offline files (i.e. redirected My Documents)
    > This by itself works well until you start using EFS.
    >
    > Thanks,
    > andyr
    >
Ask a new question

Read More

Windows