NTFS & Share permissions

Archived from groups: microsoft.public.win2000.security (More info?)

How do i prvent users from creating more fodlers on a network share but still
allow them to create files ??
I have tried modifying the registry as follows but with no luck.
"Navigate to HKEY_LOCAL_MACHINE\System\
CurrentControlSet\Services\LanmanServer\Shares.
Select Shares and all of the folder's subkeys.
Go to Security | Permissions.
For the Shares folder and each of its subkeys, grant the Read permissions
(at a maximum) to the Everyone group and all untrusted domains, and click OK."

please help !!!
4 answers Last reply
More about ntfs share permissions
  1. Archived from groups: microsoft.public.win2000.security (More info?)

    You should be able to do that with "special permissions" available in the
    advanced page of security. You would have to add the group twice - once for
    folder and then files only permissions in the "apply onto" box. Make sure
    they have the "create files" but not the "create folders" permissions in the
    permissions for the folder.--- Steve

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;308419 -- XP
    special permissions that applies to W2K also.

    "riddler" <riddler@discussions.microsoft.com> wrote in message
    news:F398BDCF-9F8D-4EC0-B0F0-30C12756181A@microsoft.com...
    > How do i prvent users from creating more fodlers on a network share but
    > still
    > allow them to create files ??
    > I have tried modifying the registry as follows but with no luck.
    > "Navigate to HKEY_LOCAL_MACHINE\System\
    > CurrentControlSet\Services\LanmanServer\Shares.
    > Select Shares and all of the folder's subkeys.
    > Go to Security | Permissions.
    > For the Shares folder and each of its subkeys, grant the Read permissions
    > (at a maximum) to the Everyone group and all untrusted domains, and click
    > OK."
    >
    > please help !!!
  2. Archived from groups: microsoft.public.win2000.security (More info?)

    Do u do this in the registry properties on on the folder itself as i cant
    seem to get it working from the registry...??
    I dont see the option you are speakign about..Once for folder and once for
    Files...

    "riddler" wrote:

    > How do i prvent users from creating more fodlers on a network share but still
    > allow them to create files ??
    > I have tried modifying the registry as follows but with no luck.
    > "Navigate to HKEY_LOCAL_MACHINE\System\
    > CurrentControlSet\Services\LanmanServer\Shares.
    > Select Shares and all of the folder's subkeys.
    > Go to Security | Permissions.
    > For the Shares folder and each of its subkeys, grant the Read permissions
    > (at a maximum) to the Everyone group and all untrusted domains, and click OK."
    >
    > please help !!!
  3. Archived from groups: microsoft.public.win2000.security (More info?)

    You do it by modifying the advanced permissions to the folder itself but you
    must be using ntfs file system. The link below explains advanced permissions
    more. --- Steve

    http://support.microsoft.com/default.aspx?scid=kb;EN-US;308419 -- almost
    all applies to W2K also.

    "riddler" <riddler@discussions.microsoft.com> wrote in message
    news:D8390E93-C981-44F2-ADDE-A828FD83E564@microsoft.com...
    > Do u do this in the registry properties on on the folder itself as i cant
    > seem to get it working from the registry...??
    > I dont see the option you are speakign about..Once for folder and once for
    > Files...
    >
    > "riddler" wrote:
    >
    >> How do i prvent users from creating more fodlers on a network share but
    >> still
    >> allow them to create files ??
    >> I have tried modifying the registry as follows but with no luck.
    >> "Navigate to HKEY_LOCAL_MACHINE\System\
    >> CurrentControlSet\Services\LanmanServer\Shares.
    >> Select Shares and all of the folder's subkeys.
    >> Go to Security | Permissions.
    >> For the Shares folder and each of its subkeys, grant the Read permissions
    >> (at a maximum) to the Everyone group and all untrusted domains, and click
    >> OK."
    >>
    >> please help !!!
  4. Archived from groups: microsoft.public.win2000.security (More info?)

    I will give it a try .Thanks a million..

    "Steven L Umbach" wrote:

    > You do it by modifying the advanced permissions to the folder itself but you
    > must be using ntfs file system. The link below explains advanced permissions
    > more. --- Steve
    >
    > http://support.microsoft.com/default.aspx?scid=kb;EN-US;308419 -- almost
    > all applies to W2K also.
    >
    > "riddler" <riddler@discussions.microsoft.com> wrote in message
    > news:D8390E93-C981-44F2-ADDE-A828FD83E564@microsoft.com...
    > > Do u do this in the registry properties on on the folder itself as i cant
    > > seem to get it working from the registry...??
    > > I dont see the option you are speakign about..Once for folder and once for
    > > Files...
    > >
    > > "riddler" wrote:
    > >
    > >> How do i prvent users from creating more fodlers on a network share but
    > >> still
    > >> allow them to create files ??
    > >> I have tried modifying the registry as follows but with no luck.
    > >> "Navigate to HKEY_LOCAL_MACHINE\System\
    > >> CurrentControlSet\Services\LanmanServer\Shares.
    > >> Select Shares and all of the folder's subkeys.
    > >> Go to Security | Permissions.
    > >> For the Shares folder and each of its subkeys, grant the Read permissions
    > >> (at a maximum) to the Everyone group and all untrusted domains, and click
    > >> OK."
    > >>
    > >> please help !!!
    >
    >
    >
Ask a new question

Read More

Security Permissions Windows