Sign in with
Sign up | Sign in
Your question

The Four Horsemen, Gremlins and my computer problems. Help!

Last response: in Systems
Share
February 16, 2007 5:41:18 PM

If computer problems were funny, I would be dead with a smile on my face.

Well... here we go. Never could trust myself around technology...

Something is wrong with my memory. Or my mobo. Or both. You guys (or gals) tell me. I'll write down everything that happened prior to the problems.

Built it myself... a beautiful budget gamer. Antec Sonata 2 case with Antec SP 450 PSU, Biostar TForce4 U 775 Mobo, Pentium D 805, E-geforce 7600 gt, 2x 512 of 667 Vitesta RAM, Western Digital 250 Gig HD as well as an external 250...

Alas, too many variables. Something was bound to go wrong, I suppose.

I am turning off my comp when my computer informs me that I had yet to install the latest updates from Microsoft. I shrug, and I turn it off anyway. As it is doing so, it began to install the updates before it turns off. A new feature I supposed. I crawled into bed as it was still installing the first of 20 updates it told me it had to do. I figured it would finish, my comp would turn off, and everything would be fine in the morning.

I woke up next morning to find my computer still on. I turn on the screen, and I see that it is still installing the first update. It never got to the rest. A trifle alarmed, I turn it off manually. I turn my comp, and I receive a weird message once windows is fully running for a minute or so.

"Generic Host Process for Win 32 has encountered a problem etc..."

I am a bit puzzled by this, and I try my best to ignore my slowly mounting anxiety. I blame it on what happened this morning, and console myself that a reboot is all that is necessary. Before did so, I then tried to listen to some songs on itunes. It gave me a weird message... something about my computer config not not necessarily allowing itunes to function, though it still may. I try to listen to music anyway, and nothing will play. I try to use Winamp, and it tells me

"Bad DirectSound Driver. Please install proper drivers or select another device in configuration. Error code 88780078"
I am not sure I want to know what will happen if I try to play a game...

I decide that I needed to restart the computer. Immediately.

I restart, and it doesn't POST

This is where I start sweating. I repeat "Don't Panic" like a mantra, the only thing I remember from the Hitchhiker's Guide. I open my comp, and look inside as I restart. I notice that my Western Digital Mybook external HD doesn't turn on (it's supposed to... that's one of the features, it turns on with the computer) keyboard lights turn on, my mouse turns on, everything inside the case is running. As I sit before the empty black hole that is my screen, I notice that my DVD drive is thinking. I don't know whether that is important or not.

I turn it off and look at memory. I wasn't gonna start taking off parts and putting them back on etc. I'm wasn't computer savvy enough to know which parts to do first etc.

But I knew how dangerous a bad memory stick could be. I knew of someone who's bad DIMM's caused him many, many problems. I figured, "why not?", and I took out a DIMM. It POSTed. I feel elated. Yay! I fixed it all by my lonesome! As Windows starts, however, I discover that my problems are far from over.

Windows informs me that my copy of Windows needs to be re-activated, on account of massive hardware changes, or something to that effect. I think to myself, "That ain't right. Something like this should happen if I get a different processor, or mobo. Not simply taking out a DIMM!." Then, as Windows finally stops setting up, I get a funny error message.

"The instruction 0x745f2780 referenced memory at "0x00000000". The memory could not be "read". Click OK to terminate the program etc."

And then again "Generic Host Process for Win 32 has encountered a problem..."

I try to play music, and the same error message.

As I am reading the old error message again, my taskbar reverts to the Win95 version, then back to XP. Takes just over a second to happen. Oh, happy days.

I put the DIMM that wouldn't let me POST in all of my four slots. No good, still can't POST. I put my "good" DIMM in all of my slots. Works every time. I take the bad memory stick and put it aside for later. I believe I left it in the toolbox last... the hammer, I mean.

I ask someone I know online what to do. He tells me that I should try booting with no RAM. I try to, and the mobo starts wailing at me. Big wails. No POSTing but loud screaming. I'll bet if I had a sound card, it would be swearing at me. I look in my mobo manual, and it tells me that it wails like that when there is no DRAM detected. Now, I don't know if this is normal or not. He told me that it should be able to post by itself without the memory. Maybe my mobo doesn't let itself POST without any mem... I have no friggin clue.

As I sit before my comp, I review my options. I could...

A)Razor
B)Pills and a lot of alcohol
C)Find a gun... where would I?
D)Post this situation on Tom's Hardware and hope to the the Holy Mother, Father, Allah, Buddha, and Wiccan god(desses) of your choosing that they could help me. And so here I am. I am confident that someone here will know what to do... Please help, and thanks in advance for it. (and reading the long post)

PS - If you guys (or gals) can't help me, I'm gonna go with B.
February 16, 2007 6:00:32 PM

OK where to start. First and foremost your friend lied..you system will not post without RAM hence the screeming which is normal.

1. First I would put back in both ram sticks. Make sure your comp is not plugged in and pull the CMOS battery (looks like an oversized watch battery) After about a minute put the battery back in. Plug in your system and see if it boots. If it does skip to step 2. If not pull the one possible bad DIMM out and move to step 2.

2. Chances are that your windows Operating system has become corrupted due to you trying to shut down while trying to update windows. I have seen this with people messing with there comps while installing Service pack 2. In the bios make sure you have your boot sequence set with the CDrom drive being your first boot device and make sure you have your windows cd in the tray. Boot using your windows cd. You should then have the options of repairing windows or doing a fresh install. First try repair and see if that fixes your windows errors. If not go to step 3.

3. If you still receive the errors after the repair you will have to suck it up and do a full reinstall of windows. Boot through the cd again. Delete your current windows partition and reinstall windows on the freshly created partition. This should fix your windows issues.

As for your ram if it wont boot even after the mobo reset you probably have a bad DIMM which would be very back luck/timing since in my experience there is no correlation to the two problems.

*Edit- On second thought yeah I guess there could be a correlation if your ram crapped out while updating windows which caused your system to lock up while windows is doing its thing. However windows could not kill your ram from screwing up an update.
February 16, 2007 6:18:19 PM

It sounds like one of the sticks of ram is bad. But definately try pulling the CMOS battery to reset things.

Running windows with a bad stick of ram will quickly (and sometimes permanently) break windows. You'll probably need to reinstall.

I've even had bad ram make it so a corrupted harddrive cannot be put into any other windows machine (that can recognize NTFS formatted drives) without causing the computer to blue-screen. Thank goodness for linux being able to read NTFS.

I don't necessarily link the windows shutdown thing with the issues you are having (unless the bad ram caused the problem).
Related resources
February 16, 2007 6:30:06 PM

Hey, Im sorry about the last suggestion about the POSTing with no RAM. I

You know the guy above's suggestion about windows repair/reinstall reminds me of a wonderful story. Ah, it is too sad to recall though.

Quote:
As for your ram if it wont boot even after the mobo reset you probably have a bad DIMM which would be very back luck/timing since in my experience there is no correlation to the two problems.


Thats what I said after my PC fried my keyboard and mouse at the same time as failing to load 3dMark06. My 2.5yr old Dell XPS died 4 days later when my PSU finally comitted suicide, taking out my hard drive and motherboard in the process. Before it died though, I did do a repair reinstall and ran into issues updating: I had to hard-shutdown as well in the middle of SP2.

If you all would like to read of my misery just click on this link:http://forumz.tomshardware.com/hardware/Memtest-Errors-...

Good Luck bob on figuring out your issues. You should feel lucky that you are able to get free replacements for all of your parts, unlike someone else I know. So calm down and try to isolate the issue.
I would do a repair/reinstall of WinXP but dont connect to the internet to update. I downloaded this app that will patch WinXP from a CD. It should be safer than connecting to the dark and dangerous internet. I'll give you the CD on sunday. provided you come to school.

good night and good luck to all
February 16, 2007 7:34:16 PM

Well Rodney, I did what the page told me to do, and now part of my problem is gone. I don't get errors when trying to use media anymore. Thank you very much.

If I could send thanks in the form of lipo-suction fat, I would be 50 pounds skinnier, and you would have a mysterious bag at your front door tommorow morning. Thanks again!

As for the rest of the problem... I've never really removed the CMOS battery... is there some sort of procedure I should follow? Am I even allowed to ask this here?
February 16, 2007 7:45:08 PM

they are relatively a pain in the butt to get out Usually it involves having 3 hands (jking) Its usually just held in by plastic numbs. Pushing one of them back while trying to pull the edge up on that side of the battery usually does the trick.
February 16, 2007 8:14:49 PM

Well Gemini, I removed the CMOS battery, stuck in the stick, and it still wouldn't boot. I think this means (don't rush me now)... the stick is bad!

Yippee! I still have a warranty on it I believe... but the hammer option would be more amusing...

I did the thing on the the page Rodney sent me and the Windows issues (That directsound driver issue, the Generic Host Process issue, the memory 0x0000... issue) seem to have gone away... It doesn't look like there are any problems... can't be sure though. You think i should repair/reinstall just to be sure? I would really prefer not to... Though there is that whole Windows activation thingy that now tells me I've got three days to activate... so I guess there still is a problem...

At least the worst is over. Praise The Holy Mother, Father, Buddha, Allah... and thanks Gemini
February 17, 2007 10:12:35 PM

Well that sounds great bob, Im happy for you that you fixed those update issues. What you should do to make sure that your PC is running fine is to boot up a couple times as well as try out a bunch of apps. Doing this should weed out any issues that you may have.

An important point: Any apps that you ran while the bad stick was in could be corrupted. No one knows how long it was out for, could have been minutes; could have been days.

So just try out a great variety of apps (inc. 3dMark05+06 :lol:  )and run some Orthos tonite. Youre overcoming of this horrible issue has given me new hope that someday I might be able to touch the insides of a PC again.
February 17, 2007 10:14:19 PM

No problem man. I have a printout of that article on my bulletin board at work... from time to time I'll see that same problem and that's always worked for me (for now!)

Glad to help.
!