Sign in with
Sign up | Sign in
Your question

File sharing permissions

Last response: in Windows XP
Share
March 5, 2005 1:12:11 AM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

I posted this before, but apart form one question, no-one came up with
any suggestions. Does this mean it's an intractable problem? If it
is, if someone could tell me that, I'll give up trying to sort it :-)

I've just been trying to connect a new laptop to a LAN. Both
machines use XP and the LAN works fine.

I used the wizard to set up the LAN. It wasn't entirely
straightforward, but I cracked it eventually! The main problem
seemed to be getting the main desktop machine in the right workgroup -
I had to start again and create a new workgroup because the two
machines each defaulted to a different one.

I have a problem sharing the folder C/Documents & Settings/Debbie/..
and subfolders, including My Docs

I can't set my "My Docs" folder to allow file sharing. When I right
click and open the tab for file sharing, the network sharing &
security option is greyed out and neither box is checked. The local
sharing and security box is also greyed out, but there is a check in
"Make this folder private"

It says in the box that "The options in this tab are disabled because
this folder is in another folder that is private"

If I click on the "another folder", it takes me to the "Debbie" folder
in Documents and Settings.

On the sharing tab for this, the Local sharing is greyed and there is
a check in "Make this folder private"

Network sharing shows only the top box greyed out, but the "Share this
folder" box is checked. The lower box (Allow network users to change
files) is checked and can be unchecked - but if I alter it, then click
"apply", it warns me that "making this folder private will make its
subfolders unavailable on the network". So I click cancel, and it
actions the lower network sharing box change the next time I open the
tab. This seems to suggest that the folder is a bit confused as to
whether it is private or not, and I wonder if this is where the
problem is. The troubleshoot isn't helping at all :-(

The docs and settings folder is shared and works properly - I can see
it from the laptop and open it.

There must be something wrong, or I'm doing something very stupid.
I've never set any of these folders to "private". Everything else on
the network is fine.

Both machines run xp home



Any ideas, anyone?

Thanks in advance.

--
Debbie posting as Debbie
Anonymous
March 5, 2005 1:12:12 AM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

Hi,

The user profile folders cannot be shared in that manner. If you want other
systems to access certain files, place them in the shared documents folder
which can readily be shared on the network.

--
Best of Luck,

Rick Rogers, aka "Nutcase" - Microsoft MVP
http://mvp.support.microsoft.com/
Associate Expert - WindowsXP Expert Zone
www.microsoft.com/windowsxp/expertzone
Windows help - www.rickrogers.org

"Debbie" <debbie@removethisgeekesse.co.uk> wrote in message
news:65nh21lv1rg0sktvt05lviolf1gu8teoc5@4ax.com...
>I posted this before, but apart form one question, no-one came up with
> any suggestions. Does this mean it's an intractable problem? If it
> is, if someone could tell me that, I'll give up trying to sort it :-)
>
> I've just been trying to connect a new laptop to a LAN. Both
> machines use XP and the LAN works fine.
>
> I used the wizard to set up the LAN. It wasn't entirely
> straightforward, but I cracked it eventually! The main problem
> seemed to be getting the main desktop machine in the right workgroup -
> I had to start again and create a new workgroup because the two
> machines each defaulted to a different one.
>
> I have a problem sharing the folder C/Documents & Settings/Debbie/..
> and subfolders, including My Docs
>
> I can't set my "My Docs" folder to allow file sharing. When I right
> click and open the tab for file sharing, the network sharing &
> security option is greyed out and neither box is checked. The local
> sharing and security box is also greyed out, but there is a check in
> "Make this folder private"
>
> It says in the box that "The options in this tab are disabled because
> this folder is in another folder that is private"
>
> If I click on the "another folder", it takes me to the "Debbie" folder
> in Documents and Settings.
>
> On the sharing tab for this, the Local sharing is greyed and there is
> a check in "Make this folder private"
>
> Network sharing shows only the top box greyed out, but the "Share this
> folder" box is checked. The lower box (Allow network users to change
> files) is checked and can be unchecked - but if I alter it, then click
> "apply", it warns me that "making this folder private will make its
> subfolders unavailable on the network". So I click cancel, and it
> actions the lower network sharing box change the next time I open the
> tab. This seems to suggest that the folder is a bit confused as to
> whether it is private or not, and I wonder if this is where the
> problem is. The troubleshoot isn't helping at all :-(
>
> The docs and settings folder is shared and works properly - I can see
> it from the laptop and open it.
>
> There must be something wrong, or I'm doing something very stupid.
> I've never set any of these folders to "private". Everything else on
> the network is fine.
>
> Both machines run xp home
>
>
>
> Any ideas, anyone?
>
> Thanks in advance.
>
> --
> Debbie posting as Debbie
Anonymous
March 5, 2005 1:12:12 AM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

A minor note: You are using forward slashes in your path in your posting
('/'). These should be back slashes ('\'). We understand you, but if you
used them that way when trying to set up your shares, it would fail.

--
Colin Barnhorst [MVP Windows - Virtual Machine]
(Reply to the group only unless otherwise requested)
"Debbie" <debbie@removethisgeekesse.co.uk> wrote in message
news:65nh21lv1rg0sktvt05lviolf1gu8teoc5@4ax.com...
>I posted this before, but apart form one question, no-one came up with
> any suggestions. Does this mean it's an intractable problem? If it
> is, if someone could tell me that, I'll give up trying to sort it :-)
>
> I've just been trying to connect a new laptop to a LAN. Both
> machines use XP and the LAN works fine.
>
> I used the wizard to set up the LAN. It wasn't entirely
> straightforward, but I cracked it eventually! The main problem
> seemed to be getting the main desktop machine in the right workgroup -
> I had to start again and create a new workgroup because the two
> machines each defaulted to a different one.
>
> I have a problem sharing the folder C/Documents & Settings/Debbie/..
> and subfolders, including My Docs
>
> I can't set my "My Docs" folder to allow file sharing. When I right
> click and open the tab for file sharing, the network sharing &
> security option is greyed out and neither box is checked. The local
> sharing and security box is also greyed out, but there is a check in
> "Make this folder private"
>
> It says in the box that "The options in this tab are disabled because
> this folder is in another folder that is private"
>
> If I click on the "another folder", it takes me to the "Debbie" folder
> in Documents and Settings.
>
> On the sharing tab for this, the Local sharing is greyed and there is
> a check in "Make this folder private"
>
> Network sharing shows only the top box greyed out, but the "Share this
> folder" box is checked. The lower box (Allow network users to change
> files) is checked and can be unchecked - but if I alter it, then click
> "apply", it warns me that "making this folder private will make its
> subfolders unavailable on the network". So I click cancel, and it
> actions the lower network sharing box change the next time I open the
> tab. This seems to suggest that the folder is a bit confused as to
> whether it is private or not, and I wonder if this is where the
> problem is. The troubleshoot isn't helping at all :-(
>
> The docs and settings folder is shared and works properly - I can see
> it from the laptop and open it.
>
> There must be something wrong, or I'm doing something very stupid.
> I've never set any of these folders to "private". Everything else on
> the network is fine.
>
> Both machines run xp home
>
>
>
> Any ideas, anyone?
>
> Thanks in advance.
>
> --
> Debbie posting as Debbie
Related resources
March 5, 2005 3:39:13 AM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

On Fri, 4 Mar 2005 17:44:02 -0500, "Rick \"Nutcase\" Rogers"
<rick@mvps.org> wrote:

>Hi,
>
>The user profile folders cannot be shared in that manner. If you want other
>systems to access certain files, place them in the shared documents folder
>which can readily be shared on the network.

But I *can* view other users' My Documents folders. It's only one
that I can't sort out - and it's my own My Documents folder, which is
the one I could most use :-)


--
Debbie posting as Debbie
March 5, 2005 3:40:21 AM

Archived from groups: microsoft.public.windowsxp.basics (More info?)

On Fri, 4 Mar 2005 17:01:23 -0700, "Colin Barnhorst"
<colinbarharst(nojunk)@msn.com> wrote:

>A minor note: You are using forward slashes in your path in your posting
>('/'). These should be back slashes ('\'). We understand you, but if you
>used them that way when trying to set up your shares, it would fail.

Sorry, yes, too much time webbing. The fingers work faster than the
brain sometimes. The path is properly set with back slashes
everywhere except on Usenet :-)



--
Debbie posting as Debbie
!