Sign in with
Sign up | Sign in
Your question

allowing the asp.net account to access a share

Last response: in Windows 2000/NT
Share
Anonymous
a b 8 Security
March 17, 2005 7:36:03 PM

Archived from groups: microsoft.public.win2000.security (More info?)

Hello

I have a project where I need to display graphic files housed on another
computer.
I access these files using a UNC address.

The machine is a windows 2000 server SP 4 with all critical updates.

My asp.net app, tells me it can't find the file in the share.
I know the file is there, so it must be a security issue.

I have tried to add ANONYMOUS and NETWORK to the share and ntfs permissions.
Still no go.

I enabled the guest account and added that account to the share and ntfs
permissons.

Am I thinking incorrectly when I think that allowing anonynous access to
this one share would allow IUSR_webserver access to the files contained in
the share ?
If not, then how can I get the server to allow this access ?

Thank you for your time and assistance.
Jon
Anonymous
a b 8 Security
March 18, 2005 7:47:49 PM

Archived from groups: microsoft.public.win2000.security (More info?)

I solved this problem by using some in code impersonation, before trying to
access the network resource.

"Jon Delano" <jd31068@hotmail.com> wrote in message
news:o P6dnV57SsGgZaTfRVn-jw@comcast.com...
> Hello
>
> I have a project where I need to display graphic files housed on another
> computer.
> I access these files using a UNC address.
>
> The machine is a windows 2000 server SP 4 with all critical updates.
>
> My asp.net app, tells me it can't find the file in the share.
> I know the file is there, so it must be a security issue.
>
> I have tried to add ANONYMOUS and NETWORK to the share and ntfs
> permissions.
> Still no go.
>
> I enabled the guest account and added that account to the share and ntfs
> permissons.
>
> Am I thinking incorrectly when I think that allowing anonynous access to
> this one share would allow IUSR_webserver access to the files contained in
> the share ?
> If not, then how can I get the server to allow this access ?
>
> Thank you for your time and assistance.
> Jon
>
!