Sign in with
Sign up | Sign in
Your question

Users cannot access certain files!!!

Last response: in Windows 2000/NT
Share
Anonymous
a b 8 Security
March 18, 2005 7:29:01 PM

Archived from groups: microsoft.public.win2000.security (More info?)

A user was explicitley denied access to a specific folder. A warning message
appeared saying that this action could have adverse affects. Now users cannot
access the files in this folder. Not even administrator. How can I fix this?

More about : users access files

Anonymous
a b 8 Security
March 18, 2005 9:59:01 PM

Archived from groups: microsoft.public.win2000.security (More info?)

Take the ownership of the files/folders, then give appropriate permissions to
users and administrator.

"HIVOLTG" wrote:

> A user was explicitley denied access to a specific folder. A warning message
> appeared saying that this action could have adverse affects. Now users cannot
> access the files in this folder. Not even administrator. How can I fix this?
Anonymous
a b 8 Security
March 19, 2005 12:56:31 AM

Archived from groups: microsoft.public.win2000.security (More info?)

An administrator can always take ownership of a folder and then grant
himself permissions if need be. The link below explains this more. -- Steve

http://support.microsoft.com/default.aspx?scid=kb;en-us;308421 --- works
the same for Windows 2000.

"HIVOLTG" <HIVOLTG@discussions.microsoft.com> wrote in message
news:257A2FAA-8FDC-4879-A9DA-7D602FBACB36@microsoft.com...
>A user was explicitley denied access to a specific folder. A warning
>message
> appeared saying that this action could have adverse affects. Now users
> cannot
> access the files in this folder. Not even administrator. How can I fix
> this?
Related resources
Anonymous
a b 8 Security
March 19, 2005 2:09:44 AM

Archived from groups: microsoft.public.win2000.security (More info?)

Perhaps you set Deny for more than you have said,
maybe Users group (?) instead of "a user"
Remove the Deny to reverse this effect.
You may need to take ownership, but likely only
need to adjust the NTFS permissions (as it is already
owned).
Then, as a best practice, set Grant permissions that
allow what is needed, avoiding use of Deny unless
there is no alternative. Deny overrides any Grants,
so if you Deny a group and that group contains your
admin accounts, the admins will not have access.

--
Roger Abell
Microsoft MVP (Windows Security)
MCSE (W2k3,W2k,Nt4) MCDBA
"HIVOLTG" <HIVOLTG@discussions.microsoft.com> wrote in message
news:257A2FAA-8FDC-4879-A9DA-7D602FBACB36@microsoft.com...
> A user was explicitley denied access to a specific folder. A warning
message
> appeared saying that this action could have adverse affects. Now users
cannot
> access the files in this folder. Not even administrator. How can I fix
this?
Anonymous
a b 8 Security
March 20, 2005 12:29:04 PM

Archived from groups: microsoft.public.win2000.security (More info?)

Thanks guys. For some reason, I was finally able to take ownership and fix
the problem. From now on I will not use the Deny option. Have a great day.

"Roger Abell" wrote:

> Perhaps you set Deny for more than you have said,
> maybe Users group (?) instead of "a user"
> Remove the Deny to reverse this effect.
> You may need to take ownership, but likely only
> need to adjust the NTFS permissions (as it is already
> owned).
> Then, as a best practice, set Grant permissions that
> allow what is needed, avoiding use of Deny unless
> there is no alternative. Deny overrides any Grants,
> so if you Deny a group and that group contains your
> admin accounts, the admins will not have access.
>
> --
> Roger Abell
> Microsoft MVP (Windows Security)
> MCSE (W2k3,W2k,Nt4) MCDBA
> "HIVOLTG" <HIVOLTG@discussions.microsoft.com> wrote in message
> news:257A2FAA-8FDC-4879-A9DA-7D602FBACB36@microsoft.com...
> > A user was explicitley denied access to a specific folder. A warning
> message
> > appeared saying that this action could have adverse affects. Now users
> cannot
> > access the files in this folder. Not even administrator. How can I fix
> this?
>
>
>
!