Sign in with
Sign up | Sign in
Your question

Problem with PSU?..please help!

Last response: in Systems
Share
February 20, 2007 4:19:56 AM

So I built my system, installed cards, mobo, optical drives, hdd, etc.
Plugged it all in with an OCZ 700w PSU. Try to fire it up and nothing happens, no fans move in the PSU and no fans in the case. Just the blue led turns on. So I try to rewire a bit and try it again. Still nothing. CHecked over wiring a few more times and then decided to just try powering up one fan to see if that would work. I tried all the outputs on PSU that would connect to it and the fan still didnt move. Is there anything else I should try or should I assume its dead on arrival and RMA it?

More about : problem psu

February 20, 2007 10:41:08 AM

Whoa. My Galaxy did exact same thing. It wouldn't power up anything. The warning led was on, which could mean more than one thing. Tried every combo of wiring. Got it RMA'ed for free. The same dam thing was happening again as soon as I followed the manual to the letter. After a while I gave up. I plugged the modular cpu power cable in a different connector, bingo!

The psu is so intelligent that it decides to quit if it thinks a cable is plugged in a wrong place. I can replicate the same thing. If your psu is modular (I don't think so), check that the cpu power cable is plugged in correctly.

This just came to me. I left out one thing: I plugged a 4-pin molex (extra power for pci-e) in the mobo which isn't needed. This stopped the psu from powering on. As soon as I removed the molex, it powered on.
February 21, 2007 12:07:11 AM

K I'll try it. THanks!
February 21, 2007 2:30:59 AM

Okayy, so the fans work but when I plug everything back in nothing works. No fans or anything. Whats the next step? I'm suspecting it might be the motherboard?..I'm lost after that.
!