Sign in with
Sign up | Sign in
Your question

HIS X1650XT IceQ Turbo Problems!! HELP!!!

Last response: in Graphics & Displays
Share
February 20, 2007 1:32:56 PM

I recently purchased an HIS Radeon X1650XT IceQ Turbo Edition card. I'm an ATI fan and didn't want to buy a new PSU, so this was the right card for me. However, I'm running into some problems and need some help. This card is overclocked from the factory, the core is at 630MHZ vs. the standard 575MHZ and the memory is at 1460MHZ vs. the standard 1380MHZ. HIS boasts significant performance increase by having the card overclocked from the factory to the above specs. The problem I'm having is that in most games it works very well, I'm playing BF2142 on High setting at 1152x864 with no problems and smooth FPS. I play Vanguard as well and get 25-40 FPS on Balanced at 1280x1024 and I also play Marvel: Ultimate Alliance at 1280x1024, all settings maxed except Shadows are set to Low. It uses HDR and FSAA all at the same time and looks outstanding on most games, BUT...
...I can't play Star Wars Empire at War: Forces of Corruption. All of the above games will play for hours on end with no problems, but SW crashes the GPU from the main menu. Within just a minute of loading the game and seeing the menu screen, my whole screen artifacts and the ATI GPU Recovery kicks in. I know the overclock can cause this, but why would more graphic intensive games not crash even after 2-3 hours and this game crash within just a minute?
I've tried playing it in safe mode and it works ok, but still crashed after only about 30 minutes. Please help!

Don't laugh, I'm a budget gamer:
CPU: AMD Sempron 3000+
RAM: 1GB PC3200 DDR
SOUND: SBLive 24-bit
VIDEO: HIS X1650XT Turbo
HDD: 160GB UDMA

My case stays pretty cool, it's a little rigged but has a lot of airflow, never had any overheating issues before. Please help!
February 20, 2007 1:48:49 PM

Sounds like a driver issue, if it was a PSU issue it should have manifested in other games too.

But I've never had a problem with my Radeon playing Forces of Corruption so I'm not sure what to tell you...

I guess try the card on a friend's machine and see if it does the same thing. Also ask around on the Empire at War forums and see if this is a common problem.
February 20, 2007 4:28:57 PM

I've tried several different versions of the drivers, but to no avail. Nobody seems to know what the deal is on the EAW forums. Thanks for the tips, I'll keep checking back for any more input.

On a side, note, I've tried to use ATITool to clock the card back down to factory specs, but with no luck. Even underclocking the card causes a ATI VPU Recovery to kick in.
Related resources
February 20, 2007 4:58:59 PM

Strange. Are there any updates for the game itself. If not, contact Lucasarts (good luck but it's worth a shot) and see what they say.
February 22, 2007 9:24:50 PM

I'm updating my original post just to help anyone who may need it regarding this card.

I decided to try and underclock the card and it worked! It's a small nuissance, but so far only 1 of the 4 gams I currently play requires me to do that.

I did not clock the memory speed down at all, but I clocked the core speed from the OC'd 630MHZ to the standard X1650XT core speed of 575MHZ. It worked flawlessly in Star Wars Empire at War: Forces of Corruption.

Keep in mind this is the ONLY game I've had to underclock the card in, and it's well worth the performance boosts to keep the card kickin' and OC'd in all the other games.
!